Solved

Cisco 2621 Router-Sluggish traffic, flash memory.

Posted on 2006-07-01
16
584 Views
Last Modified: 2012-06-21
I can not get hold of my engineer who takes care of my programming side, my expetise is installation of  sites, towers, etc.  Here is one of my two problems: 1.)  My tech. says our cisco 2621 router is sluggish, traffic is slow.  People are griping.  We found virus and elimainated them on the access points.  Every thing was working fine, until this virus problem.  We have about 50 users on our system.  I have downloaded the cisco config program, looks like I can figure some of this out.  Why and how can I fix this problem?

    Problem 2:
 
    I wish I had known about this site before I got tinkering with a spare cisco 2621 router, I erased the flash memory.  Now (thanks to EE) I pretty sure I can install the fix, but I do not have a copy of it. (c2600-i-mz.122-34a.bin) I will be using hyperterminal.  Could anybody send me a copy? Email is: mst@kvnet.org  I gather once I get this image installed I can then download from the router that is acting up and install in this spare.  

Finally, I may not have a problem with the current router if you think it is programming mistake.  I'm just getting tired of the phone ringing with gripes about speed.  Please help ASAP

Many thanks,
w4ljm
0
Comment
Question by:W4LJM
  • 6
  • 5
  • 2
16 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
Comment Utility
As far as Problem 1, what is it that you want to do? Are you saying the router has a virus?

Problem 2: The only way to get a copy of the IOS is through Cisco. If you have a SmartNet maintenance contract, you can login to the download section at Cisco and download it. If you don't have a contract, you can contact them and explain your situation and they may help.

However, if you've already got another 2621, just copy the IOS off of that.

As for the speed issue, what type of connections do you have (T-1, 10 ethernet, etc.)? Can you post the config of your current router? (show run)
0
 

Author Comment

by:W4LJM
Comment Utility
Is it possible to have damage from a virus?  How can I tell?  We have access to a T3 and we are allowed 4megabyte of bandwith.  The main site is 30 miles away and we back haul with 5.8 ghz Tranzeo.  There it goes into router- bandwidth controller-back hauls-access points- client's home.  I will have to wait until tommorrow to get to the site.  It is about 45 road miles away.  I will use the config maker from cisco and download the program and post it here to look at.  You are saying I can upload this program, if it is ok, into the spare, even with the erased image, it will take the programming with no problem?  I'm very green with this.  I just started this system up two months ago and a young tech who has a lot to learn and a owner who can follow instructions.  Help is appreciated.  Any thing else you and others can think of that I need to get or do is truly welcomed.  
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
To my knowledge, there are no viruses that can infect the IOS. If someone is telling you your performance problems are due to a virus, it would HAVE to be the host devices that are infected.

I've never used Config Maker. I do everything from the command line so I really can't speak to what can be done or how to do it using Config Maker. What I meant to say was that it is possible to copy the IOS from one router to another.
0
 
LVL 3

Assisted Solution

by:axiomtechnologies
axiomtechnologies earned 250 total points
Comment Utility
Another path you can investigate regarding performance problems on that link is a layer 2 problem. I operate a large WISP network and I have yet to find a piece of radio hardware that plays nice with Cisco on ethernet. Badly negotiated ethernet connections and duplex problems between the Cisco and your Tranzeo can cause sluggish performance and generally crappy throughput. If you call Tranzeo they'll tell you without hesitation that their radio's don't autonegotiate properly with Cisco ethernet. Same story with most other radio gear I've worked with.

A couple things to check and try:

Never use autonegotiate on the ethernet port. Manually set the Tranzeo (or other radio) to whatever you have for a physical port on the Cisco...generally 10HDX or 100FDX. Don't try to use 10FDX...especially if you only have a 4Meg port anyway.

If you ~must~ connect your radio direct to the Cisco then that's pretty good advice. On my own network I've gone a step further and put a 10/100 switch between the Cisco and the radio's at each PoP. The Cisco and Tranzeo/Trango's..etc. are gleefully happy talking through the switch...in comparison to operating very clunkily when directly connected. Even a cheap $30 Linksys 10/100 will work. Additionally the switch gives me a physical test point at the link.

Good luck!

-Nelson
0
 

Author Comment

by:W4LJM
Comment Utility
Well, here is the latest.  I'm still at a snail's pace for speed.  I put in a Cisco 7206 router ( used), low speed, some people nothing.  The static IPs works fine, give some one one of these, he has speed, reg ips dished out, next to nothing.  I'm losing people, I'm ready to check into the crazy house, local guys say it should be working, can not talk to cisco unless you have deep pockets,  I at the point of giving up and getting the crying towel out.  I'm not a software guy, and the kid I have thinks he knows a lot more than he does and a good friend of mine whom is pretty knowledgeable in this stuff is somewhat stumped too.  Thats it.  All advice is appreciated and many thanks,
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Can you post the config for this router?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:W4LJM
Comment Utility

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mst
!
enable secret 5 $1$fWP.$ccRnXzFTzLyuQh54B6smT0
enable password mst1676
!
!
!
!
!
clock timezone EST -4
ip subnet-zero
ip cef
 --More--         no ip finger
ip name-server 12.10.53.2
ip name-server 12.127.16.68
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.20
ip dhcp excluded-address 192.168.1.21
ip dhcp excluded-address 192.168.1.22
ip dhcp excluded-address 192.168.1.23
ip dhcp excluded-address 192.168.1.24
ip dhcp excluded-address 192.168.1.25
ip dhcp excluded-address 192.168.1.26
ip dhcp excluded-address 192.168.1.27
ip dhcp excluded-address 192.168.1.28
ip dhcp excluded-address 192.168.1.29
ip dhcp excluded-address 192.168.1.30
ip dhcp excluded-address 192.168.1.32
ip dhcp excluded-address 192.168.1.33
ip dhcp excluded-address 192.168.1.34
ip dhcp excluded-address 192.168.1.35
ip dhcp excluded-address 192.168.1.36
ip dhcp excluded-address 192.168.1.37
 --More--         ip dhcp excluded-address 192.168.1.38
ip dhcp excluded-address 192.168.1.39
ip dhcp excluded-address 192.168.1.40
!
ip dhcp pool users1
   network 192.168.1.0 255.255.255.0
   dns-server 12.10.53.2 12.127.16.68
   default-router 192.168.1.1
!
!
!
!
interface FastEthernet0/0
 ip address 12.199.228.145 255.255.255.248 secondary
 ip address 192.168.1.1 255.255.255.0
 ip access-group 130 out
 ip nat inside
 duplex full
 
!
interface FastEthernet2/0
 ip address 12.154.118.73 255.255.255.192
 ip access-group 130 in
 --More--          ip nat outside
 duplex full

!
ip nat pool KVN 12.154.118.73 12.154.118.73 netmask 255.255.255.192
ip nat inside source list 1 pool KVN overload
ip nat outside source static 12.154.118.73 192.168.1.22
ip classless
ip route 0.0.0.0 0.0.0.0 12.154.118.65
no ip http server
!
access-list 1 permit 192.0.0.0 0.255.255.255

!
line con 0
 transport input none
line aux 0
line vty 0 4
 password (omitted)
 login
!
ntp clock-period 17180768
ntp server 130.207.244.240
ntp server 209.81.9.7
ntp server 192.5.41.209
end
 --More--         
mst#exit
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I don't see anything that jumps out which would cause the behavior you're describing. But just to be sure...

The performance problems only occur when the users get their IP address using DHCP from this router? When you use a static IP it works fine?

A couple items just to clean things up a bit:

instead of all those exclude statements use just one.

ip dhcp excluded-address 192.168.1.1 192.168.1.40

And instead of creating a NAT pool with only the IP address of the outside interface, do this instead:

ip nat inside source list 1 interface f2/0 overload

0
 

Author Comment

by:W4LJM
Comment Utility
That seems to me it.  When we use a static IP it seems to do fine.  I forward your recommendations to my friend.  We are just dead in the water.  We have checked the Netequalizer bandwith controler, in and out, reset the conf., seems to do fine, back haul from here to 27.5 miles shows -76 signal, will pass 54 mbs., goes into the Netequalizers, to the switches and to the 6 backhauls to the access points.  All Tranzeo.  We have tried the cisco 7206 router on both sides of the back haul, some get the internet, some do not, some slow, but we assigned a static ip to a customer for exper. and he gets great speed, works fine. That is it.  
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Well, I hate to say this... but it's not the router.

The router doesn't know (or care) how a device gets it's IP address. In this case, you've got two seperate operations going on in the same box. The router has an additional process running which allows it to act as a DHCP server. Once it recieves a DHCP request, instead of ignoring it, the router will now respond. After that, the whole issue of dynamic IP addressing vs. static becomes moot.

Can you describe your local topology?
0
 

Author Comment

by:W4LJM
Comment Utility
Local area is hilly.  We backhaul 6meg from a T3 orginating from a town about 21 miles away.  It goes from source to a 100' tower then to another tower  about 6miles away. The second tower, the backhaul antenna is 300' up and backhauled to my tower 16 miles away and the dish is 320' high.  From my tower we use a Andrew 3' dish(33db) and 200mw backhaul to a town that is 27.5 miles away.  This tower is 200' and has the same type of dish and power.  Signal shows -76, tested 54mbs transfer rate.  Perfect line of sight on all sights.  Local terain is semi-hilly, but we have great tower sites.  Line of sight programs show no problem here.  From the 200' site we hook into our router, bandwidth filter, switch, backhauls to various access points around the town and county.  Some as far away as 10 miles, others mostly 4 to 6 miles.  Access points are 2.4 to clients homes.  Some access points are as high as 300' sectorized, 200', 140', 100' all show great signal levels to clients and from the backhauls.  I just got a call and my young tech said some people are back up, but he had to turn off or disconnect 3 backhauls.  We have about 40-50 homes hooked up, 10 at the most on any access point, most of them around 5 to 8.  All sites have UPS, 12 port switches, 10/100 manageable, set to 100fdx as recommended.  All sites have been checked for channel interference and have been set to recommended spacing, we have no other systems in our town, we run a mixture of horz and vert. pol. And we do have one server at one of the sect. sites tied in.  That is about all I can think of.  I hope this is helpful.
Thanks.






a
0
 
LVL 3

Expert Comment

by:axiomtechnologies
Comment Utility
How about firmware on those radios? We went through some pretty strange behavior with early release software on our Tranzeo's last year.

Current versions are here: http://support.tranzeo.com/files.php?firmware

I've also seen issues with Tranzeo's ARP cacheing a default route and not dynamically updating it as the bridged netblock is altered. This is easy to check/remedy...a reboot of the Tranzeo after the netblock change would identify/clear this up. Usually that's on ad hoc bridges between clients though. Usually not an issue with their dedicated bridging products...but something else to check.

-Nelson
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I'm sorry. I should have expressed it differently...

What type of network topology do you have?

i.e.

Workstations --- 5500 Catalyst --- 7200 router ------ ISP
                    ^                       ^                      ^
                 10mbps             100mbps               T-3

I think you're going to end up with some type of local issue considering the symptoms.

-Don
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now