Solved

Problem connecting to Exchange over the internet through Outlook 2003. "You must connect to your Microsoft Exchange Server computer with the current profile before you can synchronize your folders"

Posted on 2006-07-01
32
516 Views
Last Modified: 2013-11-15
Exchange is running, sending and receiving email. I can access my mailbox via the web (EX: http://server.mydomain.com/exchange) The problem is I cannot get outlook setup and working.

I enabled RPC on the server and went through all the docs on setting it up. But when I try to open outlook I get the error:

"You must connect to your Microsoft Exchange Server computer with the current profile before you can synchronize your folders with your offline folder file."

The exchange server is not local and I have no way to connect local nor do the other users that will connect to this.

I am stuck I have been working on this for a little while now and I cannot figure it out.
0
Comment
Question by:Roginsky
  • 18
  • 10
  • +1
32 Comments
 
LVL 29

Expert Comment

by:mass2612
ID: 17025440
0
 

Author Comment

by:Roginsky
ID: 17025942
I have seen the last two and I followed all the steps. The first link says to open port 135. Which I just did. Now I get the error

"The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action."

0
 
LVL 104

Expert Comment

by:Sembee
ID: 17026364
You shouldn't need to open port 135.

You have said that the server is not local. Is there any way that you can get the an Outlook installation local to the Exchange server (but NOT on the Exchange server itself). You need to prove that the application is working correctly.
Failing that, can you get a VPN connection to the Exchange server so that you can make a regular connection to Exchange with Outlook first, then adjust it for RPC over HTTPS?

RPC over HTTPS is very sensitive - it either works or it doesn't. A single semi-colon in the wrong place will stop the feature from working.

Simon.
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 

Author Comment

by:Roginsky
ID: 17027300
I cannot get a PC on the same local network as Exchange. I am working on getting a VPN setup but I have other employees that will never have local access and that will not be able to make a VPN connection.

I am able to access Exchange via the web and my mail and whatnot works fine. I have been over the config quite a few times and I see nothiong wrong.
0
 

Author Comment

by:Roginsky
ID: 17027307
one thing other thing that didn't make since is when I try to browse http://server.mydomain.com/rpc I get a user name and password prompt that I can never login to.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17027904
Browsing to the /rpc virtual directory and getting a login failure is normal. You will get three failures and then an error message. That isn't an indication that the feature is not working though.

You have to be really careful when setting up an Outlook client that is outside of the network, as it will not actually connect unless you configure it in the correct order. I have outlined the procedure here: http://www.amset.info/exchange/rpc-http-client2.asp

Simon.
0
 

Author Comment

by:Roginsky
ID: 17028137
I followed all that but if NTLM Authentication is on it won't log in I have to have it set to basic. The check name works after that but then I get that error about "You must connect to Microsoft Exchange...."

0
 
LVL 104

Expert Comment

by:Sembee
ID: 17030355
When you have completed the setup process, do you restart Outlook, or attempt to go straight in to the application?
You must restart Outlook, so that the new connection process is used.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17032035
Outlook isn't running when I setup it up. If I try to start outlook and add the Exchange account it says I must go to control panel. So I shut outlook down goto control panel > mail then do it from there. Then start outlook. I also tried from my laptop and I get the same message. I am just lost.
0
 

Author Comment

by:Roginsky
ID: 17032775
I just went the server and brought my laptop. I am able to connect just fine. Just to let you know.

Also this is behind a firewall with ports 80, 443, 4900-5100, and 135 all open.

0
 
LVL 104

Expert Comment

by:Sembee
ID: 17032945
Are you sure that it connected over HTTPS with the laptop?
Did you use the RPCDIAG switch on Outlook to verify?

You don't need port 135, 4900-5100 or 80 open to use this feature. 135 is dangerous to have open to the Internet. You only need port 443 - nothing else.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17033024
With my laptop I am connected locally. In connection status it does not show HTTPS.

Now I connected to my laptop from the internet and not directly connected to the server and it will not connect.
0
 

Author Comment

by:Roginsky
ID: 17033874
When I goto Connection Status in outlook I see its trying to connect to HTTPS but then it says diconnected.

When I setup this machine I named the machine but then when I setup the domain I name it with the name.(Ex: server.server.mydomain.com)

I think is where my problem lies.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17033914
If it will not connect locally on https, then the feature isn't working.

What I usually suggest is the following.

1. Configure Outlook as you would if it was on the same LAN as the Exchange server.
2. ADD the RPC over HTTPS information. Don't change anything that you entered in to Outlook in the first step.

RPC over HTTPS is a connection method - nothing more. It doesn't change who the core of Outlook works - it adds to it.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17039958
I was not sure how it connected when it was local. I did not check. But I did have it set to use HTTPS all I did after I setup outlook from home is bring it to the server and I was able to connect. When I am not on the local network I get the message I posted afterwards.

"When I goto Connection Status in outlook I see its trying to connect to HTTPS but then it says diconnected. "

...

What I did is reloaded the server. I followed all the steps from Petri's website.
When I setup the domain I made it just the domain name without anything in front (EX:mydomain.com) my external DNS points to this server.

Now when I try to connect outside of my local network I get:
"The action could not be completed. The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action."
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17045957
Not having local or VPN access makes this so much more difficult - as you don't actually know if the feature is working or not - as there could be something getting in the way.

The messages you are getting are standard cannot connect messages - so they don't really help. There could be any number of reasons for the failure - certificate, registry settings, firewall etc.

If you browse to https://servername.domain.com/rpc (where servername.domain.com is the name on the certificate) do you get any certificate warnings? You should get a login prompt.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17046756
as of right now nothing happens when I browse there. It used to though I would get a certificate warning (which I had fixed at one point).

I just heard that Windows Server 2003 R2 (which is what I am using) has issues with Exchange. Should I reload and use the older version of Windows 2003?
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17046887
There are no issues with R2 version of Windows 2003. It is a supported OS for Exchange 2003.
If nothing is happening when you browse to that location then either the feature isn't setup, the certificate is wrong or you haven't opened the ports correctly.

You can't go any further forward until you can browse to that location.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17046936
ok good.

I will work on that... what is the best way to setup RPC ... what default ports does it use etc. I read you need to edit the registry to do this (per technet) and it messed something up so I un-did the settings.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17046984
RPC over HTTPS uses only one port - 443.
If it is a single server then there is a load of registry hacking to do. I have outlined what is required on my web site:
http://www.amset.info/exchange/rpc-http-server.asp

Simon.
0
 

Author Comment

by:Roginsky
ID: 17047192
thank you I will check that out.
0
 

Author Comment

by:Roginsky
ID: 17047802
Ok on the "Single Server Configuration" area do I need to open those ports on my router also?
0
 

Author Comment

by:Roginsky
ID: 17047959
I did as your instructions say and I can now go to https://server.mydomain.com/rpc. It asks for a username and password but mine nor admin work. if I hit escape then it says "You are not authorized to view this page" which I heard was normal.

So now I go to outlook and try to set it up but when I check "check name" I get the username box and I can never log in.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 17049359
The ports listed in the registry do NOT have to be opened on the firewall. ONLY port 443 is required.
The authentication failure is normal.

When setting up the client, the check name will fail if you attempt to do that before configuring the additional RPC over HTTPS settings. You have to go in to advanced settings and setup the additional settings.

Do not make the mistake of putting in the Exchange server's external name in to the Exchange server box. If the server is known as exch.domain.local on the LAN, but mail.domain.com for the SSL certificate, then you put exch.domain.local in to the first box with your username, then click on Advanced settings and enter the RPC over HTTPS settings.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17055310
Well I was able to connect... one of the problems was I was entering my username for outlook as domain\robert and that was not working I found an article saying you need to enter the username as name@mydomain.com this worked and I was able to sync.

One thing that stopped working is ActivePush to my cell phone. so I am looking into that. It was working before and so was OWA (which still works.)

Thank you for all the help.
0
 

Author Comment

by:Roginsky
ID: 17285353
RPC is still not working. I cannot connect.
0
 
LVL 39

Expert Comment

by:redseatechnologies
ID: 17285368
*still* not working?

>Well I was able to connect...

If that is incorrect, please post more information and with any luck Sembee will come back and respond.

-red
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17285812
Need more information.

"I cannot connect" is a little generic.

Simon.
0
 

Author Comment

by:Roginsky
ID: 17308250
Yes I know this. I was responding to Administrative Comment I have not been able to reply.

Everything connected and was working nothing changed on the server EXCEPT the certificate expired. I purchased the certificate and replaced it but I still cannot connect. I am at a loss again.
0
 

Author Comment

by:Roginsky
ID: 17308281
So now what happens is I open Outlook and it says "Trying to Connect" if I open the connection status window it saying "connecting" then after a little while it say "disconnected".
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Read this checklist to learn more about the 15 things you should never include in an email signature.
Viewers will learn how to use the Hootsuite Dashboard.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question