Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SETUP ROUTER AND VLANS COMMUNICATION

Posted on 2006-07-02
20
Medium Priority
?
337 Views
Last Modified: 2010-04-17
I am trying to setup this diagram, which can be found on www.virgoletta.com. I am trying to make both PC’s talk to each other through the router. Both PC’s are in different VLANS. I am having trouble setting this up can someone help me out with the configuration.

          Thank You,
         vreyesii
0
Comment
Question by:vreyesii
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
  • 4
20 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 1000 total points
ID: 17028610
Switch:

conf t
vlan 563

int fa0/7
switchport mode access
switchport access vlan 563
no shutdown

int fa0/(whatever PC 1 is plugged into)
switchport mode access
switchport access vlan 563
no shutdown

int fa0/12
switchport mode access
switchport access vlan 1
no shutdown

int fa0/(whatever PC 2 is plugged into)
switchport mode access
switchport access vlan 1
no shutdown

end
=========
Router

conf t

int e0/1
ip address 172.16.0.1 255.255.255.0
no shutdown

inte0/0
ip address 192.168.10.1 255.255.255.0
no shutdown

end
====================

Make sure PC 1 has a default gateway of 172.16.0.1
Make sure PC 2 has a default gateway of 192.168.10.1


0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 1000 total points
ID: 17033778
Just to add to Don's excellent comments above:
Make sure that the switchport connected to router E0/1 is also set for switchport access vlan 563

0
 

Author Comment

by:vreyesii
ID: 17034195
Ok I did the configuration however, PC1 is not able to ping PC2. But from PC1 I am able to ping the gateway of PC2 . Same goes for PC2. Each PC is able to ping there own gateway however they cannot ping each other. What am I doing wrong. Below is a copy of the switch config.

Thank You,
vreyesii


Building configuration...

Current configuration : 1314 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch
!
enable secret 5 $1$YDpL$4dUyXqovrwQCyrGp7a9xa0
enable password 7 055F1E5C740C1A114A50
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
vtp domain Gotham
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
vlan 1
 tb-vlan1 1002
 tb-vlan2 1003
!
vlan 563
!
vlan 1002
 tb-vlan1 1
 tb-vlan2 1003
!
vlan 1003
 tb-vlan1 1
 tb-vlan2 1002
 parent 1005
 backupcrf enable
!
vlan 1004
 bridge 1
 stp type ibm
!
vlan 1005
 bridge 1
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 563
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
 switchport access vlan 563
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface Vlan1
 ip address 192.168.10.3 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
 password 7 01471E570E4B52177219
 login
line vty 0 4
 password 7 03504358535B391F1B
 login
line vty 5 15
 password 7 03504358535B391F1B
 login
!
!
end

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 79

Expert Comment

by:lrmoore
ID: 17034228
Is the ip addressing in your diagram correct?
PC1 172.16.0.2
  Default gateway 172.16.0.1
PC1 connected to switchport 4 or 7
 Router Eth0/1 = 172.16.0.1
  routing is enabled on the router
  Router is connected wo switchport 4 or 7

PC2 192.168.0.2
  default gateway 192.168.0.1
PC1 connected to which switchport?
 Router Eth0/0  192.168.0.1
 Connected to which switchport?

Can you ping either PC from the router console?
Are both router interfaces UP/UP ?
0
 

Author Comment

by:vreyesii
ID: 17038719
On www.virgoletta.com I put up an updated version of how the network currently is. Both interfaces on the Router are up. However, the only PC from the router using the console port I can only ping PC2. I am not able to ping PC1.


Thank You,
vreyesii
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 17038741
Can you post the results of "show vlan brief" and "show int status" on the switch?
0
 

Author Comment

by:vreyesii
ID: 17038774
Here it is.
Thank You,
vreyesii

Switch#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/5
                                                Fa0/6, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
563  VLAN0563                         active    Fa0/4, Fa0/7
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Switch#
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 17038805
And you're saying that from the router you can ping PC2 but not PC1?

Can PC1 ping 172.16.0.1?
0
 

Author Comment

by:vreyesii
ID: 17038820
Yes that is what I am saying. From PC1 I tried pinging 172.16.0.1 and I was not able too.

Thank You,
vreyesii
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17038963
Can you post result from the router of "show ip int brief" ?
0
 

Author Comment

by:vreyesii
ID: 17038976
Here is the output for the Router.

New_York#sh ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
Ethernet0/0                192.168.10.1    YES manual up                    up

Serial0/0                  5.0.2.1         YES manual down                  down

Ethernet0/1                172.16.0.1      YES manual up                    up

New_York#
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17038992
And from the router console you cannot ping the pc 172.16.0.2 . . .
Is there any firewall software on that PC that could possibly be blocking ICMP?

This one's a head scratcher.....!!!
Are you sure the cables are good?
0
 

Author Comment

by:vreyesii
ID: 17039067
Ok I rebooted PC1 and now I able to ping 172.16.0.1 however PC1 cannot ping 192.168.10.2 which is PC 2 but PC1 can ping 192.168.10.1.

thank you,
vreyesii
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17039108
OK that looks like progress. Now post result of "C:\>route print"  from PC2
Any Firewall sofware on PC2?
0
 

Author Comment

by:vreyesii
ID: 17039196
I got it working. What I did was that I enabled routing on the New York router. Now from PC1 I am able to ping PC2 and vice versa. However, I thought I did not have to enable routing on the New York router?

thank you,
vreyesii
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17039349
Of course you have to enable routing any time you have different ip subnets on different interfaces and you want to route between them...
0
 

Author Comment

by:vreyesii
ID: 17039495
why didn't donjohnston in his configuration mention anything about that?

thank you,
vreyesii  
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17039531
Probably because routing is usually turned on by default and we don't normally think about it?

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 17039615
Unless you're running a VERY old IOS version, the only way ip routing could be disabled is if someone issued the command "no ip routing". We just assumed that it was enabled.
0
 

Author Comment

by:vreyesii
ID: 17039688
Alright, I understand. I have another question which I have open http://www.experts-exchange.com/Hardware/Routers/Q_21908136.html  is there anyway maybe you can take a look and help me out.


Thank You for all your help.
vreyesii
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question