Solved

Pinging a Cisco router interface from the Internet when this interface is not the route of last resort.

Posted on 2006-07-03
10
462 Views
Last Modified: 2012-08-14
   172.27.4.17/24-┐------SonicWall Content filter-----X.X.235.251  
                           │                                              
                           │
                           │    _________________
     172.27.4.1/24─└─│Int 0/0      int 3/1   │----------------X.X.235.253
    172.27.5.1/24--──│int4/0                    │
    172.27.6.1/24----─│int 4/1                   │
                               │________________│

DHCP (for users) set to Default gateway of 172.27.X.1

My problem is this: My 0.0.0.0 0.0.0.0 route listed in the router is set to 172.27.4.17, so that the SonicWall will filter Internet traffic to the users. Our VPN tunnels go out 3/1 so that the content filter doesn't have to handle the tunnel traffic. All works well except that I now need to ping  X.X.235.253 interface from the Internet. I cant because my 0.0.0.0 0.0.0.0 route is not set to X.X.235.254, my ISP's default gateway. I have static routes set for the individual Internet addresses for the far-end tunnel destinations, and those routes are set to the X.X.235.254 GW. I can't make my router 0.0.0.0 0.0.0.0 set to 254 because then my users won't get content filter. I cant make my users default gateway 4.17 becaust then my 5.0 and 6.0 users couldn't reach the Internet. Port re-direction for ICMP packets seems to be the answer but I can't seem to wrap my mind around the concept completely and I'm very rusty on ACL's. Could someone please provide me with some code?
Addl info:  My goal is to put an address of 172.27.4.25 on an Asterisk box and use port redirection to expose it to the Internet. Until I can ping the router port from the Internet, the port re-direction won't work either. I temporarily gateway'd my router to X.X.235.254, and all worked well on the Asterisk deal, but of course that leaves the SonicWall out of the picture.
0
Comment
Question by:n7okn
  • 5
  • 5
10 Comments
 
LVL 3

Author Comment

by:n7okn
Comment Utility
Oops my picture is completely unreadable. I will describe the pic.
Int. 0/0 is 172.27.4.3/24
Int 3/1 is X.X.235.253/29
Int 4/0 is 172.27.5.1/24
Int 4/1 is 172.27.6.1/24
SonicWall LAN is 172.27.4.17/24 (same network as cisco int 0/0)
SonicWall outside is X.X.235.251/29

0
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
Still difficult :-) Can you redraw your diagram?

Cheers,
Rajesh
0
 
LVL 3

Author Comment

by:n7okn
Comment Utility
Sure. Here is the link
http://qso.com/john/cisco.jpg
It's hand drawn, as I don't have visio on my home computer.
0
 
LVL 3

Author Comment

by:n7okn
Comment Utility
The lines in the image appear broken and pixelated on my screen, but crystal clear when printed on a laser printer.
0
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
No Problem, took me 10 minutes to understand it :-) Well, your network needs a major redesign.

Coming back to the problem, you need to do policy routing and not port-forwarding. In the Cisco router, you need to set the default gateway as 4.17 (Internal sonicwall address) for all the traffic except for icmp, the default gateway should be the .254 (ISP gateway).

We should be able to do that, but once done, all the ping requests from inside also won't be seen by sonicwall (All ICMP work would be directly done through the router, whether incoming or outgoing).

Can you post your router config here ?

Cheers,
Rajesh


0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 3

Author Comment

by:n7okn
Comment Utility
Sure, here it is. I've posted everythign of relivance, if there's some more info you need, please don't hesitate to ask.


version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname DHQMain

ip name-server 172.27.4.29
ip name-server 172.27.4.21
ip dhcp excluded-address 172.27.6.1 172.27.6.50
!
ip dhcp pool 2
   network 172.27.5.0 255.255.255.0
   dns-server 172.27.4.29 172.27.4.21
   netbios-name-server 172.27.4.29
 
   default-router 172.27.5.1
!
ip dhcp pool 3
   network 172.27.6.0 255.255.255.0
   dns-server 172.27.4.29 172.27.4.21
   netbios-name-server 172.27.4.29
 
   default-router 172.27.6.1
!!
interface Loopback0
 ip address 172.200.10.1 255.255.255.255
!
interface Loopback1
 no ip address
!
interface Loopback10
 ip address 10.0.0.200 255.255.255.0
!
interface Tunnel0
 description DHQ <--> Las Vegas, NV Admin
 ip address 192.168.11.1 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel1
 description DHQ <--> Maryvale, AZ
 ip address 192.168.11.5 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination

!
interface Tunnel2
 description DHQ <--> Tempe
 ip address 192.168.11.9 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel3
 description DHQ <--> Glendale
 ip address 192.168.11.13 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel4
 description DHQ <--> Lake Havasu City AZ
 ip address 192.168.11.17 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel5
 description DHQ <--> Chandler AZ
 ip address 192.168.11.21 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel6
 description DHQ <--> Flagstaff AZ
 ip address 192.168.11.25 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel7
 description DHQ <--> Farmington NM
 ip address 192.168.11.29 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel8
 description DHQ <--> Bullhead City, AZ
 ip address 192.168.10.5 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel9
 description DHQ <--> Roswell NM
 ip address 192.168.10.13 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel10
 description DHQ <--> Mesa Corp
 ip address 192.168.10.21 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel11
 description DHQ <--> Laura
 ip address 192.168.10.25 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination

interface Tunnel12
 description DHQ <--> Phoenix
 ip address 192.168.10.29 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel13
 description DHQ <--> Albuquerque Corp
 ip address 192.168.10.33 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel14
 description DHQ <--> Albuquerque
 ip address 192.168.10.37 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel15
 description DHQ <--> Henderson, NV
 ip address 192.168.10.41 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel16
 description DHQ <--> Las Cruces, NM
 ip address 192.168.10.45 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel17
 description DHQ <--> Prescott, Az
 ip address 192.168.10.49 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel18
 description DHQ <--> LV
 ip address 192.168.10.53 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel19
 description DHQ <--> Las Vegas ARP
 ip address 192.168.10.57 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel20
 description DHQ <--> Camp
 ip address 192.168.10.61 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination

interface Tunnel21
 description DHQ <--> Tucson
 ip address 192.168.10.65 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel22
 description DHQ <--> Yuma
 ip address 192.168.10.69 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
interface Tunnel23
 description DHQ <--> Apache Junction
 ip address 192.168.10.73 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel24
 description Kingman, AZ
 ip address 192.168.10.77 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel25
 description Tucson Transition
 ip address 192.168.10.81 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel26
 description DHQ <--> Tucson
 ip address 192.168.10.85 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel27
 description DHQ <--> Tucson Senior Nutrition
 ip address 192.168.10.93 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel28
 description DHQ <--> Sierra Vista, AZ
 ip address 192.168.10.97 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel29
 description DHQ <--> Tucson South
 ip address 192.168.10.89 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel30
 description DHQ <--> El Pueblo
 ip address 192.168.10.101 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel31
 description DHQ <--> Sun Cities
 ip address 192.168.10.105 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel32
 description DHQ <--> GreenValley
 ip address 192.168.11.33 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel33
 description DHQ <--> LVFS
 ip address 192.168.10.17 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel34
 description DHQ <--> CasaGrande
 ip address 192.168.11.37 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel35
 description DHQ <--> Elpaso Pisano   172.27.43.1
 ip address 192.168.11.41 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
interface Tunnel36
 description DHQ <----> Elpaso Temple (East) 172.27.44.1
 ip address 192.168.10.9 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel37
 description DHQ<--->Elpaso Hercules 172.27.63.1
 ip address 192.168.11.45 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel38
 description DHQ<--->Hobbs  172.27.51.1
 ip address 192.168.11.49 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel39
 description DHQ<--->Santa Fe 172.27.36.1
 ip address 192.168.11.53 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel40
 description DHQ <---> Globe  172.27.65.1
 ip address 192.168.11.57 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel41
 description DHQ <--> Clovis 172.27.66.1
 ip address 192.168.11.61 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel42
 description DHQ <--> Las Vegas, NM  172.27.67.1
 ip address 192.168.11.65 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
interface Tunnel43
 description DHQ <---> Prescott Valley 172.27.88.1
 ip address 192.168.11.69 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel44
 description DHQ <--> Phoenix Central 172.27.55.1
 ip address 192.168.11.73 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel45
 description Phoenix Korean <----> DHQ 172.27.99.0
 ip address 192.168.11.77 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel46
 description White Mountain <---> DHQ 172.27.89.0
 ip address 192.168.11.81 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination 24.119.156.19
!
interface Tunnel47
 description Alamogordo <---> DHQ  172.27.105.1
 ip address 192.168.11.85 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel48
 description DHQ <---> Pathways 172.27.30.0
 ip address 192.168.11.89 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel49
 description This is the tunnel to South Mountain. 172.27.68.0
 ip address 192.168.11.101 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel50
 description Estrella <---> DHQ  172.27.45.0
 ip address 192.168.11.105 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel51
 description North Las Vegas Corps <---> DHQ 172.27.31.0
 ip address 192.168.11.109 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel52
 description Lied <---> DHQ 172.27.32.0
 ip address 192.168.11.113 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel53
 description Roswell Family Services <---> DHQ 172.27.33.0
 ip address 192.168.11.117 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel54
 description DHQ <---> Las Cruces Corps 172.27.74.0
 ip address 192.168.11.121 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel55
 description dhq <---> LV Womens ARP
 ip address 192.168.11.129 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel56
 description ARP Whse <---> DHQ 172.27.21.0
 ip address 192.168.11.125 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel100
 description DHQ<--->Cascade Division
 ip address 192.168.11.133 255.255.255.252
 tunnel source FastEthernet3/1
 tunnel destination
!
interface Tunnel200
 bandwidth 1000
 ip address 192.168.12.1 255.255.255.252
 ip mtu 1400
 delay 1000
 tunnel source FastEthernet3/1
 tunnel destination
!
interface FastEthernet0/0
 description this is the Interface to DHQ network (main building)

 ip address 172.27.4.3 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet3/0
 description this is the bldg 100 Segment
 ip address 172.27.6.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet3/1
 description this is the DSL2 gateway to the Corps.
 ip address 63.230.235.252 255.255.255.248 secondary
 ip address 63.230.235.253 255.255.255.248
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet4/0
 description this is the gateway to 300-400 Bld.
 ip address 172.27.5.1 255.255.255.0
 ip nat inside
 speed auto
 full-duplex
!
interface FastEthernet4/1
 no ip address
 shutdown
 duplex auto
 speed auto
!

!
ip nat inside source list 10 interface FastEthernet3/1 overload
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 172.27.4.17
ip route X.X.55.32 255.255.255.255 X.X.235.254
ip route X.X.41.124 255.255.255.255 X.X.235.254........ And so on for all the satellite offices
ip route 172.16.0.0 255.255.0.0 172.27.4.1 (this is an unrelated router that tunnels to our HQ in Calif.)
ip route 172.19.0.0 255.255.0.0 192.168.11.134 (this is the route to Cascade)
ip route 172.27.21.0 255.255.255.0 192.168.11.126
ip route 172.27.22.0 255.255.255.0 192.168.11.130
ip route 172.27.25.0 255.255.255.0 192.168.12.2
ip route 172.27.30.0 255.255.255.0 192.168.11.90
ip route 172.27.31.0 255.255.255.0 192.168.11.110
ip route 172.27.32.0 255.255.255.0 192.168.11.114
ip route 172.27.33.0 255.255.255.0 192.168.11.118
ip route 172.27.36.0 255.255.255.0 192.168.11.54
ip route 172.27.40.0 255.255.255.0 192.168.11.2
ip route 172.27.41.0 255.255.255.0 192.168.10.78
ip route 172.27.42.0 255.255.255.0 192.168.10.18
ip route 172.27.43.0 255.255.255.0 192.168.11.42
ip route 172.27.44.0 255.255.255.0 192.168.10.10
ip route 172.27.45.0 255.255.255.0 192.168.11.106
ip route 172.27.51.0 255.255.255.0 192.168.11.50
ip route 172.27.55.0 255.255.255.0 192.168.11.74
ip route 172.27.60.0 255.255.255.0 192.168.10.22
ip route 172.27.61.0 255.255.255.0 192.168.10.70
ip route 172.27.62.0 255.255.255.0 192.168.10.74
ip route 172.27.63.0 255.255.255.0 192.168.11.46
ip route 172.27.65.0 255.255.255.0 192.168.11.58
ip route 172.27.66.0 255.255.255.0 192.168.11.62
ip route 172.27.67.0 255.255.255.0 192.168.11.66
ip route 172.27.68.0 255.255.255.0 192.168.11.102
ip route 172.27.70.0 255.255.255.0 192.168.10.26
ip route 172.27.71.0 255.255.255.0 192.168.10.30
ip route 172.27.72.0 255.255.255.0 192.168.10.34
ip route 172.27.73.0 255.255.255.0 192.168.10.38
ip route 172.27.74.0 255.255.255.0 192.168.11.122
ip route 172.27.75.0 255.255.255.0 192.168.10.42
ip route 172.27.76.0 255.255.255.0 192.168.10.46
ip route 172.27.77.0 255.255.255.0 192.168.10.50
ip route 172.27.78.0 255.255.255.0 192.168.10.62
ip route 172.27.79.0 255.255.255.0 192.168.11.14
ip route 172.27.80.0 255.255.255.0 192.168.11.10
ip route 172.27.81.0 255.255.255.0 192.168.11.18
ip route 172.27.82.0 255.255.255.0 192.168.11.6
ip route 172.27.83.0 255.255.255.0 192.168.11.22
ip route 172.27.84.0 255.255.255.0 192.168.11.26
ip route 172.27.85.0 255.255.255.0 192.168.11.30
ip route 172.27.86.0 255.255.255.0 192.168.10.58
ip route 172.27.87.0 255.255.255.0 192.168.10.54
ip route 172.27.88.0 255.255.255.0 192.168.11.70
ip route 172.27.89.0 255.255.255.0 192.168.11.82
ip route 172.27.90.0 255.255.255.0 192.168.10.66
ip route 172.27.91.0 255.255.255.0 192.168.10.86
ip route 172.27.92.0 255.255.255.0 192.168.10.82
ip route 172.27.93.0 255.255.255.0 192.168.10.94
ip route 172.27.94.0 255.255.255.0 192.168.10.98
ip route 172.27.95.0 255.255.255.0 192.168.10.90
ip route 172.27.96.0 255.255.255.0 192.168.10.102
ip route 172.27.97.0 255.255.255.0 192.168.11.34
ip route 172.27.98.0 255.255.255.0 192.168.11.38
ip route 172.27.99.0 255.255.255.0 192.168.11.78
ip route 172.27.100.0 255.255.255.0 192.168.10.106
ip route 172.27.105.0 255.255.255.0 192.168.11.86
ip route 172.27.160.0 255.255.255.0 192.168.10.14
ip route 172.27.250.0 255.255.255.0 192.168.10.6

access-list 10 permit 172.27.4.0 0.0.0.255
access-list 10 permit 172.27.5.0 0.0.0.255
access-list 10 permit 172.27.6.0 0.0.0.255
!
!
line con 0
line aux 0
line vty 0 4
 password xxxxxxxxxxxxxxxx
 absolute-timeout 9999
 login
!
end

DHQMain#
0
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
On the interface where you want this to be done; do it this way;

Basic example;

access-list 100 permit ip 1.1.1.1 any eq icmp
access-list 200 permit ip 2.2.2.2 any
!
interface ethernet 1
   ip policy route-map exit => Exit is the name of the route map.
!
route-map Exit permit 10
   match ip address 100
   set ip next-hop x.x.x.254
!
route-map Texas permit 20
   match ip address 200
   set ip next-hop 172.27.4.17

Looking at it, when traffic comes, it looks at the route-map entry 10 first, it sees if the traffic matches access-list 100, if so the next-hop router is set to ISP gateway (since it will match icmp)

If the traffic is not icmp, it will match the route-map entry 20 first and let all the traffic to SonicWall.

Hope this is clear;

Also look at the site below for full explanation on how the route-maps work;

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800ca590.html

Cheers,
Rajesh
0
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
>> route-map Texas permit 20

Read the above as route-map Exit permit 20

Cheers,
Rajesh
0
 
LVL 3

Author Comment

by:n7okn
Comment Utility
Please tell me if this is the code I would enter. I'm not exactly sure of what I'm doing, so I need to verify the right
numbers before I try it. No subnet mask needed when specifying ip addresses in the acl? Please let me know if I got the numbers right.


access-list 100 permit ip 0.0.0.0 any eq icmp (Default from any IP address on the Internet)
access-list 200 permit ip 172.27.0.0 any (from any address on the private network)
!
interface fa3/1 (This interface where the ICMP packets are expexted to hit from the outside)
   ip policy route-map exit => Exit is the name of the route map.
!
route-map exit permit 10
   match ip address 100
   set ip next-hop x.x.x.254
!
route-map exit permit 20
   match ip address 200
   set ip next-hop 172.27.4.17
0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 200 total points
Comment Utility
access-list 100 permit ip any any eq icmp
access-list 200 permit ip any any

int fa0/0
ip policy route-map exit

int fa4/0
ip policy route-map exit

int fa5/0
ip policy route-map exit

route-map exit permit 10
match ip address 100
set ip next-hop x.x.x.254

route-map exit permit 20
match ip address 200
set ip next-hop 172.27.4.17

That should be it.

Cheers,
Rajesh
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

In a WLAN, anything you broadcast over the air can be intercepted.  By default a wireless network is wide open to all until security is configured. Even when security is configured information can still be intercepted! It is very important that you …
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now