Solved

eth0 Won't Start when Using Crossover Cable (connected to Win 2000 Pro computer)

Posted on 2006-07-03
8
396 Views
Last Modified: 2010-03-17
I am trying to connect a linux (Mepis, a Debian variant) computer to a Win 2000 computer using a crossover cable.

 Normally the linux computer is connected tothe internet via a broadband router/modem by ethernet cable, and I am changing the connection using the same ethernet port by turning the linux computer off, changing LAN cables (obviously), and then restarting it.

 The two main problems I'm noticing at this stage are:

- The eth0 daemon doesn't start like it usually does on bootup..
- Naturally enough, I get "unable to find any workgroups in your local network" underthe Samba browser. The localhost computer IS visible when the other ("internet") cable is connected.
 
 Any suggestions (see troubleshooting below)?


==================================================================
 
 TROUBLESHOOTING (note user name edited  as "********" in some outputs below)
 
- The same crossover LAN connection works fine when running the "linux" computer under a Windows
2000 partition (in other words connecting two Win 2000 computers), so I don't
think it's a cable hardware problem.


- smb.conf file:

;*******************section global*****************
[global]

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d
printing = cups
workgroup = WORKGROUP
server string = %h server (Samba %v)
hosts allow = 192.168.0. 192.168.1. 192.168.2. 127. 169.254.
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=4096 SO_RCVBUF=4096
passdb backend = tdbsam guest
dns proxy = no
max log size = 1000
security = users
restrict anonymous = no
domain master = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto
paranoid server security = no
;*******************section *************************
[********]
comment = /home/********
path = /home/********
guest ok = yes
read only = no
;*******************section homes*****************
[homes]
comment = Home Directories
browseable = no
read only = no
;*******************section printers*****************
[printers]
comment = All Printers
path = /tmp
browseable = no
printable = yes
guest ok = yes
create mask = 0700
print command = lpr -P %p -o raw %s -r

[Unnamed]
case sensitive = no
msdfs proxy = no
path = /mnt/hda5/share
browseable = yes
writeable = yes
public = yes
guest ok = yes


- "testparm" output:

Load smb config files from /etc/samba/smb.conf
Processing section "[********]"
Processing section "[homes]"
Processing section "[printers]"
Processing section "[Unnamed]"
Loaded services file OK.
Warning: Service printers defines a print command, but print command parameter is ignored when using CUPS libraries.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

output after pressing "enter":

# Global parameters
[global]
        server string = %h server (Samba %v)
        passdb backend = tdbsam, guest
        max log size = 1000
        server signing = auto
        paranoid server security = No
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=4096 SO_RCVBUF=4096
        preferred master = No
        domain master = No
        dns proxy = No
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        hosts allow = 192.168.0., 192.168.1., 192.168.2., 127., 169.254. ;
        printing = cups
        print command =
        lpq command =
        lprm command =

[********]
        comment = /home/********
        path = /home/********
        read only = No
        guest ok = Yes

[homes]
        comment = Home Directories
        read only = No
        browseable = No

[printers]
        comment = All Printers
        path = /tmp
        create mask = 0700
        guest ok = Yes
        printable = Yes
        print command = lpr -P %p -o raw %s -r
        browseable = No

[Unnamed]
        path = /mnt/hda5/share
        read only = No
        guest ok = Yes
        case sensitive = No
        msdfs proxy = no

      
- "ifconfig" output (while connected to internet; so far no eth0 section when crossover cable connected):

eth0      Link encap:Ethernet  HWaddr 00:06:5B:CD:58:05
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::206:5bff:fecd:5805/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2094 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3077 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1533840 (1.4 MiB)  TX bytes:412549 (402.8 KiB)
          Base address:0xdcc0 Memory:ff6e0000-ff700000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2471 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:133410 (130.2 KiB)  TX bytes:133410 (130.2 KiB)
        
 - Have also run "dmesg" and checked /var/log/messages without noticing any "useful" differences when changing cables....


               
========================================================================
0
Comment
Question by:1111_____1111
  • 3
  • 3
  • 2
8 Comments
 
LVL 57

Assisted Solution

by:giltjr
giltjr earned 150 total points
ID: 17034274
What messages are you getting in /var/log/messages that deal with eth0?

Are you sure the cable is good and correctly crossed?
0
 

Author Comment

by:1111_____1111
ID: 17035483
giltjr:

 Selected /var/log/messages outputs after booting with a crossover cable, and then an ordinary one. (Note passages containing "eth0" are highlighted with a "#")


With XOver Cable:

Jul  4 18:22:36 mepis1 kernel: intel8x0: clocking to 48000
Jul  4 18:22:36 mepis1 kernel: Intel(R) PRO/1000 Network Driver - version 5.5.4-k2
Jul  4 18:22:36 mepis1 kernel: Copyright (c) 1999-2004 Intel Corporation.
Jul  4 18:22:36 mepis1 kernel: ACPI: PCI interrupt 0000:02:0c.0[A] -> GSI 9 (level, low) -> IRQ 9
#Jul  4 18:22:36 mepis1 kernel: e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
Jul  4 18:22:36 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 18:22:36 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 18:22:36 mepis1 kernel: NTFS driver 2.1.22 [Flags: R/W MODULE].
Jul  4 18:22:36 mepis1 kernel: NTFS volume version 3.0.
Jul  4 18:22:36 mepis1 kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
Jul  4 18:22:36 mepis1 kernel: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
Jul  4 18:22:36 mepis1 kernel: ttyS1: LSR safety check engaged!
Jul  4 18:22:36 mepis1 kernel: ttyS1: LSR safety check engaged!
Jul  4 18:22:36 mepis1 kernel: Linux Kernel Card Services
Jul  4 18:22:36 mepis1 kernel:   options:  [pci] [cardbus] [pm]
Jul  4 18:22:36 mepis1 kernel: NET: Registered protocol family 17
#Jul  4 18:22:36 mepis1 kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
Jul  4 18:22:36 mepis1 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jul  4 18:22:36 mepis1 kernel: ip_conntrack version 2.1 (8192 buckets, 65536 max) - 300 bytes per conntrack
#Jul  4 18:22:36 mepis1 kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
Jul  4 18:22:36 mepis1 kernel: Device not ready.  Make sure there is a disc in the drive.
Jul  4 18:22:36 mepis1 kernel: Device not ready.  Make sure there is a disc in the drive.
Jul  4 18:22:36 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 18:22:36 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 18:22:36 mepis1 kernel: NTFS volume version 3.0.
Jul  4 18:22:40 mepis1 kernel: parport0: PC-style at 0x378 (0x778) [PCSPP(,...)]
Jul  4 18:22:40 mepis1 kernel: parport0: irq 7 detected
Jul  4 18:22:40 mepis1 kernel: lp0: using parport0 (polling).
Jul  4 18:22:40 mepis1 kernel: lp0: console ready
Jul  4 18:22:40 mepis1 kernel: ttyS1: LSR safety check engaged!
Jul  4 18:22:42 mepis1 xfs: ignoring font path element /usr/share/fonts/truetype/arphic/ (unreadable)
Jul  4 18:22:42 mepis1 xfs: ignoring font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/CID (unreadable)
Jul  4 18:22:44 mepis1 kernel: Win4Lin: module license 'unspecified' taints kernel.
Jul  4 18:22:44 mepis1 kernel: win4lin: mki_version 7, num_cpus 1, pae 0
Jul  4 18:22:44 mepis1 kernel: win4Lin: preempt_enable 0xf8ea59d0
Jul  4 18:22:45 mepis1 kernel: NET: Registered protocol family 10
Jul  4 18:22:45 mepis1 kernel: Disabled Privacy Extensions on device c0420c40(lo)
Jul  4 18:22:45 mepis1 kernel: IPv6 over IPv4 tunneling driver



With "Standard" Cable

Jul  4 19:08:55 mepis1 kernel: Intel(R) PRO/1000 Network Driver - version 5.5.4-k2
Jul  4 19:08:55 mepis1 kernel: Copyright (c) 1999-2004 Intel Corporation.
Jul  4 19:08:55 mepis1 kernel: ACPI: PCI interrupt 0000:02:0c.0[A] -> GSI 9 (level, low) -> IRQ 9
#Jul  4 19:08:55 mepis1 kernel: e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
Jul  4 19:08:55 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 19:08:55 mepis1 kernel: VFS: Can't find a valid FAT filesystem on dev hda1.
Jul  4 19:08:55 mepis1 kernel: NTFS driver 2.1.22 [Flags: R/W MODULE].
Jul  4 19:08:55 mepis1 kernel: NTFS volume version 3.0.
Jul  4 19:08:55 mepis1 kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
Jul  4 19:08:55 mepis1 kernel: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
Jul  4 19:08:55 mepis1 kernel: ttyS1: LSR safety check engaged!
Jul  4 19:08:55 mepis1 kernel: ttyS1: LSR safety check engaged!
Jul  4 19:08:55 mepis1 kernel: Linux Kernel Card Services
Jul  4 19:08:55 mepis1 kernel:   options:  [pci] [cardbus] [pm]
Jul  4 19:08:55 mepis1 kernel: NET: Registered protocol family 17
#Jul  4 19:08:55 mepis1 kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
#Jul  4 19:08:55 mepis1 kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex
Jul  4 19:08:55 mepis1 kernel: NET: Registered protocol family 10
Jul  4 19:08:55 mepis1 kernel: Disabled Privacy Extensions on device c0420c40(lo)



 The cable is good and correctly wired as far as I can tell. It has "standard" wiring at one end , and "crossover" wiring at the other. I've verified each wire using a diagram and an ohmmeter.


 I've also tried swapping cable ends between the two computers (no change).


0
 
LVL 87

Accepted Solution

by:
rindi earned 100 total points
ID: 17037649
Have you assigned a static IP to both NICS at each end of the cable?
0
 
LVL 57

Assisted Solution

by:giltjr
giltjr earned 150 total points
ID: 17038677
Based on your log eth0 is comming up with the cross over cable.

To exapand on rindi's question: Have you assigned static IP address on both systems that are in the same IP subnet?

0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 

Author Comment

by:1111_____1111
ID: 17039712
I have had the Linux computer set up for DHCP because that's the way the ISP I use works. Two Windows 2000 computers connected by crossover seem to be able to get around this, but it sounds like i'll have to switch to static on  both computers to make the crossover connection work when one of the computers  running Linux. Will look into this in the next day or so.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17039837
When setup for DHCP Windows will autoconfigure a IP address if it can't find a DHCP server.  This is something that MS added to Windows.  Most Linux distributions will NOT do this, some do.   Configuring Linux with a static IP address will help, but you also have to configure Windows with one also, in the same IP subnet as the one you use on the Linux box.
0
 
LVL 87

Expert Comment

by:rindi
ID: 17040115
Anyway, the windows way of assigning an IP like 169.x.x.x is a bad workaround and this should never be used. You need to assign a static IP when connecting 2 pc's together for things to correctly work, or setup one of the PC's to be a dhcp server itself.
0
 

Author Comment

by:1111_____1111
ID: 17041259
Thanks guys. Have got eth0 working, and the linux and windows computers are now "seeing" eachother (via Samba and "My network Places " respectively).
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now