Solved

Network Problems

Posted on 2006-07-03
29
458 Views
Last Modified: 2010-07-27
Hello!

My network stopped functioning properly a couple of weeks ago, and I can't find the problem...

What I currently have is the following:
1 laptop w. Windows XP Home
1 PC with w. Windows XP Pro
1 D-Link switch/router
in an ethernet LAN configuration using MS Networking and Internet Connection Sharing.
The laptop is the host for the Internet Connection Sharing.

Everything worked fine a couple of weeks ago, but now I'm unable to access the laptop's shared documents and printers from the PC. However, the internet connection is still accessible from the PC and the laptop is also visible on the PC.

When I try to access the laptop, I get a falure message saying I do not have sufficient rights or something like that...

Any help is much appreciated!
0
Comment
Question by:Julian Matz
  • 13
  • 4
  • 4
  • +5
29 Comments
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034281

Here's the exact error message:


\\ComputerName is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Logon failure: the user has not been granted the requested logon type at this computer.
0
 
LVL 19

Expert Comment

by:simpswr
ID: 17034301
What firewall is in place . . try disableing it to see if you can see the laptop
0
 
LVL 19

Expert Comment

by:simpswr
ID: 17034304
Also . . see this for some ideas . . http://www.homenethelp.com/web/howto/net.asp
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034305
I have Norton Internet Security on both machines. I've already tried disabling both...

On the PC, I can actually see the laptop computer in the network, but just not access it...
0
 
LVL 19

Expert Comment

by:simpswr
ID: 17034306
0
 
LVL 4

Expert Comment

by:miloudi
ID: 17034333

Did u try giving the laptop a different name?
If you already did.
How about installing NETBEUI in the win XP Home machine.

Install NetBEUI on Windows XP
The files necessary for installing the NetBEUI protocol on Windows XP are Netnbf.inf and Nbf.sys. Complete the following steps to install NetBEUI:

1. Insert your Windows XP CD-ROM into the CD-ROM drive and browse to the Valueadd\MSFT\Net\NetBEUI folder.
2. Copy Nbf.sys to the %SYSTEMROOT%\System32\Drivers directory.
3. Copy Netnbf.inf to the %SYSTEMROOT%\Inf hidden directory.

NOTE: To make a hidden folder viewable, perform the following steps:

1. Click Start, click Run, type Explorer, and then press ENTER.
2. Click Tools, click Folder Options, and then click the View tab.
3. Under Advanced Settings, click Show hidden files and folders under the Hidden files and folders Folder.
4. Click Start, click Control Panel, and then double-click Network Connections.
5. Right-click the adapter you want to add NetBEUI to, and then click Properties.
6. On the General tab, click Install.
7. Click Protocol, and then click Add.
8. Click to select NetBEUI Protocol from the list and then click OK.
9. Restart your computer if you receive a prompt to complete the installation.
The NetBEUI protocol should now be installed and working.

NOTE: %SYSTEMROOT% is a Windows environment variable that identifies the directory where Windows XP is installed (for example, C:\Windows). To view the value associated with %SYSTEMROOT%, as well as other environment variables, at a command prompt, type set, and then press ENTER.


 
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034357
I think this may be an issue with the TCP/IP settings...

It's a little complicated with this network because I don't have access to broadband and need to use ICS over modem.
The router is only used to connect the computers and I got it because there used to be 3 computers in the network.

Thus, I had to give the router the IP address 192.168.0.2 and the laptop the static IP 192.168.0.1.
The router assigns static IPs to connected clients.

The settings on the laptop must have *somehow* changed and I can't remember the correct settings...
I'm gonna give this a try but if anyone has any suggestions re. TCP/IP, they'd be much appreciated...
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034361
Also, I am able to ping the laptop from the PC...
0
 
LVL 6

Expert Comment

by:marce_lito
ID: 17034464
make sure you have corresponding users in the computers with no blank password (windows xp sp2 doesn't permit network logons with accounts with blank passwords)

if you still have problems, enable logon auditing on the laptop and see if the event viewer has a useful message description on why it doesn't authenticate the user on the other computer...
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034496
marce_lito,

You might be right, although it worked before and I had SP2 installed on both computers for a long time now...

Anyway, I opened the security events viewer and the logon attempts were there.
It says "logon failure" and the reason is that the user was not granted access.

My username on the laptop is "Julian Matz" and the username on the PC is "Julian".
I changed the username on the PC to "Julian Matz", but the security events viewer still says
access denied for user "Julian". What's that about?

0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034563
Ok, I added a new account with the same name and password as on the laptop just to try it...
I got the same message in the security events viewer:

534
Logon Failure
Reason: The user has not been granted the requested logon
Username: Julian Matz
0
 
LVL 18

Expert Comment

by:Crash2100
ID: 17034581
Try this...  Go to start->run, type "gpedit.msc" and say ok.  In the window that appears, go to the following location in the list:

Computer configuration\Windows settings\security settings\local policies\user rights assignment

Make sure "Everyone" IS listed in the "Access this computer from the network" list, and it ISN'T listed in the "Deny access this computer from the network"

If you don't want to mess with that, you can just enable the Guest account in the user accounts control panel.  But that makes your shared files accessible to anyone.
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034592
Crash2100,

XP Home edition does not have security policies. There is no "gpedit.msc".
Guest account wasn't enabled before but I had it enabled now to see if it would work, but it still doesn't...
0
 
LVL 18

Expert Comment

by:Crash2100
ID: 17034602
Sorry, I missed the part about it being xp home.  Did you restart after enabling the guest account?  If not, try that and see if it makes any difference.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 19

Expert Comment

by:simpswr
ID: 17034605
Check Services to be sure that Workstation Service is running . .
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034606
Ya, I even restarted the laptop... No luck...
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034613
Yes, Workstation service is also started...
0
 
LVL 18

Accepted Solution

by:
Crash2100 earned 350 total points
ID: 17034618
Try this:

http://ecross.mvps.org/faq.htm

Q:  I have two computers on the network and they are both running Windows XP. The problem is with one of the computers on the network. I can access shared files on one computer. When I try to access any of the shared files and connect to the other computer I get the following error:

PC#1 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Logon failure: the user has not been granted the requested logon type at this computer.

A: If the computer runs Windows XP Home Edition, the "secpol.msc" program isn't available to make the required user right assignments. Use the ntrights utility that is part of the Windows 2003 Resource Kit Tools to make the change. To do so, follow these steps:

1. Download and install the Windows Server 2003 Resource Kit Tools.
http://go.microsoft.com/fwlink/?LinkId=4544

2. Click Start | All Programs | Windows Resource Kit Tools | Command Shell. Type these lines at the command prompt.  The second and third commands are case-sensitive, so type them exactly as shown.  Note the "+r" in the second one and the "-r" in the third one:

 net user guest /active:yes
 ntrights +r SeNetworkLogonRight -u Guest
 ntrights -r SeDenyNetworkLogonRight -u Guest
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17034628
Ya, I saw that solution somewhere on the net, but I'd really prefer to figure out the cause of this because it did work a couple of weeks ago...

Also, I never had the Guest account activated...

There must be another solution... ???
0
 
LVL 18

Expert Comment

by:Crash2100
ID: 17034643
I think you could use that kit to do what I had suggested you do with the group policy editor.  Try something like this:

ntrights +r SeNetworkLogonRight -u Everyone
ntrights -r SeDenyNetworkLogonRight -u Everyone
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17035094
Ok, I downloaded and installed the Kit Tools...
I ran the commands successfully, but when I try to access the laptop now it says "Access is denied.".

One thing I don't understand...

+r == grants rights
-r == revokes rights

If this is correct, what exactly is being revoked with the second command?
0
 
LVL 44

Expert Comment

by:scrathcyboy
ID: 17035427
You simply need the same login and password for both computers, you need to have both on the same workgroup name, and the shares need to be so they allow access to ALL users.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 17036827
hi there

have u upgraded ur browser that is internet explorer as the new upgrade of IE has enhanced security settings which would disable any connectivity between two computers that is for browsing the shared folders and things like that.

so check for any upgrades or any automatic updates that have been applied and try to uninstall them


bhanu
0
 
LVL 6

Expert Comment

by:marce_lito
ID: 17037105
take a look at:

http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B885184

it's a microsoft article that describes your problem and the resolution... you might find it useful...

you may also want to take a look at:

http://www.experts-exchange.com/Networking/Q_21841003.html
0
 

Expert Comment

by:jacobmaloney
ID: 17047130
If this was a service pack upgrade, it may have enabled "XP simple file sharing". Try going to My computer > tools > folder options > then browse to the 2nd tab labeled view, scroll to the bottom and make sure "use simple file sharing" is unchecked.

Sounds more like a service / netbios issue due to an update, something had to of changed, I am guessing that would be about it.
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17047668
It seems to work now... Windows Server 2003 Resource Kit Tools must have done the trick after a system reboot...
One question about that: are there any security issues I should be aware of?

Most of the articles posted here I've seen already, none of them really seem to apply.
First I thought it was a TCP/IP issue, but found out it wasn't.
I'm pretty certain this problem was caused by a Virus. According to my AV sw, my laptop had been infected with the W32.spybot.worm. I've since seen a few references on the net stating that this worm can mess with the registry and stop networks from functioning properly.

I also recently had a process running which caused some trouble (or maybe another program using the process). It was called "runjava.exe" and while the process was running I had absolutely no network connectivity, not even internet over modem (although the modem was connected successfully). Things seemed to function again properly as soon as the process was killed. It was shortly after that the virus warning kept popping up, and although the virus was supposedly removed, it did come back a couple of times, but I haven't had any reports now for a while...

Anyone else ever hear of this?
0
 
LVL 6

Assisted Solution

by:marce_lito
marce_lito earned 150 total points
ID: 17051683
this is copied from http://support.microsoft.com/default.aspx?scid=kb;en-us;308007

Note: All network access to either a Windows XP Home Edition-based computer in a workgroup or to a Windows XP Professional-based computer in a workgroup uses the Guest account. Before you continue troubleshooting, make sure that the Guest account is set up for network access.

So, the guest account is supposed to have rights to do a network login... it's no more a security risk than the windows default.
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 17051754
I don't know what happened between then and now, but I never had the Guest user account activated on either machine, and have never had any problems until about 3 weeks ago...

Anyway, it's working now, so I guess it's solved... I hope to be buying a new laptop soon anyway... No more XP Home :)
0
 
LVL 6

Expert Comment

by:marce_lito
ID: 17051776
thank God!!! xp home sucks...
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Disclosure: Use this tutorial only when no other options helps to get Windows XP running without any problems and you don't want to format the drive. The back up of the data is the responsible of the user, however there is a description of how t…
Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
This video discusses moving either the default database or any database to a new volume.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now