Solved

Hard drive suddenly sees some (not all) previously full folders as 0kb files!!!!!

Posted on 2006-07-03
9
364 Views
Last Modified: 2010-04-25
I want to get the best advice/results possible for my (quite unsettling) problem, so I will explain it first in short, then in detail, below:

In a nutshell:
My Western Digital WDC WD2000JB-00GVA0 200GB hard drive was working perfectly just moments ago.
Now, some, but not all, folders which contained many files are displayed in 'my computer' as 0kb files.
The drive, however, is displayed as healthy, active, and 175gb full, just as before.


In Detail:
My computer is normally configured with an 80GB Seagate Master- I will now refer to this as the SEAGATE, and a Western Digital WDC WD2000JB-00GVA0 200GB Slave- I will now refer to this as the WDC.  Both drives have never had any problems up to this point.  A friend gave me a 60gb Maxtor 4D060H3- I will now refer to this as the MAXTOR.  Because all my Primary IDE and Secondary IDE openings were full, I invested in an "SATA to IDE dongle" for converting the Maxtor ATA HDD to SATA Interface (2 of which my motherboard has).

I hooked up the dongle to the Maxtor and put it into the SATA1 slot in my mobo, and configured the BIOS.  This did not work.  I tried several times.  I even tried "hot plugging" the SATA cable.  During this attempt I bumped a power cable that contacted (only) the Maxtor's power input slot, which shorted the computer and it immediately shut down.  This i consider negligible, especially since it happened to the Maxtor hard drive.  I later came to the conclusion/was told that the Maxtor was probably dead (also, it previously had some version of linux on it).  So I 'gave up,' took out the SATA cord, unhooked the dongle from the Maxtor, and put the BIOS settings back to what the were before.   That is fine, I'm not concerned about the Maxtor...

Now, I am back to my exact previous hardware configuration.  I have discovered that the WDC slave hard drive is showing some folders as 0 KB files.  In the root HDD directory, there are 17 folders, 3 of which are now shown as 0kb sized files.  This is a very upsetting, as these folders contained almost all of 150gb of important backup files.  I simply cannot comprehend what could have caused this.  Throughout the above explained process I did nothing to this drive to cause this.  


What I have done so far:
I ran chkdsk on the WDC hard drive slave
Results were fine, reporting file, index, and security descriptor as verified.  It showed this:
195350368kb total disk space
183665352kb in 87273 files
45768kb in 10092 indexes
0kb in bad sectors
170296kb in use by the system
65536kb occupied by the log file
11468952kb available on disk.

4096 bytes in each allocation unit
48837592 total allocation units on disk
2867238 allocation units available on disk
------------------------------------------------------
Drive properties show 175gb used and 11gb free on the drive.
------------------------------------------------------
I have Windows Vista installed on another partition on the Seagate Master.  I booted up the computer in that OS, and viewed the WDC slave hard drive from 'my computer...'   it showed the exact same 0kb files, rather than folders, as in WinXP.


All this seems normal, yet three root folders, which contain many folders and files, are now displayed as files of size 0 kb.  Despite all this, the Seagate Master drive is just fine.
Should I replace the IDE cable?
Should I make an image of the WDC somehow, and rewrite it somewhere else?
Check my profile for my computer system specs.

ANY HELP, advice, or questions are GREATLY appreciated.  
0
Comment
Question by:LeftHandedPants
  • 4
  • 4
9 Comments
 
LVL 14

Expert Comment

by:FriarTuk
Comment Utility
sounds like you've maxed the drive, 175gb of 186 total (after formatting) leaving only 11gb left - this can cause the file index to become corrupted

i''d boot into safe mode & start removing temp files, temporary internet files, cookies, clear recycle bin, purge system restore files

once you make room, boot into normal mode & start backing your large files up somewhere else - need to remember that the o/s needs to have space for its swap file c:\pagefile.sys (mine's about 800mb) plus it needs space for temporary stuff while you have things running
0
 

Author Comment

by:LeftHandedPants
Comment Utility
There has been a slight development!!  
But first:
I see where you're coming from, FriarTuk, but the WDC drive we're talking about here does not have windows installed on it.  It is used purely for storage and is a slave.  There are no temp files, cookies, recycle bin, or system restore files, etc.  Therefore there is no OS to need space for a pagefile.  The only things on this drive are files I MANUALLY put there for storage.

IMPORTANT:
Today I went into Folder Options and unchecked "hide protected operating system files(Recommended)" and selected "Show hidden files and folders."
After doing this I was surprised to see a 'system' folder of size 151,753,239kb show up!!  This folder is called "found.000"; it is read-only, and hidden, as a system folder.  Browsing into this folder reveals more folders and files with names like "dir0000.chk" and "file0001.chk".  Browsing into some of these folders reveals the files and folders that WERE in the 2 folders called: "Cameron N. Hess" and "Stuff", which are now shown as 0kb size files.  
I am a bit relieved to see my files, but still, there is something definately wrong here.  Any ideas?

I have posted a list of some of these files and folders for you to look at, if it might help.  Download the .txt file here: www.messiah.edu/~ch1217/fdrivelist.txt.  Search the .txt file for 'found.000' to see the folders, subfolders, and files that have suddenly shown up there.  Search the .txt file for 'cameron n. hess' or 'stuff' to see the 0kb sized files that once contained, in an organized fashion, what is now strewn about the folder called "found.000."

Any ideas?

Thanks for your help.


0
 

Author Comment

by:LeftHandedPants
Comment Utility
EDIT:  The file fdrivelist.txt is just a small sample of the entire list.  It should show the most pertanent information with respect to my problem.  Had I uploaded the entire list, it would've been a 8mb download.  ~175 gb of files makes a long list, indeed.
0
 
LVL 28

Expert Comment

by:burrcm
Comment Utility
Files such as found.000, file0001.chk are the result of scandisk/chkdsk finding lost data and saving it. This indicates a failing drive. There is no help for it. Replace it. GetDataBack or similar may be able to recover some or all of the missing data.

Chris B
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 14

Expert Comment

by:FriarTuk
Comment Utility
how big is the combined "found.000" folder? if not = 175gb then it is just pointer info that was problably recovered - i concur with burrcm that it is indicative of a failing drive, boot into safe mode command prompt & run chkdsk /r on it (may run a long time for 200GB) & also try the diagnostic from WD

Western Digital      
http://support.wdc.com/download/  enter model# (WD2000JB-00GVA0)
0
 

Author Comment

by:LeftHandedPants
Comment Utility
Actually, the folder "found.000" adds up to about 152GB.  This, as I mentioned, contains everything that WAS in the folders that are now being displayed as 0kb files.  There are folders, however, other than these 2 messed up folders, that appear to have not been affected in the least.  Summed up they amount to about 26gb.  These make up the entire ~175gb of data out of the total 186gb capacity on this "200GB" hard drive.  I have viewed many of these files, they all appear to be perfectly intact and non-fragmented.  That's what i'm hoping for now.  I'd rather move all the data to another HD and format this one and start over with it.  I'm thinking the File Allocation Table was being written to when the system was shorted and powered down (mentioned in the initial post).  If I salvage the files, whipe the drive, and start over... i'm thinking it could be just fine.  What do you think?

burrcm and FriarTuk, thanks again for your input.  I'm not yet willing to deem this drive as dead, as I can not only see all my files intact, but i can read them/open them as if nothing ever happened to them (except being moved to found.000).

I have invested in a 400GB hd.  It should arrive in the mail soon.  Then some options may open up.  

p.s.- I already ran chkdsk in windows cmd prompt, but not with /r, and not in safe mode.

p.p.s.- I realize the importance of not writing to the drive, so as to not overwrite anything any more than it already is.  Is it okay, however, for it to be hooked up still, as a slave.  If I cut power, do you think the "found.000" hidden system folder will disappear?
0
 
LVL 14

Accepted Solution

by:
FriarTuk earned 500 total points
Comment Utility
no not dead, but has issues, hence running diagnostics on it fully

most importantly would be to slave it to a larger drive & moved those folders/ files to it first, just in case anything might make matter worse
0
 
LVL 14

Expert Comment

by:FriarTuk
Comment Utility
the folder should still be there after pwr off/on, also another culprit may have been the system restore on that drive (unless you disabled that option under system properties - system restore tab) or a 3rd party defragmentor running in the background

chkdsk /r
/R              Locates bad sectors and recovers readable information
0
 

Author Comment

by:LeftHandedPants
Comment Utility
I have officially installed a new 400GB sata hard drive.  I transfered everything from the 200GB WDC drive (especially the 'found.000' folder) to this new drive.  Then I formatted the WDC drive and moved all the data back from the new 400gb drive and organized it.  The WDC is now working just fine, and I have made a backup image of it and stored it on the new drive as well.  This drive appears to be in perfect condition; I believe the electrical short that occured (explained in problem statement) may have caused some sort of FAT write process to be ended abruptly and incompletely, thus messing up some of the drive's folder structure... but the files are all perfectly intact, so far.  

Thank you everyone, for your help and advice, i very much appreciate it.  
However, because this predicament was not 'solved' as much as it was "worked around"... I will award FriarTuk 500pts for his support of moving files to this drive to back them up, and helpful comments.  
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now