Solved

Windows Security Warning when opening a doc with pics

Posted on 2006-07-04
18
1,104 Views
Last Modified: 2012-06-27
We have just installed a SBS 2003. I have several rtf docs with screenshots within. When I try to open these docs up from a remote client PC, I get a Windows Security Warning. Doc with just text have no problems.

I believe this is coming from the security settings of IE, but not sure. I would like to turn this security 'feature' off - perhaps via Group Policy for the whole domain.

Any ideas? Thanks
0
Comment
Question by:omb
  • 10
  • 8
18 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17035505
How about providing the exact security warning you are receiving.

Thanks!

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17035506
Also, have you posted these rtf docs to your Companyweb?

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17035587
It's in German... I'll try a quick translate:

Windows Security Warning:
This document contains code that the security settings does not permit. Therefore it will not be correctly displayed.

There is a link which I can click on "Should I open this document" and it talks about OLE objects. If I open the doc, the pictures are not displayed, but the text is.

No, the rtf docs have not been posted in SharePoint. I have just created a Share on my SBS for docs.

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 100 total points
ID: 17035769
rtf documents are basically html, so you really wouldn't want to lower the security settings because doing so could allow malicious code to be executed through such documents that users may download from the web or as email attachments.

I would first suggest that you use SharePoint for your "share".  But if you have made these for instructional purposes, I'd also direct you to the built-in help that's available to all users on your network.  There is a link on your Companyweb for "Information and Answers", and it should also be in each person's favorites.  (the actual link is http://<servername>/clienthelp)

There is also a fantastic end-user training PowerPoint slideshow at http;//sbsurl.com/training

Otherwise, put your documents into a SharePoint document library... or just turn them into web pages on your companyweb.  It's quite easy, by going to http://companyweb, then on the top menu click Create > Basic Page.  This will bring up the Rich Text Editor, and you can copy and paste your document contents into it and then click SAVE.

Because http://companyweb is in the Intranet zone, the security permissions are lower and you will have no problems with these documents.

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17036158
Some of these docs are just screenshots from sofware setups made in Wordpad and saved as .rtf - no use for anyone but the admin. Hence, I just require them somewhere on the SBS server, so that they can be accessed from other workstations...

It there a way of lowering the security permissions in the Intranet zone of the SBS? Globally, for all? I never had this problem before with other SBS intallations.

Thanks for your help.

p.s. New points as this "easy" question has become "more difficult".
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 100 total points
ID: 17038128
Still put them in SharePoint.  I always create an IT Documentation Library on the Companyweb with permissions set for only Administrator access.

Jeff
TechSoEasy

:-)  and the P.S. is perfect!
0
 
LVL 3

Author Comment

by:omb
ID: 17040565
OK, I will think about putting them in... but why the error? Is there a new security feature in SBS that I need to be aware of? How can it be turned off?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17042063
What version of IE is on the client machine?

Also, FYI, if you rename the documents to have a .doc extension, then you probably wouldn't have the error anyhow.

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17168229
On most version 6.0.2900.2180...
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17169541
Actually, I don't know why you would get that error since an RTF document should open in either MS Word or in WordPad and not in IE.  If you would still like to find out what the error was caused by, please post the entire error message (which is probably still in your Application Event Log).  I realize that the error message would be in German which is fine.

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17174775
Unfortunately, nothing appears in the event logs. Only a dialog box with the following info (in German, my translation is above):

=========== paste ===========

Windows-Sicherheitswarung:
Dieses Dokument enhält Code, den die Sicherheitseinstellungen nicht zulassen. Es wird deshalb eventuell nicht richtig angezeigt wird.

Sollte ich das Dokument öffnen?

=========== paste ===========

Thanks for your continued help.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17175231
omb, what version of office is installed on the machines that are having these errors?

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17201861
As already mentioned, the docs are created in Wordpad (I often do this on servers so that I can capture screenshots of important setup or info screens. Office is not installed on any of the servers from which I get this error.

Any ideas?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17201904
your question didn't say anything about you opening these on servers and getting the error, it said client PCs?  Office is not installed on any of those?

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17270373
No - office is not installed on them.

Sorry, but the rtf's were being opened on the servers themselves. If the doc was local, no problems. Across the network (i.e. from a network share) the error comes up.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17274963
So, what happens if you rename the .rtf documents to have a .doc extension?  This should resolve the issue... the problem being that .rtf documents are actually html and can therefore execute code.

.doc files should still open fine in Wordpad.

Jeff
TechSoEasy
0
 
LVL 3

Author Comment

by:omb
ID: 17276917
Unfortunately this did not work.

However, I've got a solution / workaround. I added all servers to the trusted sites in IE Security - this did the trick. What I don't understand it why?
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 100 total points
ID: 17284361
that'll work... it's because the documents are opening in IE.  .rtf is no different than .html as far as scripting and security goes.  Which is why renaming them with a .doc extension should have resolved it... unless you also have .doc files opening in IE.

Jeff
TechSoEasy
0

Featured Post

ScreenConnect 6.0 Free Trial

Want empowering updates? You're in the right place! Discover new features in ScreenConnect 6.0, based on partner feedback, to keep you business operating smoothly and optimally (the way it should be). Explore all of the extras and enhancements for yourself!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question