Improve company productivity with a Business Account.Sign Up

x
?
Solved

Strange networking between XP ME

Posted on 2006-07-04
6
Medium Priority
?
369 Views
Last Modified: 2013-12-07
I have a home user, 2 machines, XP Home SP1 and WinME, the XP had a virus, removed with no major problem, then the LJ4L died, she replaced it with a newer LJ1320, she can print and everything else, but for some strange reasons, the ME can no longer see the XP shared files/printer, I can ping from ME to XP and XP to ME, zonealarm is both opened for both machines 192.68.0.1-192.168.0.250, I have also disabled both firewalls.

The XP can see shared files on the ME, just not the other way round, if I try to connect by network name \\AlexXP  from WinME, it just said resource not found.

So far I have removed NetBUEI, Windows Networking, File and printing on both machines and reinstalled them, same problem, the machine is cleaned (checked by Bitdefender, Avast and Panda, removed afterward), and they just have ZoneAlarm and AVG on them, and as said earlier, ZoneAlarm were first disabled and then shutdown with same result.

Anyone could suggest something to head for ?

Many thanks
0
Comment
Question by:robertdims
  • 2
4 Comments
 
LVL 4

Author Comment

by:robertdims
ID: 17037188
Forgot to say, Guest account is also enabled.
0
 
LVL 43

Expert Comment

by:Steve Knight
ID: 17037247
Is netbios enabled on the properties of tcp/ip on the XP machine?  Can you get to the other with Start | run \\ipaddress in which case maybe add an LMHOSTS and/or HOSTS entry for servername against the ip address.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 17037436
Information that I have compiled over the years with lots of good information:

Some information networking XP to non-XP. XP has a whole new setup and must be adjusted to be backward compatible.

--------------------
Differences between Windows XP Home and Professional
http://www.wown.info/j_helmig/wxpdifs.htm

--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin (yes, some AV products have built-in firewall), VPN client (Raptor Mobile, Cisco VPN), et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040

----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP

   Click Start, click Control Panel
   Click Network Connections.
   Right-click "Local Area Connection", and then click "Properties".
   Click on (highlight) "Internet Protocol (TCP/IP)", and then click "Properties" button
   Click the General tab, and then click "Advanced" button , bottom right.
   Click the WINS tab.
   Under "NetBIOS setting" section, click Enable NetBIOS over TCP/IP, and then click OK two times, the "close".
     ( ) Default
     (*) Enable NetBios
     ( ) Disable NetBios

   Reboot the computer.


Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.
--------------------------

Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled

Now you may disable the Guest account as recommended for improved security (for the XP box).  Without this set properly nothing will work for XP!

--------------------------
There's a different Guest account setting that controls networked access to XP's shared disks and folders when simple file sharing is enabled.

To enable networked access, enter this line at a command prompt:

   net user guest /active:yes

To disable networked access, enter this line at a command prompt:

   net user guest /active:no
0
 
LVL 4

Author Comment

by:robertdims
ID: 17037814
Thanks all, I see two key points here that might help, as I am not near the machines so I cant check but from memory from last week, NetBIOS were enabled and browser for both WKS/Server were enabled, but I need to double check it again on Thursday.

What foxed me is that the whole thing were working fine before, and these users never changes any settings without first asking for advice, so how the links broke is beyond me.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Unable to change the program that handles the scan event from a network attached Canon/Brother printer/scanner. This means you'll always have to choose which program handles this action, e.g. ControlCenter4 (in the case of a Brother).
In short, I will be giving a guide on how to install UNMS on a virtual machine in hyper-v and change the default port for security (you don’t need to have a server, since Windows 10 supports hyper-v)
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

595 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question