Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

The network connection to your application was interrupted

Posted on 2006-07-04
9
Medium Priority
?
1,710 Views
Last Modified: 2008-01-09
I am trying to access an application using the web client and once I click on the icon of the published application, I receive the following message: "The network connection to your application was interrupted. Try to access your application later or contact the technical support".

I have tried deleting the MSLicense key with no results. I have updated the NIC Drivers and still no go. It is obviously a local desktop issue since I have some PCs from which I am able to connect to the application.
I even used the same network connection for two separate PCs both running Windows XP and I was able to connect only from one of the PCs. I encountered the same issues on Windows 2003 server machines.

Citrix said that this could be a local policy issue but they did not give any other suggestion. I have checked the local policies and did not find anything unusual.

I've also disabled MacAffee and Windows Firewall.
0
Comment
Question by:smoga1968
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 13

Expert Comment

by:ET0000
ID: 17043990
Is it only this application that is affected, or is it any application on these clients?
0
 

Author Comment

by:smoga1968
ID: 17044421
Actually there is only one application published at this point.
0
 
LVL 13

Accepted Solution

by:
ET0000 earned 2000 total points
ID: 17046140
Check to ensure that your license server is up and working correctly. If the working machines already have licenses, they won't notice that the license server is down, but a machine that doesn't yet have a license (or had a temporary one that expired) will fail when they can't get a license.

You may want to try publishing something simple like NotePad to see if the error occurs there or is specific to your currently published application.

0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 

Author Comment

by:smoga1968
ID: 17049938
Thanks ET0000 this is something I will definitely look into.
0
 

Author Comment

by:smoga1968
ID: 17050217
ET0000, I did a quick test by exporting the MS Licensing registry key from a PC that is able to connect to the Citrix application and import it into a PC that we could not connect from and we were able to access the application fine which proves your theory that this is a licensing related issue. Now we need to find out why some PCs are able to grab a license and others are not.
Thanks a lot
0
 
LVL 13

Expert Comment

by:ET0000
ID: 17052810
Glad to hear you are on your way to connectivity!

A good place to start would be license counts (and the licensing mode - by device or by user).
0
 

Author Comment

by:smoga1968
ID: 17052940
My machine still doesn't grab a license after I delete the MS Licensing key. And we are using per user licensing. Any suggestions ET000?
0
 
LVL 13

Expert Comment

by:ET0000
ID: 17055239
I'm assuming you've checked the most obvious thing, which is whether there are any licenses available.

You should probably check the event log on the licensing server to see whether any information is being logged there when the license request comes in.

The article link below describes something that isn't the same error, but that could be because Citrix is masking the error (you could try an RDP connection from the problem machines to see if there is a more information message for that connection),
   http://www.windowsitpro.com/Article/ArticleID/25607/25607.html?Ad=1

However, unless there was a change on your license server, or these are your only XP machines, I'd think twice about fiddling with the certificates on the server, since other machines are working OK.

0
 

Author Comment

by:smoga1968
ID: 17055516
Actually somebody deactivated the TS Licensing server and installed a new one but it did not install any permanent licenses. When the temporary licenses expired for some of the clients, they were not able to connect to any ICA sessions.
Thank you ET0000 for pointing me towards the right answer.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #XenDesktop #POC #Proof-of-concept
Citrix XenDesktop 7.6 Citrix Policies Disable Peripherals
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question