Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1585
  • Last Modified:

Slow wireless speed and connection loss with full strength signal

I have a laptop with an Intel PRO/Wireless 2200BG wireless card and I'm trying to connect to our network.  We have a Linksys WRT54GS V.2 router and a Linksys WAP54G V.1 access point acting as a repeater.  I can view our wireless network and I am using 128 WEP encryption.  I get 54mpbs speed and Excellent signal strength.  Internet access is relatively quick at times but more than often I get kicked off or I experience extreme latency.  I thought it might be our ISP but there have been times when I have gotten a reply over 3000ms when pinging our router.  I experience the same thing regardless of the distance away from the wireless router or the access point.  I sometimes can view the network and try to connect to it and it'll say "Waiting for the network..." but I cannot connect even with Excellent signal strength and 54mbps speed.  DHCP is enabled on the router and a wired connection works with no problems.  I have also updated all drivers and firmware for all hardware.

Does anyone have ideas on what I can do to improve my connection on this wireless network?
0
adonaicomputers
Asked:
adonaicomputers
3 Solutions
 
ChrisMacleodCommented:
How many other networks are in your area and what channel are they on?  What channel are you using?

You can download a program called net stumbler to help you get this information.  I think other networks maybe causing some interference.
0
 
adonaicomputersAuthor Commented:
We are on channel 6.  There are quite a few networks around this area.  Other channels are 1, 6, 9, 11 right now but I know at different areas of our house there are more networks.  I changed the channel on our router and AP to 7.  The connection seems a bit steadier and I ping the router with16ms while another laptop beside me gets 1-2ms.  The other laptop pings my computer at 800-3500ms.  The connection seems a lot steadier now but another computer downstairs receives full bars when viewing wireless networks but will still say "Waiting for the network..." and never connect.

Any other ideas?
0
 
victornegriCommented:
Wireless networks should have at least 1 channel between them for the least amount of noise. Try changing your channel again but choose something that's the farthest away from other networks in your area (i.e. Ch.3-4). Also, see if your AP has a setting for robustness or increased signal strength.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
adonaicomputersAuthor Commented:
And although the connection is a lot steadier now, the connection seems slow; especially compared to another laptop right next to me.
0
 
ChrisMacleodCommented:
Each channel actually works on a range of frequencys and they overlap checkout the site below.

http://www.qsl.net/n9zia/dsss-channels.html


You need to find a clear channel which is most likely going to be 1, 6 or 11.  May not be possible by the sounds of it in your case.  
0
 
adonaicomputersAuthor Commented:
I am now on channel 3 and it looks like connections are a lot steadier.  I also changed a few network card settings on the other computer in the basement and it is now connected fine.  The connection is fairly fast and 1ms ping from the router.  I am even closer to an access point with this laptop but still only get a ping of around 20ms from the router and the connection seems relatively slow compared the the computer in the basement.  A laptop with the same wireless card right beside me gets a low ping from the router around 2ms.
0
 
Steve KnightIT ConsultancyCommented:
I agree about the issues of overlapping channels however you will nearly always find it works though potentially slowly though not in the way you are getting with a high latency.  We put 11 AP's in at one place to cover the whole site and naturally there had to be some overlap of channels, I could move from one area with an AP on channel 1 say and walk down until signal was low on Channel 1 then it would switch over to another access point which also happened to be on Channel 1 without even missing a PING -- i.e. access to two AP's on the same channel at the same place...  

Load up net stumbler as suggested and walk around your house you might find the spectrum is more crowded than you think though from what you suggest channel 3 or 4 should be best as victornegri says.

0
 
adonaicomputersAuthor Commented:
I went into the wireless card settings and some settings were not the default value.  Once I used the default values I was getting a ping of 1ms from the router.  The wireless connection here is also now a lot more stable because of using a different channel.  Thank you everyone for all of your help, I appreciate it.
0
 
adonaicomputersAuthor Commented:
I also realized that the lower my battery power was, the lower my connection speed was too.  I was trying all of this with less than 50% battery power which was why I was getting 16ms ping.  When I plugged in my power adapter I received 1ms immediately.  Thanks again for everyone's help.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now