Solved

Windows can't detect my modem on startup

Posted on 2006-07-04
11
333 Views
Last Modified: 2012-05-05
Greetings,

I'm having a really weird problem. Windows can't seem to detect my modem anymore on startup. I have an external U.S. Robotics 56K Faxmodem USB which has worked perfectly for two years. Only recently, whenever I boot up my computer (AMD Athlon 2800+ with Windows XP Pro SP2), the LED on my modem fails to light up and essentially the modem is not detected by Windows (is non-functional). The problem is reproducable on every boot.

Also, (here's the wierd part) I can 'fix' the problem by simply unplugging the line that plugs my modem into a USB port in the back of my computer while the computer is on and then simply plug it back in again and the LED on my modem will now light up and the modem is fully functional but only as long as the computer remains on. As soon as I turn off the computer and then turn it back on again, the same scenario happens where the modem is not detected. This only happens on a cold reboot (full shut down, wait ten seconds, turn back on again). If I click Start >> Turn Off Computer >> Restart then the modem remains detected and fully functional.

I've tried everything I can think of to fix this problem including reinstalling the modem software, changing the COM port # for the modem, plugging it into a different USB ports (they all produce the same problem).

This is kind of an annoyance more than anything. I can get the modem to work but not after unplugging and replugging it into the USB port. I'd like to get this working back to the way it was normally, i.e., Window detects my modem on startup, the LED lights up and the modem is fully functional automatically.

Any help would be appreciated. I'm clean out of ideas.

Thanks.
0
Comment
Question by:matt_bell
  • 6
  • 4
11 Comments
 

Author Comment

by:matt_bell
ID: 17038927
I'd also like to add that I suspect that this MAY have something to do with starting to use one of my USB ports to download photos off my digital camera but I only plug my camera into the port when I want to download the pictures after which I unplug the line from the USB port. It seems to me that this modem problem started when I got my digital camera (but then again it may just be a coincidence).
0
 
LVL 70

Expert Comment

by:garycase
ID: 17039122
Do you "Safely Remove" the camera when you use it?   ... if not, try plugging it in; then correctly (Safely Remove) removing it.   See if that changes your behavior.
0
 
LVL 2

Expert Comment

by:monkeyjr
ID: 17039740
Have you update or change BIOS setting recently?
0
 

Author Comment

by:matt_bell
ID: 17041509
garycase,

Sheesh, I didn't even know you had to do that. The documentation that came with my digital camera is very poor (Rollei dt4200). It didn't mention a thing about safely removing the camera. I just figured it was good enough to make sure the power was off on the camera before plugging or unplugging the USB cable. Okay so I tried plugging it back in and, by clicking on the icon in the system tray, I found the option to 'Safely remove USB...etc' and I did that, unplugged the camera cable, rebooted the computer and the modem is still dead on startup. So, assuming this is the problem, what do you figure I've done here by not 'safely removing' my camera? Have I corrupted something in the Windows registry or have I permanently fried something on my motherboard?

monkey jr,

No I didn't update or change anything in the BIOS prior to this problem starting to happen (although I've been poking around in there since looking for some relevant option). The only other change I've made with my computer recently is I put in a new LCD monitor (to replace an old CRT). But this new monitor plugs into the normal VGA port (?) on my computer so I can't imagine that having an effect on anything (although I could be wrong).
0
 
LVL 70

Expert Comment

by:garycase
ID: 17042993
Okay ... unplug all of your USB devices.   Go into Device Manager (right-click on My Computer; select Properties; click the Hardware tab; then click on Device Manager)  and Uninstall ALL of your USB controllers and hubs (everything under Universal Serial Bus Controllers => expand it by clicking the "+" sign; then for every entry right-click and choose "Uninstall").   Then close Device Manager and shut down your computer (shut it down -- don't just restart).    Now reboot the computer -- all of the USB ports/controllers will be redetected and re-installed.   Now plug in your modem and see if the symptoms have changed.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:matt_bell
ID: 17046099
Okay garycase, I tried everything you suggested and still no go. I also tried uninstalling my modem driver altogether and then uninstalling all the USB ports as you suggested and then reinstalling everything and still no go. In fact, my situation has now gone from bad to worse because now my modem repeatedly connects (and only connects) at 33.2 Kbps. This problem was usually corrected by applying an updated driver but for some reason applying the updated driver no longer works and its the same updated driver I've been applying for the past two years whenever I had to reinstall the modem for whatever reason and it's never failed to work. I also noticed that when I check in Add/Remove programs in Control Panel, the file installation size of my U.S. Robotics modem is only .28 MB whereas it used to be .52 MB. I'm starting to freak out here a little bit.
0
 

Author Comment

by:matt_bell
ID: 17046235
Further update: I just disconnected my modem from AMD 2800+ and plugged it into my backup computer (AMD Duron 900Mhz) which I haven't used to go on the internet since Christmas. Fortunately it still had all the drivers and whatnot installed for this modem. Windows detected the modem without any problem at all on startup and I logged on and getting normal connection speeds (ranging between 46.6 and 48 Kbps) so we can rule out the modem as being the problem. Seems to me it's working perfectly. I also checked the U.S Robotics Faxmodem file installation size on this computer and it is indeed .52 MB so something really wierd is going on with my other computer.
0
 

Author Comment

by:matt_bell
ID: 17046249
I'm seriously considering reinstalling Windows on my AMD 2800+ (although is will be very time consuming since I've got over 100 programs installed on it). Is there anything else I should try before taking such drastic measures?
0
 
LVL 70

Accepted Solution

by:
garycase earned 250 total points
ID: 17047484
Clearly you've got the wrong US Robotics drivers installed on the 2800+ machine.   Compare the versions between your two computers and install the same version on the 2800+ as the other machine.   That should resolve the connection speed issue -- but perhaps not the "disappearing modem" problem.   Reinstalling Windows is indeed a "drastic" step (I can empathize -- I've got about 300 programs installed); but may be the best approach to ensure the system's really cleaned up.

Before you try that, try doing this:  (a)  unplug your modem;  (b)  remove all of your US Robotics software;  (c)  remove the modem from Device Manager (if it's still shown);  (d) run RegSupreme on your registry (http://www.macecraft.com/);  (e)  repeat the USB removal & re-detect from my last post ==> after you've done all that reinstall the modem and see if the symptoms improve.  Be SURE you're using the same drivers as the other computer.
0
 

Author Comment

by:matt_bell
ID: 17057274
Thank you, garycase!

Especially for pointing out that I had the wrong drivers installed. I don't know why but Windows was misbehaving and even though I was pointing it to the right drivers during the reinstallation of the modem, it kept installing the wrong drivers. It was only after reading your comment that I got the idea to force Windows to install the drivers directly from my updated driver file folder. I didn't know this could be done nor have I ever had to do it before but it seems I don't even need the modem installation disk to install the modem anymore. So that fixed the connection speed issue.

As for the 'disappearing' modem thing, for all intents and purposes it's fixed as well. I ran the last ditch procedure you suggested, used RegSupreme (and a couple of other registry cleaners and man did I clean up a LOT of crap, and my computer is even booting faster now).

Now Windows detects my modem on startup pretty much everytime EXCEPT when I do what I call a 'quick' cold boot (shut down the computer, wait ten seconds, start the computer up again). If I do a quick cold boot then Windows doesn't detect my modem. It seems that my computer has to be shut down for a minimum amount of time (I have yet to determine exactly what this is but it's at least half an hour) in order for Windows to detect my modem on startup. Weird, eh?

Before all this mess happened, a quick cold boot posed no problem with regards to Windows detecting my modem. But anyway my situation is now is close enough for rock 'n' roll so I'll award you the points but if you have any further suggestions regarding my no-modem-detect-on-quick-cold-boot problem, I would really appreciate it.

Thanks for all your help.
0
 
LVL 70

Expert Comment

by:garycase
ID: 17058683
You're most welcome.    Glad it's working well now -- and even the detection of the modem seems to be working "okay" ==> I suspect in normal use you never do a "quick" cold boot.   Something is retaining a bit of power and taking a while to drain -- but isolating exactly what could be a very time consuming process and isn't worth bothering since it's working nicely.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now