• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1583
  • Last Modified:

MSCRMExRouterService Error in Microsoft CRM 3.0

Our environment consist of 4 servers all using Win2003 Server. They are each an AD, Exchange, File, and CRM 3.0 server.

On our Exchange logs we see a MSCRMExRouterService error (see below). As per KB article #908390, it says we need to make sure the Exchange server is a member of the PrivUser group in the AD service. What's odd is that we don't even have a PrivUser group at all.

Thoughts?

*************

Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceException: Verifying before delivery message: Re: Re: in mailbox: CRMadmin failed (System.Net.WebException: The request failed with HTTP status 400: Bad Request.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.Crm.Platform.Proxy.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
   at Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger logger, ExchangeSinkServiceMailbox mailbox, Message message)). ---> System.Net.WebException: The request failed with HTTP status 400: Bad Request.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.Crm.Platform.Proxy.EmailWebService.CheckIncoming(String messageId, String subject, String from, String to, String cc, String bcc, Int32& reasonCode)
   at Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger logger, ExchangeSinkServiceMailbox mailbox, Message message)
   --- End of inner exception stack trace ---
   at Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger logger, ExchangeSinkServiceMailbox mailbox, Message message)
   at Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMessage(Connection connection, ExchangeSinkServiceMailbox mailbox, Recordset recordSet)
   at Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMailbox(ExchangeSinkServiceMailbox mailbox)
0
leeym
Asked:
leeym
1 Solution
 
ck_damuCommented:
I had a similar problem.
Please reinstall the router and make sure you give the email forwarder address and its must be a valid mailbox and must be disabled and then please run the deploy and verify rules on the mail boxes.
Hope this helps.
0
 
leeymAuthor Commented:
That's what we already did. we will try it again, but still don;t see the PrivUser security group. Am I missing something here? Thanks
0
 
preitmeyerCommented:
Hey Leeym,
I have written a 65 step document on how to resolve this issue, however, it is internal and not for public use :-).
Anyways, the simple answer to your problem is this:

Open services.msc on your Exchange Server where the router is installed. Go to the "Microsoft CRM Email Router Serivce".
Right click the service and go to properties
Go to the Login Tab (or whatever it is called) and change the user that runs the service from 'Local System' to the user you selected as the CRM Email Router Mailbox user. So for instance, if during install you said you wanted crmemail@whatever.com to be your user for the CRM Email Router, than you must make that user run the service (I know, its a bug and Microsoft is working on it). Also, go into Active Directory and find the user (in our case it would be crmemail), and go to the "Member Of" tab, add the user to the "PrivUserGroup" and press OK. Once you have the crmemail user running the service and in the PrivUserGroup, restart the service and your errors should dissappear as well as all emails should work properly. If you have more issues, try adding the crmemail user to the "Domain Admins" group in Active Directory as well. If you have any issues, email me preitmeyer@gmail.com as I dont check this website very often.
Good luck!
-Paul
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
preitmeyerCommented:
Wait, I just read your comments above in the question... you dont have a PrivUserGroup ? it is installed by default when CRM is installed. The location of the group is wherever you specified it during the CRM Server 3.0 Installation (usually at the root of your AD Domain, sometimes in an OU called CRM). If you dont have it anywhere in AD you have different issues. Open Active Directory users and computers, click on your domian, and then click "Actions", then "Find" and just type "Priv" and click search (make sure you are searchnig for Users and Groups in the first option). I hope the group is there since the crmemail user MUST be a member of this group and MUST NOT be a CRM user.
-Paul
0
 
leeymAuthor Commented:
Through a MS CRM posting we found the answer. Check out this link:

http://www.microsoft.com/Businesssolutions/Community/NewsGroups/dgbrowser/en-us/default.mspx?dg=microsoft.public.crm&mid=7f97f9b3-f52d-4ea1-b64d-3298f6e96570

Check out David P's response from 5/23/06. Especially step #5. Everyone else missed that step, and after doing so, all seems to be fine.

Thanks
0
 
DarthModCommented:
PAQed with points refunded (125)

DarthMod
Community Support Moderator
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now