Problem with Remote Desktop

Hi there

Situation: We recently changed our ISP, and how it worked in the past is that we had a router (with a fixed IP address on the Internet) connected to a firewall and the rest of our network. When i wanted to access our server through remote desktop, VPN, and our internal tomcat applications it was simple, all i did was forward the relevant ports on the firewall to the server, connected via the router IP address,  and it all worked perfectly.

However, now for some reason (BT says its security reasons) the IP address of our router does not stay fixed (It changes every couple of days). When I use this IP address for VPN, remote desktop etc. it all works perfectly, however I cant keep working like this as i never know when the IP is going to change. So what I did is ordered a static IP address from BT and assigned it to the server so that our server is visible direclty through that IP address on the internet, which stays constant. However, whenever I try to connect to that IP through VPN, remote desktop it says the the remote pc is busy, or not accepting and more connections etc.

Any Ideas? Its a server 2003 with 2 network cards, one with the static IP address on the Internet, and the other with an internal IP address.

Cheers
AndriesKeunAsked:
Who is Participating?
 
life_jConnect With a Mentor Commented:
Downlaod No -ip from the below link and install on your machine.You need to register with no Ip.The registration details need to be entered on your client software that you are installing.


http://www.no-ip.com/downloads.php

Can you telnet your Static IP from outside your network on port 3389
0
 
life_jCommented:
Open terminal service manager and see how many users are connected to the server. At the most only 2 remote users can connect unless its a terminal server.If there are already 2  remote users.logoff the users and try connecting again.

For you knowledge if you don't have a static Ip you can install no-ip on your server which updates the Ip address to a hostname. so you can use host name to connect instead of Ip. This way you don't need to remember the IP address.
0
 
AndriesKeunAuthor Commented:
>> For you knowledge if you don't have a static Ip you can install no-ip on your server which updates the Ip address to a >> hostname. so you can use host name to connect instead of Ip. This way you don't need to remember the IP address.

Can you elaborate on this a bit wrt my setup please?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AndriesKeunAuthor Commented:
sorry, forgot to add. checked terminal services and there is only one remote user, which was me logging on to check how many remote users there was.
0
 
AndriesKeunAuthor Commented:
think i found the problem. sometimes it works, and other times it doesnt.

there are two network cards on my server, one for the internal network IP 200.0.0.10 and one with the static ip address on the internet. the internal one is used for everyone to access the server, and i want the external on so we can access it from outside.

Problem is that sometimes the server uses the static ip to connect to the internet, and other times it uses the internal ip which goes through the router and uses that IP address (the one that is constantly changing)

Is there anyway to disable the internal IP network card so that it does not even try to acces the internet, but still works on the internal network?
0
 
BLipmanCommented:
You really should not be using a server to bridge your internal network with the Internet, you are begging for trouble.  The safer way to do this is to place the server behind a router and/or firewall, use private address internally, and NAT just the ports you need across the firewall/router.  
0
 
AndriesKeunAuthor Commented:
>>You really should not be using a server to bridge your internal network with the Internet, you are begging for trouble.  The safer way to do this is to place the server behind a router and/or firewall, use private address internally, and NAT just the ports you need across the firewall/router.  

If you read my post you would see that that is how i used to do it, the problem is the IP address of my router is constantly changing (Our ISP says its so that it is more secure and there is now way to keep it static). So I can access my server etc. through the router with a VPN, RDP etc. when i know the IP of the router, but when it changes i have no way of knowing what it changed to.
0
 
AndriesKeunAuthor Commented:
Cheers mate, no-ip works like a dream. And its free :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.