Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 443
  • Last Modified:

Again the "classic" problem sending to AOL.com

Hi All,

I know the features required by AOL (http://postmaster.aol.com/trouble/mailer.html) and I have followed these excellent tutorials at http://www.amset.info/exchange/dnsconfig.asp and http://www.amset.info/exchange/smtp-connector.asp but I still have the "classic" problem sending to AOL.com.

I have Exchange 2003 SP2 + W2003 DC server + Popcon pop3 connector. I have the Virtual SMTP server forced to use external DNS (due problems with exchange and non exchange users). Then I can send OK to all places, except AOL.com that is allways retrying.

It seems that all is checked ok. As I am at DSL line with static IP and my ISP can't add my DNS reverse setup ok, I have setup a SMTP Connector only for AOL domain. I also have configured my SMTP Virtual server propierties with mail.mydomain.com (these name is correct because if you type this from WAN you will get to my IP). I put mail.myhosting.com or its Ip with [ ] and with its SMTP authentification detail login etc.

At the queue list I see that the AOL pending emails are changed to another queue list "Relay for Aol.com [217.xxx.x.x.x]" But I get error: the remote server do not respond to connection (translated to english, sorry).  I tried too with the server name of ISP mail server and the same. All AOL.com messages are still re-trying.

Any ideas? Thank you all
0
isaacmateo
Asked:
isaacmateo
  • 5
  • 4
2 Solutions
 
harleyjdCommented:
If you have a cisco firewall try turning off EDNS0

DNS query responses do not travel through a firewall in Windows Server 2003
http://support.microsoft.com/kb/828263

0
 
isaacmateoAuthor Commented:
Hi Harleyjd,

Thank you for your information. I have followed method 2 (due I do not have any cisco firewall). I have installed Support Tools and from promtp I insert: dnscmd /config /enableednsprobes 0
I get that the command was ok and registry enableednsprobes was successfully reset, but it fails again.

If I try without extra SMTP connector y get "Error SMTP protocol"
If I try using extra SMTP connector y get "the remote server has not respond to connection"

Any ideas?
0
 
SembeeCommented:
If you have configured the SMTP Connector correctly, then the problem is with the server that you are trying to send email through.
Do you need to authenticate when you send email via that server? If it is for your hosting company and not your ISP, then you probably will. Configure authentication on the SMTP Connector.

If you are using your hosting company, then try your ISP - you usually don't have to authenticate to use their servers.

Simon.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
isaacmateoAuthor Commented:
Hi Sembee

I think I have configured ok the SMTP connector, I tried with its hosting company domain name, and with its IP [ ]. I also have basic authentification (this server needs it) configured.
Do you know any "open" or free relay for doing this tests? I think my smtp login and pass are well configured but...

Thanks!
0
 
SembeeCommented:
An open relay is exactly that - an open relay, and therefore don't exist (on purpose anyway).

Can you telnet to port 25 of the address that you have entered in to the smtp connector?

telnet mail.hosting.net 25

Simon.
0
 
isaacmateoAuthor Commented:
Hi,

I mean a "open" SMTP without authentfy for doing tests... Anyway:

I test:
telnet mail.mydomain.com 25:

I get:
220 mail.mydomain.com Microsoft ESMTP MAIL Service, Version: 6.
0.3790.1830 ready at  Wed, 5 Jul 2006 15:59:55 +0200

If I test this:
telnet servername 25

I get the same:
220 mail.mydomain.com Microsoft ESMTP MAIL Service, Version: 6.
0.3790.1830 ready at  Wed, 5 Jul 2006 15:59:55 +0200


Then I suppose this is ok?

0
 
SembeeCommented:
Did you enter mail.mydomain.com in to the SMTP Connector?
If so, that is wrong. It should be your ISPs SMTP Server. At the moment you are just routing the traffic back on itself.

Simon.
0
 
isaacmateoAuthor Commented:
Ok,

It works! I must to put smtp.myhosting.net into SMTP server connector... Thats all :)

Anyway following harleyjd comment I have modified dnscmd /config /enableednsprobes 0... Must I re-config this one?

Thank you a lot both :)
0
 
SembeeCommented:
That DNS change doesn't do any harm, so you can leave it in place.

Simon.
0
 
isaacmateoAuthor Commented:
Thanks both
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now