?
Solved

Cisco PTP - External CSU/DSU moving Internal - QOS to follow

Posted on 2006-07-05
8
Medium Priority
?
455 Views
Last Modified: 2006-11-18
To Whom It May Concern:

I have a fully functioning point-to-point using old cisco routers with an external CSU/DSU (MCK units to be exact). I have purchased two new routers with internal CSU/DSU (CISCO1841-T1 to be exact). More ... I will require QOS in the near future.

Note: The current point-to-point is spliting the T1 into 12 channel voice and 12 channels data. The new configuration will be using 100% data.

Question 1: I was told that the IOS that comes with the router will not do QOS/traffic prioritization and that I would need to get a IP_VOICE IOS from Cisco? Is this true?

Question 2: The following configuration is being used for the point-to-point routers (with an external CSU/DSU). I now have an internal CSU/DSU and I'm not sure what changes need to be made to the configuration (clocking, framing, etc), please assist.

Question 3: Hopefully after you make the necessary corrections to the configurations for the internal CSU/DSU you can explain the following:
a. If you are adding the segment controller T1 1/0, what is this used for and when is it used?
b. You will notice that the current point-to-point configuration doesn't have an encapsulation on S0, why?
c. What type of cable will connect from the wall jack with the live circuit to S0/0 on the router? Cisco specific I imagine.

Regards,

Mike

Router 1:
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2451-1440
!
enable secret
!
ip subnet-zero
no ip source-route
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Connected to LAN
 ip address 10.0.0.70 255.255.224.0
 no ip redirects
 no ip directed-broadcast
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 description T1 (channels 1-12)
 bandwidth 768
 ip address 172.30.17.1 255.255.255.0
 ip helper-address 10.0.0.23
 no ip redirects
 no ip directed-broadcast
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 172.30.16.0 255.255.255.0 Serial0
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7
 login
!

Router 2:

Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 1440-2451
!
enable secret
!
ip subnet-zero
no ip source-route
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Connected to LAN
 ip address 172.30.16.70 255.255.255.0
 ip helper-address 10.0.0.23
 no ip redirects
 no ip directed-broadcast
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 description T1 (channels 1-12)
 bandwidth 768
 ip address 172.30.17.2 255.255.255.0
 no ip redirects
 no ip directed-broadcast
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password x
 login
!
end
0
Comment
Question by:ilovespam12000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 10

Expert Comment

by:naveedb
ID: 17046465
Question 1: I was told that the IOS that comes with the router will not do QOS/traffic prioritization and that I would need to get a IP_VOICE IOS from Cisco? Is this true?

Your T1 will have data only? Then you can configure it with IOS you do not need IP_VOICE IOS.


Question 2: The following configuration is being used for the point-to-point routers (with an external CSU/DSU). I now have an internal CSU/DSU and I'm not sure what changes need to be made to the configuration (clocking, framing, etc), please assist.

What have you set on the external CSU/DSU for clocking, framing etc.? Please provide it and we can recommend the changes.

Question 3: Hopefully after you make the necessary corrections to the configurations for the internal CSU/DSU you can explain the following:
a. If you are adding the segment controller T1 1/0, what is this used for and when is it used?
b. You will notice that the current point-to-point configuration doesn't have an encapsulation on S0, why?
c. What type of cable will connect from the wall jack with the live circuit to S0/0 on the router? Cisco specific I imagine.

Will answer once we have more information from Q2.
0
 

Author Comment

by:ilovespam12000
ID: 17046594
Question 2:

I'm not very familar with the external CSU/DSU and it only a very small LCD. The routers will be connected to a new point to point circuit. Since the desired configuration will not include the external CSU/DSU or the prior circuit, can we make the assumption that no clocking or framing has been set and proceed to the configuration?
0
 
LVL 10

Expert Comment

by:naveedb
ID: 17062890
You can get the information from carrier, they will be able to provide it to you.

If you can provide us with the model number of external CSU/DSU, we may be able to get the information from it.

Cisco has defaults for framming etc., which may or may not be same as the external CSU/DSU. So not setting them may not work.
0
Plug and play, no additional software required!

The ATEN UE3310 USB3.1 Gen1 Extender Cable allows users to extend the distance between the computer and USB devices up to 10 m (33 ft). The UE3310 is a high-quality, cost-effective solution for professional environments such as hospitals, factories and business facilities.

 
LVL 4

Expert Comment

by:mattbcs
ID: 17064345
The cisco wic has an internal csu/dsu and is quite handy... I've got several of these set up in a p2p situation.

I'm asuming location 1 has a different subnet than location 2 (good network design practice dictates this...)
I'm going to give you 2 configs, because one router will have an extra line in it, and if both get that line, then it will not work....


SIDE A

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
enable secret 5 [pick one]
enable password [pick one]
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
!
!
!
!
interface Serial0
 description RouterA to RouterB
 service-module t1 clock source internal
 ip address 172.16.1.1 255.255.255.0
 encapsulation ppp
 no fair-queue
!
interface FastEthernet0
 description Location A LAN Connection
 ip address 172.16.0.1 255.255.255.0
 speed auto
 half-duplex
!
router rip
 version 2
 network 172.16.0.0
 network 172.16.1.0
!
ip classless
no ip http server
!
!
line con 0
 password [pick one]
login
line aux 0
 password [pick one]
 login
line vty 0 4
 password [pick one]
 login
!
no scheduler allocate
end

---------------

The Other Side:


service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
enable secret 5 [pick one]
enable password [pick one]
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
!
!
!
!
interface Serial0
 description RouterB to RouterA
 ip address 172.16.0.2 255.255.255.0
 encapsulation ppp
 no fair-queue
!
interface FastEthernet0
 description Location A LAN Connection
 ip address 172.16.1.1 255.255.255.0
 speed auto
 half-duplex
!
router rip
 version 2
 network 172.16.0.0
 network 172.16.1.0
!
ip classless
no ip http server
!
!
line con 0
 password [pick one]
login
line aux 0
 password [pick one]
 login
line vty 0 4
 password [pick one]
 login
!
no scheduler allocate
end

If this doesn't work for you, let me know, as it's 2:30am and I'm a bit on the tired side, so i'm not as sharp as usual.

Cheers,
Matt
0
 
LVL 4

Expert Comment

by:mattbcs
ID: 17070672
oops... just noticed I used different ips and subnets than your config, but if you alter the config with them. it should work fine.
Keep me posted.

- Matt
0
 

Author Comment

by:ilovespam12000
ID: 17090017
I noticed that your configuration uses ppp encapsulation and mine uses HDLC. Can I still use HDLC encapsulation?
0
 
LVL 4

Expert Comment

by:mattbcs
ID: 17092810
Yes, HDLC encapsulation will work just fine!

- Matt
0
 
LVL 4

Accepted Solution

by:
mattbcs earned 1000 total points
ID: 17102518
Please keep me posted with your progress, and if you have any problems.

- Matt
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question