Solved

Linksys WRT54G to be used as wireless access point in existing network.

Posted on 2006-07-05
19
11,158 Views
Last Modified: 2009-10-23
I am trying to configure a router as a wireless pass-through for an existing router.  My current network has a firewall also acting as the gateway using an internal IP of 192.168.1.1.  I have contacted Linkssy Tech support and received the following instructions which I followed to the letter.

1. Try to isolate your 2nd router (WRT54G) first by disconnecting everything from it and connect a computer to a regular port. Make sure that the power cord is plugged in.
2. Reset the router for 30 seconds with the power turned on. From the computer open an Internet Explorer browser and type 192.168.1.1 on the address field. Leave username blank and type admin on password, you should be at the Setup Page by now.
3. Click on Setup tab and change the LAN IP address on top to 192.168.1.2 (or to an IP address that is on the same subnet as your network) then hit apply. Note that, it won't go back to the Setup Page, close your browser.
4. Click on Start > Run > type 'cmd', click OK > type 'ipconfig/release' then hit Enter. Once it is released, type 'ipconfig/renew' then hit Enter. You should get a new IP address.
5. Open your browser and type 192.168.1.2 to get into the router's web UI. Near the bottom, you will see a section for DHCP. You would need to disable this option. Click Apply/Save Settings.
6. Click on the 'Advanced Routing' sub tab under Setup. Then change the Operating mode to "Router". Save the settings.
7. Connect the Ethernet cable to any of the numbered ports on the second router and connect the other end to another regular port on the first router.

First If I use a numbered port on the linksys, I can't connect to the router IP at all (192.168.1.120) if I connect it to the Internet port - I can only communicate with the linksys if I am connected directly to it or through wireless.  I can not ping it from another machine on the network. I can not ping another machine through the linksys.  I checked the cables to the linksys from the network. I can use this cable with my laptop and communicates fine.


What am I missing.

Brenda
0
Comment
Question by:LamkaB
  • 9
  • 7
  • 3
19 Comments
 
LVL 12

Assisted Solution

by:Scotty_cisco
Scotty_cisco earned 200 total points
ID: 17044624
Brenda;

if you plug the switched ports 1 - 4 to your existing network then you sill be able to us it as a standard switch or pass through device.  If you chose to manage the switch you need to assign it on the same address range that your current network is under.  So basically make sure nothing is plugged into the WAN port on the router and that if you chose to manage the router that the IP address is in the IP range of your existing network.

Thanks
Scott
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17044697
1.) In the WRT54G configuration, on the main Basic Setup page, on the top Internet Setup section, change the Internet Connection Type to Static IP and just fill in some random information for that section... put an IP that is in a totally different subnet. It doesn't matter what is there. What DOES matter is what you fill in on the bottom Network Setup section. Put the Local IP Address as an IP on your other router's subnet, ie. 192.168.1.254. Disable the DHCP server.
2.) Connect cable from existing router to one of the numbered ports on the WRT54G.

You should now be able to access the WRT54G via 192.168.1.254 and you should be able to connect with your main router (and the rest of the network) wirelessly as well.
0
 

Author Comment

by:LamkaB
ID: 17045315
First, I can not even access the router when the cable is plugged into the numbered ports!

Only when it is plugged into the internet port can I access it.

0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 17045345
so after you have reset the router and if you plug into it with a PC what IP address does your pc get?

go to a dos window and do an IPCONFIG /ALL

what is your gateway?  What is the IP of the machine it should be plugged into port 1 browse to http://(default_gateway) and then you should get a pop up for admin and password.

Thanks
scott
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17045834
Okay, plug it into the WAN Internet port initially so that you can get into the setup and then configure it the way I described above.

After you've configured it as I described, then change the cable to a numbered port instead and you should be able to access it.
0
 

Author Comment

by:LamkaB
ID: 17046548
OK, If I plug a pc directly into port 1 I can log in and set it up as I did.

 After configuring, I am supposed to connect a cable from the main switch to a numbered port.  After doing this, I can not use the router, wireless or otherwise.  If I connect a cable from the switch to the internet port I can talk to the router. I still can't go through the router to the rest of the network or internet.

When plugged into the router directly or switch to internet port I am able to access the set up info through 192.168.1.120

Brenda
0
 

Author Comment

by:LamkaB
ID: 17046576
Also I wanted to note.  We use strictly static IP addresses.  So I am trying to connect with a machine IP 192.168.1.181 and gateway as 192.168.1.1, I also tried gateway of 192.168.1.120.

Brenda
0
 
LVL 10

Accepted Solution

by:
ISoul earned 300 total points
ID: 17046980
Okay, I misunderstood the first time and thought your main router was 192.168.1.120, but I see now that you want the WRT54G to use 192.168.1.120

So my revised initial comment:

1.) In the WRT54G configuration, on the main Basic Setup page, on the top Internet Setup section, change the Internet Connection Type to Static IP and just fill in some random information for that section... put an IP that is in a totally different subnet. It doesn't matter what is there. What DOES matter is what you fill in on the bottom Network Setup section. Enter 192.168.1.120 as the Local IP. Disable the DHCP server.
2.) Connect cable from existing router to one of the numbered ports on the WRT54G.

You should now be able to access the WRT54G via 192.168.1.120 and you should be able to connect with your main router (and the rest of the network) wirelessly as well.

There is no reason why this shouldn't work. I actually have one set up the exact same way.
0
 

Author Comment

by:LamkaB
ID: 17075285
Sorry for the delay in responding.  I just returned to the client site today .  I tried the above instructions and still no luck.  What else can I look at?  Why can I see the router only when I have the main line in the internet port?

Brenda
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 17075309
this does not make sense at all you should not have remote access (wan) access to the unit unless that was enabled in the configuration... you may have a faulty unit...

Thank
Scott
0
 

Author Comment

by:LamkaB
ID: 17075533
I currently have the linksys set up under "Advanced" tab as "router" with Dynamic set to "Both"
I have both ignored the Internet setion and filled with bogus stuff as suggested in previous comment from ISoul. At this time I can only access the router remotely (in other words it will respond to its internal IP of 192.168.1.120) when a cable is attached to the "Internet" port, not when it is connected to a numbered port.  I know this is wierd, but I always try to assume it is a configuration error instead of a hardware failure until I can prove otherwise.

Any other suggestions on a alternative setup?  I am waiting for linksys to respond again with any other ideas too.

Brenda
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17076134
Under "Advanced" tab, the "Operating Mode" should be "Gateway".

I would recommend doing a hard reset and then performing the instructions I described above. I have done this numerous times with the WRT54G so I know it must work...
0
 

Author Comment

by:LamkaB
ID: 17076212
According to Linksys, this needs to be configured as a passthrough ROUTER.

Brenda
0
 

Author Comment

by:LamkaB
ID: 17076548
Ok,  Did a hard Reset (30 seconds) plugged in laptop with dhcp on NIC to port 1 on Linksys.

in browser, typed 192.168.1.1
Screen came up
"Management Mode"
"Firmware Upgrade"...

So... go the most recent firmware from Linksys site. Uploaded and applied.

Said SUCCESSFUL!

Typed 192.168.1.1 in browser again.  Get the same screen!!

Brenda
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17077027
...? It's giving you some management mode screen instead of the basic setup screen?

Just to confirm that we are trying to do the same thing here... the setup I have here is the following:

Our main office router is a Netscreen 5GT that handles the DHCP.
I have a WRT54G that just wirelessly connects the laptop users to the office network. The DHCP requests from the laptops is still handled by the Netscreen 5GT.

Oh, and after you had configured the WRT54G, how is your laptop connected to the network?
0
 

Author Comment

by:LamkaB
ID: 17077232
IF I use the internet port I may be able to get a basic setup screen. Right now I am not able to get past the Firmware upgrade screen!
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17077379
That's really strange. There's no reason it should be stuck in the firmware upgrade screen. And you certainly don't need to be or even should be connected to the WAN port to get into the setup!
0
 

Author Comment

by:LamkaB
ID: 17077921
Ok,

I finally have it.  After several resets.  I have connectivity with the linksys @ 192.168.1.120 and cable in port 2.  I also have the Operating Mode as "Router" and Dynamic set to "both".

My wireless connectivity sucks even though the signal strength says excellent!

I seem to timeout on most of the pings.

I will update my wireless nic driver and try again.  However,  thank both of you for sticking with me.  I will split the points.

Brenda
0
 
LVL 10

Expert Comment

by:ISoul
ID: 17078148
So what changed in your most recent setup?
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now