Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 671
  • Last Modified:

Slow Right Click

I have a *really* slow right click. The thing is, it isn't just when I right click on a file or the desktop - it's when I right click ANYWHERE on ANYTHING..!

It seems that the fade-in effect of the right click menu is just really, really slow.

I don't think it's anything to do with the shell extensions, as it happens even when I right click on the taskbar?

Thanks for any help!
0
lemon1844
Asked:
lemon1844
1 Solution
 
zephyr_hex (Megan)DeveloperCommented:
does the problem occur when you are in safe-mode?
0
 
Justin CollinsIT Support TechnicianCommented:
Try these:
1. go into any folder
click tools->folder options
go to the "view" tab
and uncheck the "automaticaly search for network folders and printers " 
click ok...

Last resort...
2. remove this Key, and all is better ****(make sure to backup your key's before removing, incase it was not the correct one)****

[HKEY_CL@ssES_ROOT\Drive\shellex\ContextMenuHandlers\Format Shell]
0
 
lemon1844Author Commented:
The problem also occurs one the start menu, when I click a menu (e.g. Programs or Accessories) the menu takes ages to load - exactly the same as right clicks do.

I'll try your suggestions, puter_geek, and if that doesn't solve it I'll try rebooting into safe mode...
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
lemon1844Author Commented:
zephyr_hex; The problem doesn't occur when I'm booted into safe mode... Does that bring us any closer to a solution?
0
 
lemon1844Author Commented:
puter_geek, [HKEY_CL@ssES_ROOT\Drive\shellex\ContextMenuHandlers\Format Shell] that key doesn't seem to exist in my registry...
0
 
LeeTutorretiredCommented:
If it doesn't happen in Safe mode, I would suspect one of the startup programs (which do not run in Safe mode) or a driver.  In Windows 98/ME/XP, you can choose which programs are run at startup by using the Microsoft Configuration utility:  click on the Start button, choose Run, type in MSCONFIG (doesn't need to be all capitals), click OK.  Choose the Startup tab, deselect programs to run at startup by removing the check mark.   In Windows XP, just click on the button for Disable All. Reboot and see if the problem goes away.  If it does then re-enable the startup programs one (or a few) at a time, reboot, and when the problem occurs again, there is your culprit.

In Windows XP: If the problem continues to come up with all startup programs disabled, then it is probably a driver or service.  You can click on the Services tab in MSCONFIG, click on the button for Hide All Microsoft Services, leaving only third-party services displayed, then try turning them off in the same way you did for startup programs.  Finally, if third-party services are eliminated from being the cause of the problem, you could try narrowing down on Microsoft services in the same way.
0
 
LeeTutorretiredCommented:
However, it could be your shell handlers.  Take a look at this page:

Right-click is slow or weird behavior caused by context menu handlers
http://windowsxp.mvps.org/slowrightclick.htm
0
 
bz43Commented:
Possible ways to increase system performance and help with the right click mouse issue.  Only suggestions.

1. Open "Control Panel".
2. Double click "System".
3. Select the tab labeled "Advanced".
4. Under "Performance" select "Settings".  The opens the "Performance Options".
5. Select the tab labeled "Visual Effects".
6. Select "Adjust for best performance".
7. This should uncheck every box.
8. If this works then go back to step 1 and try to only uncheck "Show shadows under mouse pointer".

Also, perhaps do the following -
1. Open "Control Panel".
2. Double click "System".
3. Select the tab labeled "Advanced".
4. Under "Performance" select "Settings".  The opens the "Performance Options".
5. Select "Advanced".
6. Confirm both "Processor scheduling" and "Memory usage" are both set to "Programs".

* Also the page file size should have both the "Initial size (MB) " and "Maximum size (MB)" values set at the same size.  
To do this -
1. Open "Control Panel".
2. Double click "System".
3. Select the tab labeled "Advanced".
4. Under "Performance" select "Settings".  The opens the "Performance Options".
5. Select "Advanced".
6. Click "Change" under "Virtual Memory".
7. Select "Custom Size".
8. Try values such as 1.5 times your current memory.  So, if you have 256 MB of memory set the Paging file size to 384 MB.  If anything doesn't work well you can always set the page file size back to "System managed size".  (* If you have 1 GB or more of memory a suggestion is to set the Minimum and Maximum values to 256 MB or 512 MB).

Other avenues to try are checking the "device manager" for a yellow exclamation mark under "Mice and other pointing devices".  If there is a problem under device manager you may have to fix the device driver for the mouse.

~Brian

0
 
LeeTutorretiredCommented:
lemon1844, how about some feedback?
0
 
lemon1844Author Commented:
Getting rid of the fade solves the problem completely, and changing some of the shell extensions helped speed it up a bit more :-)

However this is a P4 3Ghz, 512MB RAM and a Radeon 9700 - so surely it should be able to cope with fading! I probably need to upgrade the graphics drivers, but I've tried that before on this laptop and it wasn't exactly easy (even manufacturer-sepcific drivers had to be installed manually)!

Thanks for the help, though - the fade effect won't be missed :-D
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now