Forwarding to External Email.



I have exchange server 2003 SP2. The default policy doesn’t allow automatic forward.  But I created new Contact under ADUC with external email address (email@yahoo.com) and modified it Override Internet Mail Service setting for this recipient. Then from the my company user account under Exchange General>>Delivery Option>> point to forward to the contact I created earlier and checked the box Deliver message to both forwarding address and mailbox.
The problem is when I tested sending email for any External account to my company email account, it received on my company account and don’t receive copy on the External account (Contact created earlier (email@yahoo.com)), and the original sender will receive message :
This is an automatically generated Delivery Status Notification.

Delivery to the following recipients failed.
       Email@yahoo.com
Message/delivery-status
Reporting-MTA: dns;ServerName.Domain
Received-From-MTA: dns;AnotherServerName.domain
Arrival-Date: Wed, 5 Jul 2006 09:48:28 -0700

Final-Recipient: rfc822; Email@yahoo.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;551 This is not a relay host - mail must be to or
from host domain.
X-Display-Name:

FYI: when I send email from any my company email account, both accounts (internal and the external) receive it.


Thanks in advance!
LVL 1
ManzourAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
SembeeConnect With a Mentor Commented:
The problem here is not with your server.

"This is not a relay host - mail must be to or from host domain."

Are you sending your email out through a smart host?

It looks like the smart host needs to know what domains it should allow to send email through. In this case, the message appears to be coming from a domain it doesn't know about. As you can't enter every domain that is likely to send an email in to your server, you are going to have to ask the ISP if this behaviour can be changed. I doubt it.

You could also see if you can access the email server of the domain that you are sending to directly, but if the ISP is being picky with its SMTP server, I bet they have blocked port 25 access as well.

Simon.
0
 
ExchgenCommented:
Did we enable automatic forwards on the global end?

If you do not wish to enable it for all domains create an instance for the specific domain and enable automatic forward for that domain.

Raghu
0
 
ManzourAuthor Commented:
Thank you guys for your quick response! And sorry for being late, actually I wasn’t aware of your responses till today. For some reason I didn’t receive any email to confirm your comments!

Raghu- No I don’t want to enable automatic forwards on the global end, but I want enable it for certain users! Is it possible or I have to enable it on the globale level?

Sembee- I think you’re right about the smarthost. We are using a Surf Control application for the outbound emails as smarthost. We can setup trusted rely by IP address or domain, but I cannot think of option certain email user account.
Any idea to make it successful for some users on the exchange server or any!!

Thanks,

Mansour

0
 
SembeeCommented:
If you are using another product to send email through, then you need to either configure it to allow relaying of anything from the Exchange server's IP address, or bypass it.

Simon.
0
 
ManzourAuthor Commented:
OK...I'll check with the security administrator if we can do that!

Thanks,

Mansour
0
All Courses

From novice to tech pro — start learning today.