Zabbix Installation error

I get this error when i run the configure command for zabbix installation.

configure: error: Invalid MySQL directory - unable to find mysql.h

The command i am running from the root of zabbix was
#     ./configure --enable-server --with-mysql --with-net-snmp

I am following the instructions from
http://www.zabbix.com/manual/v1.1/install_server.php

Please advise how i can overcome that error. Thanks,
jibranilyasAsked:
Who is Participating?
 
The--CaptainConnect With a Mentor Commented:
You need the mysql development package, AFAIK.

I've installed zabbix a few times, but I'm pretty good at getting linux software to work (actually, I'm very good), so if it needed something that I didn't have in order to successfully install, I'm sure I just grabbed it and moved on (and as such, don't remember exactly what was necessary).

Typically, when you are compiling something (trust me - you are, whether you know it or not), and the compiling system complains about not having a .h file for a package you already have installed, you typically need the development package for the existing package (it usually has a "-dev" component to the package file name).

Cheers,
-Jon
0
 
jibranilyasAuthor Commented:
My OS is Ubuntu
0
 
jibranilyasAuthor Commented:
Thanks Captain,
Here is what I did

apt-get install libmysqlclient14-dev

and it works :)
0
 
The--CaptainCommented:
Yup - I knew it was going to be a dev package.

Glad to hear you got it working.

Cheers,
-Jon
0
All Courses

From novice to tech pro — start learning today.