Solved

Accessing computers on a network

Posted on 2006-07-05
5
349 Views
Last Modified: 2010-03-19
Hello, I just replaced a dumb hub with a Linksys wireless router. I added the linksys because the office wanted DSL. I have 3 desktop computers and a wireless laptop. The main computer is XP and  has a laser printer attached. I did my confguration where I was able to have the other three computers ( 2 XPs and a 98 ), access files and the laser printer off of the main computer. The main computer, however, can not see the workgroup so can not see the other computers.  I have changed the workgroup to a unique name on all computers. I think that part is correct otherwise the computers could not access the files and printer of the main computer.    
0
Comment
Question by:Rick100Lynne
5 Comments
 
LVL 13

Expert Comment

by:prashsax
ID: 17045720
Check if you can ping other computers on this computer using IP address.

Then goto start->run.
\\IP_ADDRESS of any other computer.

This should open the shared folder list.

If this works, then check the name of workgroup is correct.
Then check if computer browser service is running or not.
0
 
LVL 2

Expert Comment

by:Razor2k5
ID: 17045725
Hi,
the problem could be related to the network mask for the computer. Be sure that all computers have the same subnet mask. What is subnet mask : this magic number will help you find the coputers inside a network and deny access to other networks by restricting the access area. Thy the C class IP that is not routed : 192.168.x.x and a subnet mask 255.255.255.0 In this case you can chose 254 IP addresses that have the same 3 bytes in the IP address (first 3 digit groups the same).
0
 
LVL 2

Accepted Solution

by:
jonathanpham earned 500 total points
ID: 17047050
Hello Rick100Lynne.
You using winxp and win98 for your workgroup.
Sure all clients have same subnet mask by using ping  command.
If you can not ping to main computer (winxp service pack 2), turn off your firewall on that computer. Remember your windows xp service pack 2 has a firewall.
 =>go to  Control Panel / Windows Firewall. Turn off your firewall.
If you want to connect from win98 to winxp, you should  enable guess account on winxp.
 1. goto  Control Panel / User Account. Enable guess account.
 2. Edit your network access rule of group policy on your main computer.
 follow these steps:
 +Start run type gpedit.msc
 + Computer configuration / windows settings /  Security Settings /  Local Policies / Security options. Find "Network access: Sharing and security mode for local accounts" rule then double click on it on, click dropdown menu select "Classic - local users authenticate as themselves. Finally you must reboot your xp computer.

Ok. You have finished. I'm sure you'll see other computers on workgroup so that you can sharing.
Good luck !



0
 
LVL 1

Expert Comment

by:Nemesis09
ID: 17047405
I'd suggest checking these few things for this network, and or deleting/recreating the network connections and uninstalling/reinstalling TCP/IP, etc.

Open "local area network connection properties"

1. Check all computers are on the same subnet with the same subnet mask:
        ie. IP: 192.168.0.XXX
        Subnet Mask: 255.255.255.0
        Default Gateway: (IP address of your router)

2. Make sure the logon is set to "Client for Microsoft Networks" on the 98 machine.

3. Make sure you have "File and Print Sharing" installed and ticked in the "this connection uses the following items" list.

4. Make sure every computer is actually sharing something, if not then it wont show up in network neibourghhood/workgroup computers.

5. Disable any and all firewalls (or create relevant exceptions as a permanent solution if this turns out to be the problem).

Good luck with it...

Also from an XP machine that cant see anything try "net use X: \\computer\share" from a command prompt.
Where "computer" is the name of a computer on the network, and "share" is the name of a share on that computer. Then check in "My Computer" for the mapped drive.

Let me know how this goes.
0
 

Author Comment

by:Rick100Lynne
ID: 17052558
Here's what the problem was. I charted all pings to and from each computer. What needed to be done was to allow McAfee's personal firewall to allow access within the router's range of IP addresses. Once completed, all computers worked OK. I gave the points to Johnathan since he was the first to mention the firewall. Thanks all!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Some time ago I was asked to set up a web portal PC to put at our entrance. When customers arrive, they could see a webpage 'promoting' our company. So I tried to set up a windows 7 PC as a kiosk PC.......... I will spare you all the annoyances I…
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now