Connecting two routers

Hi

I struggling to understand what goes on when I connect two routers.

The first router (R1)  is a non-wireless router, connected to a modem, then on to my ISP. It has four LAN connectors, and handles DHCP to whatever plugs into them. I connected one of these LAN ports to the the WAN port of a RangeMax router (R2), which will serve as an access point. The reason I'm using a router and not a switch for this is because this router was the only powerful transceiver I could get my hands on.

R2 will have a few wireless PCs connected to it from time to time.

R2 is getting an "Internet" IP address from the DHCP of R1 (192.168.0.6) Mysteriously, these appeared in the static ip address boxes, and the "Use Static IP address" is checked!
R2 is getting the gateway information from R1 (192.168.0.1). Again, this has appeared in the static ip address boxes.

SO, these two IP addresses, together with the subnet mask, have appeared automatically, even though I opted to use static addresses here. So here begins my confusion.

to go on....

R2 has fixed DNS server names (my ISP's)
R2 also has a fixed LAN IP address, 192.168.2.1, that I put in it.
R2 also has a fixed subnet mask that I put in it.

This I follow.

I requested that R2 does not do any DHCP - is this correct? I thought that R1 would deal out IP addresses to the clients connected to R2, but, when I check those R2 clients, the IP address range is clearly coming from R2! How can this be, and is this correct? (Remember, the R2 is instructed not to do DHCP).

Finally, I set RIP to "Both" and used RIP_1

Some advice / help appreciated. Please don't be too technical.





LVL 11
Jason210Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NYtechGuyCommented:
Jason-

Your configuration will not work as described.  R1 is not able to issue DHCP requests to clients behind R2 - it is blocked.  In addition, "double-nat" is not a good thing (going through 2 firewalls that have WAN/LAN basically)

It seems from your statement that you know an access point is what you need, but you purchased the router b/c of its power, etc.  That is fine.

I would suggest instead of using it as a router and plugging the output of R1 into the "Internet" or "WAN" port, that you plug that cable into the "LAN" or "Inside" port (there is probably 4 ports, plus 1 WAN port).

Trust me, this will work.  Your wireless clients will get a DHCP address from the R1.

Please try and let us know.

Thanks,

justin
0
prashsaxCommented:
You should configure R2 to do a DHCP on its LAN interface.

And then configure R2 to NAT connections between WAN and LAN interfaces.(Just like R1).

This way everyone on R2 LAN interface can connect to internet.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason210Author Commented:
NYtechGuy

Thanks - I'll try that later. Presumably, the WAN settings of R2 would be ignored if I use it they way you suggest.

I would  (for my own interest, and if it's not too complicated) like to know the how to set it up the "double-nat" method. I could always turn off the firewall on R2 to minimise that problem. If I do that, I guess I'd need to enable DHCP on R2 and specify a range?

Actually, the way it's set up now, I have got one R2 client working with Internet access.  Perhaps the R2 is foolproof and is issuing ipadresses anyway, despite my ignornace.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

smurfeCommented:
post ur config, there might be some config problem
0
Jason210Author Commented:
prashsax

Is it possible and (indeed advisable?) to turn off the firewall on R2? How would I do this.
0
Jason210Author Commented:
Actually this client I'm using now is on R2.
0
NYtechGuyCommented:
jason-

Prashax seems to have explained how to setup the device doing the double-nat thing.  That can and should work.  I've always just preferred to have one, main router - and anything behind that as an access point.  Just give R2 a static IP address on it's LAN interface, and connect the cable as I have described and that is what you will have.

PS - if you do not get a link/activity light on when you connect, you may need a "crossover" cable, which is available at any comp usa or other computer store.

Thanks,

justin
0
Jason210Author Commented:
That did the trick prashsax. Enabling the DHCP server on R2 works.

It just remains this "double-nat" thing that NYtechGuy mentioned...
0
prashsaxCommented:
I think you are still using duoble-nat right now.

What is the IP address on the client machine who is able to access internet using R2.

I you don't want, you do not need to disable firewall on R2.

If your firewall allows all clients from LAN to go to WAN without any restriction and not vice versa.



0
Jason210Author Commented:
>>I you don't want, you do not need to disable firewall on R2.
OK, I'll leave it as it is since it's we won't be using doing much on the wireless clients except browsing the Internet and send mail.

However, I would like to know if there is a way you can just "turn off" the firewall on a router (this is a NETGEAR RangeMax WPN824) Is what I ask possible, or is it a case of regsitering client IPs as DMZs?
0
prashsaxCommented:
You have a heading of "Content Filtering" in the main menu.

This is where you can use the firewall feature.

But if you have not configured it, by default it will allow all the content and connection.

But if you want(in future) you can block access to some websites based on URL/IP Address.
You can also define Ports which can be access on internet(e.g HTTP,FTP,SMTP,HTTPS etc.)

For now, if it is not configured hence disabled.

I suggest leave it like this.
0
scrathcyboyCommented:
"I requested that R2 does not do any DHCP - is this correct?"

YES!!  That is how you should set it up.  There should be only ONE master router delivering DHCP, usually the one hard cabled to the WAN gateway, or it is the gateway.  You can set the other WAP routers as static in the same range as the DHCP, which is probably what you have done, but if you set them all to GET an IP by DHCP from the master router, then they all know the right gateway and inherit all the DNS server settings on the WAN side.  This is the right way to do it.

Then when the computers connect to the WAPS, they too inherit everything, not from the WAP receiver, but from the master router that is delivering DHCP.  So except for the master router, you can set EVERYTHING else to get an IP from DHCP, and it works like a bucket of greased monkeys.

Remember, noting does DHCP but one router, everything else gets it, and along with it, gets the gateway and the DNS for the WAN side, it is automatic.  !!!
0
Jason210Author Commented:
OK, that's interesting.

LAN interface of R1 router is the gateway.

So you're saying with the R2 router - I just give it a static LAN IP address and set everyhthing else to inherit?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.