Solved

help with cisco 506 opening for pop3 and port 110

Posted on 2006-07-06
9
408 Views
Last Modified: 2013-11-16
HI experts,

I'm trying to open port 110 for pop3

i have a cisco 506 e
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxencrypted
passwd xxxxxxxxxxxxxencrypted
hostname pixfirewall
domain-name My domain .con
fixup protocol dns maximum-length 1500
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 10.10.10.2 XXXXX Web
name 10.10.10.8 XXXX demo
name 10.10.10.7 XXXXXX demo
name 10.10.10.9 XXXXXX demo
name 10.10.10.6 XXXXXX book
object-group network Web
  network-object 10.10.10.2 255.255.255.255
  network-object 10.10.10.7 255.255.255.255
  network-object 10.10.10.8 255.255.255.255
  network-object 10.10.10.9 255.255.255.255
  network-object 10.10.10.6 255.255.255.255
object-group service FTPGroup tcp
  description FTP and FTP-Data
  port-object eq ftp-data
  port-object eq ftp
object-group network Web_ref
  network-object XX.XXX.8.51 255.255.255.255
  network-object XX.XXX.8.52 255.255.255.255
  network-object XX.XX.8.53 255.255.255.255
  network-object XX.XX.8.68 255.255.255.255
  network-object XX.XXX.8.69 255.255.255.255
access-list outside_access_in permit icmp any any
access-list outside_access_in remark Web Access
access-list outside_access_in permit tcp any object-group Web_ref eq www
access-list outside_access_in remark Web Access
access-list outside_access_in remark Mail Access
access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq smtp
access-list outside_access_in remark For PPTP Tunnel
access-list outside_access_in permit gre any host XXX.XXX.8.51
access-list outside_access_in remark For PPTP Tunnel
access-list outside_access_in permit tcp any host XX.XXX.8.51 eq pptp
access-list outside_access_in remark POP3 opened for Blackberry
access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3
access-list outside_access_in permit tcp any hostXXX.XXX.8.69 eq www
access-list outside_cryptomap_20 permit ip host 10.62.100.10 192.168.45.0 255.25
5.255.0
access-list inside_access_in remark Default Outbound
access-list inside_access_in permit ip any any
access-list inside_outbound_nat2_acl permit ip 10.10.8.0 255.255.252.0 192.168.4
5.0 255.255.255.0
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside XX.XXX.8.82 255.255.255.128
ip address inside 10.10.8.1 255.255.252.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.10.10.2 255.255.255.255 inside
pdm location 10.10.10.7 255.255.255.255 inside
pdm location 10.10.10.8 255.255.255.255 inside
pdm location 10.10.10.9 255.255.255.255 inside
pdm location 192.168.45.0 255.255.255.0 outside
pdm location 192.168.45.0 255.255.255.128 outside
pdm location 192.168.45.128 255.255.255.128 outside
pdm location 10.10.10.6 255.255.255.255 inside
pdm group Web inside
pdm group Web_ref outside reference Web
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 10.62.100.10
nat (inside) 2 access-list inside_outbound_nat2_acl 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) XX.XXX.8.51 10.10.10.2 netmask 255.255.255.255 0 0
static (inside,outside) XXX.XXX.8.52 10.10.10.7 netmask 255.255.255.255 0 0
static (inside,outside)XX.XXX.8.53 10.10.10.8 netmask 255.255.255.255 0 0
static (inside,outside) XX.XXX.8.68 10.10.10.9 netmask 255.255.255.255 0 0
static (inside,outside) XX.XXX.8.69 10.10.10.6 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XX.XXX.8.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.10.8.0 255.255.252.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer XX.87.52.69
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp enable inside
isakmp key ******** address XXX.XX.52.69 netmask 255.255.255.255 no-xauth no-conf
ig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.10.8.0 255.255.252.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
dhcpd address 10.10.8.2-10.10.9.1 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside



I tried to add <access-list smtp permit tcp any host xx.xxxx.8.51 eq 110>
or should it have been  
static (inside, outside) tcp interface 110 10.10.10.XX 110
access-list outside_in permit tcp any host XX .8.51 eq 110
 
but it would not accept the first command.

I have my cto tring to connect his new verizon motorola Q to use pop3.

as far as I can tell port 110 pop3 is open via the line <access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3

thanks again experts

Phishman out
0
Comment
Question by:phishman1000
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 17055000
Change this:

access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3

To this:

access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3

I'm assuming your pop3 server is 10.10.10.2 on the inside based on your static and access-list.

static (inside,outside) XX.XXX.8.51 10.10.10.2 netmask 255.255.255.255 0 0
0
 
LVL 15

Expert Comment

by:Frabble
ID: 17055008
I think you were almost there, but

access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3

also requires the source port to be 110. This port will be dynamic so shouldn't be filtered on. So.

no access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3
access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3
0
 
LVL 15

Expert Comment

by:Frabble
ID: 17055015
Must learn to type faster.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17056282
static (inside,outside) tcp interface pop3 10.10.10.2 pop3

access-list outside_access-in permit tcp any interface outside eq pop3

Cheers,
Rajesh
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:phishman1000
ID: 17059054
Hey thanks guys,

but I am bit confused???? <access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3> am I changing this (no) to stop it and then editing the new config in as <access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3>instead.
so the config I tried first <access-list smtp permit tcp any host xx.xxxx.8.51 eq 110> i assume the smtp part was wrong?
so if i'am in the pix in config t mode:
it will be:
no access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3
access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3
write mem
done?
also I'm still using the blackberries on the outside instead of porting to 110 only just leave the port as dynamic with the statement <access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3>
sorry for all the questions but I'm still a newbie to the cisco's
phisman out :)

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 17059141
Yes, exactly:

conf t
no access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3
access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq pop3
exit
wr mem
0
 

Author Comment

by:phishman1000
ID: 17060032
thanks JFrederick29,

but I'm getting a invalid port pop??? does that make sense???
<no access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3>
should it be in the config [no] access or just no access in the beginning statement?

phishman
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 17060459
Not really.  You may want to copy and paste from your configuration to avoid typos, just add no in front of access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3 and then paste it again and remove eq pop3 after "tcp any".
0
 

Author Comment

by:phishman1000
ID: 17062253
JFrederick29,
thanks for your help that worked, c&p i feel dumb now...DOH!!!

thanks again Experts,
phishman out  :)
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now