Solved

SQL Server 2005 not accepting DB instance name that include port number for replication setup

Posted on 2006-07-06
1
790 Views
Last Modified: 2008-01-09
I have SQL Server 2000 on server A.   I have SQL Server 2005 on server B.  I am trying to replicate data from server B to server A.  The database on server B is the distrbutor and is suppose to push the data to the subscriber database on server A.

For whatever reason, in order for me to connect to the database on server A, I have had to always specify not only the database instance name but also the port number ("servername\instance name, 1433").  I have to do this whether I'm setting up the ODBC setting on another server or desktop or if I trying to connect to it from SQL Server Management Studio from another server.  If I don't include the port number I can't make the connection.

The problem is that when I try to add the database on server A as a subscriber to the data to be pushed to it, SQL Server 2005 on server B will not accept the  "servername\instance name, 1433" name as the subscriber database name.  It doesn't like the "1433" appended to the end.  I get the following error message:

"SQL Server replication requires the actual server name to make a connection to the server. Connections through a server alias, IP address, or any other alternate name are not supported.  Specify the actual server name, 'servername\instance name'."

If I just input "servername\instance name" it can't connect to the database on server A and subscribor setup fails.

Server B previously had SQL Server 2000 installed and I did not have this problem in the past with SQL Server 2000.  SQL Server 2000 readily accepted the "servername\instance name, 1433" naming format during subscription setup.

Any suggestins to solve this problem.  I'll take any solutions that either enables SQL Server 2005 to accept the "servername\instance name, 1433" naming convention during the setup for subscription or a solution that allows me to eliminate the need to include the port number with the database instance name on server A in order to connect to it.
0
Comment
Question by:khrispy
1 Comment
 
LVL 13

Accepted Solution

by:
devsolns earned 250 total points
ID: 17053773
Make sure that you allow remote connections with 2k5.....http://support.microsoft.com/default.aspx?scid=kb;en-us;914277

Did you try  tcp:192.168.1.100, 1433 (notice the space after the comma) as your name and port?
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Slowly Changing Dimension Transformation component in data task flow is very useful for us to manage and control how data changes in SSIS.
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.
Via a live example, show how to extract insert data into a SQL Server database table using the Import/Export option and Bulk Insert.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now