Solved

Cannot bring up Apache by entering //localhost or //127.0.0.1 (WinXP home)

Posted on 2006-07-06
5
250 Views
Last Modified: 2012-06-21
Apache Version 1.3 has been installed as part a MRTG Bundle version 2.1 on WinXP Home

All installation parts completed without errors

I have turned off the Windows firewall, Defender and anything else which might affect it (before installation)

All services installed by the bundle have started.  Apache.exe shows twice in the active processes list.

Cannot bring up Apache default page by entering //localhost or //127.0.0.1.  The web root appears to be configured properly and there is defalt index.cgi file.

Any ideas why Apache web server cannot be accessed?
0
Comment
Question by:ianmal2
  • 2
  • 2
5 Comments
 
LVL 10

Expert Comment

by:sleep_furiously
ID: 17054016
Perhaps it is only listening on a particular interface.  Have you tried using the host's IP address instead of the loopback?  e.g. //10.20.4.100
0
 
LVL 13

Expert Comment

by:rhickmott
ID: 17054309
Has it been set to run on the default port?

Try a port scanner on your local IP or check the config fule to see what the LISTEN XX port is set to.
0
 
LVL 1

Author Comment

by:ianmal2
ID: 17054451
Have tried using local IP address. Still didn't work.

LISTEN in the Apache config file is not active.

0
 
LVL 10

Accepted Solution

by:
sleep_furiously earned 500 total points
ID: 17054600
If it is Apache 1.3, and has no Listen directives, then it must have a Port directive, and will bind to all interfaces by default.

You can try something like TCPView (free utility) to see what interfaces and ports a process has bound on Windows:
http://www.sysinternals.com/Utilities/TcpView.html

It might help to turn off name resolution in the utility, then you can see if it is bound to 0.0.0.0 (all interfaces), 127.0.0.1 (loop back only) or some specific IP address.

If you are connecting to the correct interface and port, then it is time to start looking in the Apache logs for any clues.

What exactly happens when you try to connect?  No response, and timeout?
0
 
LVL 1

Author Comment

by:ianmal2
ID: 17085165
Finally got it to work by entering the url //STUDY-COMP:9191

Nothing else would work. Thanks to 'sleep furiously' for the reference to TCPView.  It showed Apache bound to 0.0.0.0 and name STUDY-COMP

For this I award the points.

0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you've heard about htaccess and it sounds like it does what you want, but you're not sure how it works... well, you're in the right place. Read on. Some Basics #1. It's a file and its filename is .htaccess (yes, with a dot in the front). #…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now