• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1040
  • Last Modified:

dell c640 battery will not charge

My computer has been acting fickle recently. The battery will not keep charge, thus if one unplugs the AC power then the computer just shuts off. I noticed this problem before, and bought a new battery 2 weeks ago. However, the new battery has not resolved the problem. Now with the new battery, it is still not maintaining charge and only runs with AC power. Any ideas? Flashing the bios does not seem to help.

0
hmarebel02
Asked:
hmarebel02
1 Solution
 
tlcsiCommented:
Have you tried another AC adaptor?? It sounds like it may be a problem between the mainboard connector and battery connector. If you have already tried the battery then most likely it will need a new mainboard.
You could also try cleaning the connectors
0
 
hmarebel02Author Commented:
Thank you for your help, although I was hoping for a more technical answer than merely "bad motherboard" or try a new AC adapter (since I've tried both of those). But again, thx anyway. I'm deleting the question.
0
 
rindiCommented:
hmarebel02, Please follow the instructions I posted earlier in my link to close this Q properly.

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now