Solved

Outlook Mobile Access, Invalid SSL Cert error when Syncing

Posted on 2006-07-06
4
2,329 Views
Last Modified: 2012-08-13
I just enabled OMA on my Exchange server.  I set up my PDA to use the Exchange Active Sync, but when I try to sync, I get the following error:

"The Security Certificate on the server is invalid.  Contact your Exchange Server administrator or ISP to install a valid certificate on the server.

Support code:80072f0d"

I DID import the certicate on my Exchange Server (we've been using SSL for years) to my PDA by following the steps listed here:

http://www.microsoft.com/technet/itsolutions/mobile/deploy/msfp_b.mspx

It worked perfectly and the Certificate shows up on my PDA's Root listing.. but I still get that error when I try to sync!

The PDA is a Dell Axim 51v using WM5 with Exchange 2003 SP2 on the back end.
0
Comment
Question by:aconway
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17054731
Is the certificate a home grown or commercial certificate?
Did you import a root certificate, or the certificate off the web site?

Simon.
0
 

Author Comment

by:aconway
ID: 17054760
I followed the instructions listed in the URL in my first port.  It had me make some XML file and copy/past the cert info that was in my .CER file on the server then create a CAB and install it on the PDA.  Look at that URL.

The Cert is commercial from Equifax Secure Global eBusiness CA-1
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 17054794
I am well aware of what the URL states.

I have written my own instructions based on a similar technique because it doesn't actually tell you what certificate to use - whether the SSL certificate the supplier issued or their root certificate.

For maximum success, you should use the root certificate from the certificate supplier - not your own certificate.
Your own certificate is not a root certificate, so even if it is in the root certificate store, the Windows Mobile device will not look there.

Download the root certificate for your certificate from this page:
http://www.geotrust.com/resources/root_certificates/index.asp

Then repeat the process.

Simon.
0
 

Author Comment

by:aconway
ID: 17054848
Once I had the correct cert from that site you gave, everything worked perfectly!  Thank you.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question