• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2565
  • Last Modified:

Websphere Message Broker problem !!!

I have a problem when using Websphere Broker V 6.0

import javax.jms.*; // JMS interfaces
import javax.naming.*; // Used for JNDI lookup of
import javax.naming.directory.*; // administered objects
import java.io.*; // Java IO classes
import java.util.*; // Java Util classes
import com.ibm.mq.jms.*;
public class PSDemo {
      public static void main(String args[]) {
                  System.out.println("Create topic connection factory....");
                  MQTopicConnectionFactory fact = new MQTopicConnectionFactory();
                  TopicConnection conn = fact.createTopicConnection();
                  TopicSession sess = conn.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
                  Topic rtTopic = sess.createTopic( "topic://Sport/Football/Spurs/Results" );
            }catch(JMSException ex){
                  System.out.println("Error occured:"+ex.getMessage());

When run this application i found an error :

MQJMS1111: JMS1.1 The required Queues/Publish Subscribe services are not set up {0}

When I look up the meaning of this error :

MQJMS1111 JMS 1.1 : The required queues or publish/subscribe services are not set up: {0}.
                                 Explanation: The required WebSphere MQ setup for the messaging domain is not complete.

I've verified the broker is installed and running for the current queue manager .

Can you give me a solution.

Thanks for any help.
  • 2
1 Solution

Refer the article given by IBM that solves your problem :)


hope this will help :)
tuanbassAuthor Commented:
Thanks anumalas

Your article is used for W MQ version 5.3 but I am using Websphere MQ 6.0 and IBM Websphere Message Broker 6.0.
.Are there any documentation or installation guide for W Message Broker 6.0 ?

When I enter the command : dspmqbrk ,I have got this message :
"WebSphere MQ Publish/Subscribe broker for queue manager NC.QManager running"

But when i run program ,I've got the following error :
"MQJMS1111: JMS1.1 The required Queues/Publish Subscribe services are not set up {0 "

Please give me a soltution .

Many Thanks
tuanbassAuthor Commented:
I have got the answer. I forget to run this command :

   runmqsc queue_Manager_Name < "C:\Program Files\IBM\WebpsphereMQ\Java\bin\MQJMS_PSQ.mqsc"  :-)

PAQed with points refunded (500)

Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now