Solved

Adding a network printer

Posted on 2006-07-07
9
216 Views
Last Modified: 2013-12-28
I have one windows 98 client that I am having troubles with. I have not used 98 in a networking world, and is far different than XP. I simply am trying to print to a networked printer. It is a laserjet 4050. It is installed as a local printer on a ACITSLPR_1 port which has the IP address of the printer. When I try to print to it, I get this error:

There was an error writing to ACITSLPR_1 for the printer (HP Laserjet 4050): The system cannot write to the specified device.

It will print a few lines of text to the printer, and then that error comes up on the computer.

I tried to install this as a network printer, but it always tells me it is offline, even though it is not. In fact, if I go to \\printserver, all I can see is the shares. Normally it would show the shared printers as well.

Anybody have any ideas?
0
Comment
Question by:adembo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17060641
adembo,

The problem is that Windows 98 does not come with support for LPR.  It is not even an additional install on the CD.  Third party drivers or programs are available or you may have something that came with your server/network.  I don't have something that I can personally recommend but I will look to see if I can find something.  Otherwise another expert may have a solution that they have used.  That is the problem though.

b0lsc0tt
0
 
LVL 2

Author Comment

by:adembo
ID: 17060690
I was not realizing that windows 98 cannot see a printer share name with more than 8 characters. I created a new share for the printer on my printserver with less than 8 characters and now the printer is able to be added. I still installed it as a local printer, but for the port, I typed the path to the printer. It now prints as expected.

I still am curious to know what caused that. This is one of those "It has been working for years" and all of a sudden stops. Nothing had changed on the server side, but it just stopped working. I will leave it as I have setup now, as I am trying to rid the company of 98. Unfortunately, it is here because of an application that will not run under XP. Hofeully we can upgrade that sooner rather than later.

Thanks.
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17060718
I completely overlooked that fact.  I'm glad that you caught it and it sound like you fixed your problem.  If that is the case then you can post a zero point message in the Community Support topic area to ask them to take care of this question so you can get your points back.  Include the URL of this message in the message you post and your recommendation (delete with refund or accept one of your comments with refund).  If I misunderstood and you still have a question then please let me know how I can help.

Let me know if you have any questions.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 2

Author Comment

by:adembo
ID: 17060774
Well, I just did a work-a-round. I'm not sure I fixed the problem, rather just found another way to do it. The info you gave probably still applies to the original problem.

Thanks.

I will leave this open for a few more days to see if anyone else has any input, for my own curiosity.
0
 
LVL 5

Expert Comment

by:usacadena
ID: 17257405
Check that the Print server has the Windows 98 driver installed for the printer you are trying to connect use.  The print server needs this and also key printer name to 8 characters.


Let me know if this works.
0
 
LVL 2

Author Comment

by:adembo
ID: 17262922
This was fixed by changing the share name to less than 8 characters. All is well now. I just need to figure out how to close this question.

Thanks for your info.
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17265822
To close the question, post a zero point question in Community Support (http://www.experts-exchange.com/Community_Support/).  In the question include the address/URL of this question and let them know that you solved your own question.  If you have posted the solution then you can tell them which comment to accept.  If not you can ask for the question to be deleted.  They should refund your question points in either case.

Let me know if you have questions about this or want me to do it for you.

bol
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 17443842
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question