VMWare / XP Pro Host / Windows 2003 Server-IIS 6 Guest / Router - trying to have a web presence with IIS 6.0 using a dynamic IP address

VMWare 5.0 Workstation
XP Professional - Host
Windows 2003 Server with IIS 6.0  - Guest

All this behind a router with a dyamic ip address.
I have a Dynamic DNS Service - that check the address du-jour and updates the name servers of the Dynamic DNS Service.

Question:

Anyone familiar with this?
Do you use NAT on VMWare?
How do you configure the router?

Can anyone provide some general or specific guidance?


Thanks
michaelrobertfrenchAsked:
Who is Participating?
 
TheTullCommented:
You don't need to use NAT with VMWare, just bridge the network card in VMWare's settings so that VMWare uses it to get out on the network, then you can configure an IP address on both the virtual server and your xp host.  Then, on the router, you just forward port 80 comning in (I assume that's your intentions here, since you mentioned IIS), to the IP address you configured for the 2003 box.  It will all work as if the XP box and 2003 virtual machine were separate.
0
 
ded9Commented:
1. No need of config. router
2. Network type select Bidged
3. You need to forward ports in your router  www.portforward.com

One more thing your cannot browser your website within your network you will get page cannot be displayed .

get wan ip info http://www.whatismyipaddress.com/

you need to access your website from another network or install a proxy server in host pc and then try to browse your site
Also check this out
http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx
http://www.technopagan.org/dynamic/


For more info please paste your network info


0
 
michaelrobertfrenchAuthor Commented:
ded9

I have a somewhat limited understanding of networks but I proceeded as you indicated and my results were just the opposite of what I had expected based on your notes:  I can browse into my guest box but when I attempt from my work I get page can not be found.  I can ping ip or dns from anywhere though.

Regarding your Comment 3: No need of config. router

How to you forward ports without config. router.  Maybe I misunderstood.

Do you have any ideas about my opposite results?
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
ded9Commented:
have you allowed port 80 in windows firewall or other firewall in your system and also in router .

Ded9
0
 
michaelrobertfrenchAuthor Commented:
yes
0
 
ded9Commented:
You can give a try by setting your router to DMZ and then try to browse site. Just to identify if  router is not blocking ports.

Also enter static ip address in guest pc lan tcp/ip

ip=
subnet=
default gateway=
prefered dns =
alternate dns


0
 
scrathcyboyCommented:
the VM app does not inherit the dynamic IP from DHCP in all cases.  Use a fixed IP address if you want the same to inherit, else set the VMware app to a different fixed IP for cross communications of VM app to server.
0
 
scrathcyboyCommented:
Besides, IIS needs a fixed IP with the gateway and DNS servers specified in the TCP/IP properties page (as well as in the IIS setup) for it to work.  You cant do it with a variable IP address, doesnt work.
0
 
michaelrobertfrenchAuthor Commented:
According to VMWare a bridged network requires two physical nic cards and two ip address.
This box has a single NIC - so then, how can I use a bridged model rather than a NAT?
0
 
ded9Commented:
it automatically bridges the virtual network and your lan.

The whole vmware process is automated as nothing is needed to set the network.

Check www.vmware.com for proper installation


Reps
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.