• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 303
  • Last Modified:

DVD drive letter keeps changing on reboot - XP

Hi everyone. I have a problem which started about a week and a half ago. Up until then everything has been running fine on my PC. This is the problem: I have 2 internal hdds (set up as Raid 0) partitioned as C: (XP) and E: (games), an external hard drive partitioned as D: and F: and 2 dvd rom drives (G: and H:). After booting up the other week, the 2nd dvd rom drive (H:) had been reassigned to D: and what was D: is now H: I've tried assigning the correct drive letters again in Disk Management but those changes only last until the next reboot (changes made in disk management do appear correctly in the MountedDevices registry key by the way); if I boot in safe mode and make the changes then reboot back in safe mode the changes stay but upon rebooting Windows normally the dvd drive goes back to D:; if I disable that dvd drive in device manager and change the external partition back to D: as it should be and reboot that works but as soon as I enable the dvd drive again and reboot it takes over D:; I've changed the drive letter assignment in the registry but to no avail. I've uninstalled that drive and allowed windows to reinstall upon reboot at which time it gets assigned H: but it's back to D: upon reboot. I've even tried different cd/dvd rom drives but have made no difference. I cannot think of anything that I have installed that has caused this problem. I have even used different external hdds also but to no avail.  I have read another topic with a similar problem but no solution seems to have been found.  Is it a registry setting that has become corrupt? I really don't know but any help would be very much appreciated as at the moment I have to keep the drive disabled and then re-enable when I need to use it again.

Please let me know if you require any additonal info.

Thanks in advance.
0
Ade0410
Asked:
Ade0410
2 Solutions
 
dave4dlCommented:
Its possible you have installed some application that creates virtual drives or arranges your drive letters in some way.  Try disabling all startup items in msconfig (dont disable all services initially).  If doing this makes your drive letters stable, re-enable each startup item one at a time until the problem appears again.  This will let you pinpoint the app causing the problems.  If the drive letters are still not stable after disabling all the startup items, try disabling all the non-microsoft services (use msconfig since it will be easy to re-enable them here later and you can "hide" all microsoft services).

Write back your results
0
 
scrathcyboyCommented:
simply run start, programs, admin tools, computer management, then click disk management, now change the display to where you see all your drive volumes on the right side.  Right click on each drive letter. Whatever drive has the wrong letter, start with the highest, and assign it a higher drive letter temporarily to free up a drive letter.  Then go through each drive and assign it the letter you want, finally assigning the one you put too high back to the correct drive letter.  This should fix the problem.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now