DNS issue on one computer in 3 computer home network

Linksys WRK54G using wired connections. Two of 3 computers able to access internet normally.

Just spent time with linksys tech support who said that the router is responding/working perfectly and that I have a "DNS issue" in the 3rd computer. I need to know where to start trouble shooting this.
ccuretonAsked:
Who is Participating?
 
DireOrbAntConnect With a Mentor Commented:
Router and OS types?

You might have a corrupted TCP/IP stack, check this page:
http://support.microsoft.com/?kbid=299357

And try to reset it. Always start back with setting both IP and DNS to grab automatic settings.

I won't be able to help you more on this tonight, I hope it's working for you soon.
0
 
DireOrbAntCommented:
type: ipconfig /all <ENTER>
In a DOS prompt from that box. Check the results vs a box that works.
Paste the results here.

Other steps:
1. Ping your gateway (from result above)
2. Ping another machine that works
3. Ping your WAN IP (from WAN area of your linksys)
4. ping 64.233.187.99 (google.com)
5. ping google.com (by name)

Post results.
0
 
ccuretonAuthor Commented:
From working box:
192.168.1.100
255.255.255.0
162.168.1.1

pings gateway, other good box on home network and any internet site I try

Non-Connecting Box:
169.254.142.61 (Autoconfiguration IP Address)
255.255.255.0

Node type is Unknown on good box, Mixed on Bad box
Good has DNS Suffix Search list = my isp; bad does not have this line at all

Good has "Connection-specific DNS Suffix" = my isp
Bad shows category but does not shop any result


connection status shows: limited or no conectivity and will ping 127.0.0.1 but nothing else. "Ping request could not find host"

0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
ccuretonAuthor Commented:
if I manually assign an ip address to the bad box it will then ping the gateway and any computer on my home network, but not anything on internet
0
 
DireOrbAntCommented:
Looks like the good box is set to automatically grab and IP (DHCP) where the non-working one has a static IP?
Change the non working box to obtain IP and DNS automatically and see what you get.
0
 
ccuretonAuthor Commented:
The results I gave you above were with the bad one set to obtain IP and DNS automaticall... I merely added that IF I set it manually it will ping other computers on home network, otherwise it will not
0
 
DireOrbAntCommented:
Any gateway or DNS on the non-working box when you do ipconfig /all ?
0
 
ccuretonAuthor Commented:
no default gateway
no DNS
0
 
DireOrbAntCommented:
Hum, then it's not set to pick up an IP automatically (dhcp).
Go to whatever network card in use or all click properties, scroll to TCP/IP settings and make sure they don't have static IP and are set to Obtain IP auto.
0
 
ccuretonAuthor Commented:
yes they are set to obtain automatically

I also changed the NIC earlier today and tried it in working computer to make sure it was working correctly... it was
0
 
DireOrbAntCommented:
Right-click connection item and pick repair (XP right?) look at what it says. Do you see anything about getting IP and how long does it take?

Also, go to: http:\\162.168.1.1
And look at the DHCP range. Does it span from .100 to at least .150 or so?
0
 
ccuretonAuthor Commented:
Windows could not finish repairing the problem because the following action cannot be completed: Renewing your ip address

yes to DHCP range


Of course I'll continue to check out anything you suggest, but I want to make sure you realize the the router function and the hardware has been thoroughly checked out over a 10 hour period so far today. The router support team says that I have a DNS issue on the bad box... I have no idea where to start with a DNS issue.

Once again, you're the expert... I just didn't want you to overlook that point.
0
 
giltjrCommented:
You don't have a DNS issue.  You have a DHCP issue.  When the bad box is setup to automatically obtain an IP address it got 169.254.142.61, which is in a range that MS assigns if DHCP fails.

My first thought was bad cable, but you state that if you hard code a static IP address that is within the 192.168.1.x range you can ping the other hosts.  This means that the cable is good.

On the Linksys router, do you have DHCP enabled?  If so what is the maximum number of IP addresses it is setup to use.

If DHCP is not enabled on the router, what do you have doing DHCP?
0
 
ccuretonAuthor Commented:
dchp is enabled and it's set for 50 addresses
0
 
ccuretonAuthor Commented:
in case it helps to know, the DHCP Active IP Table shows the two working computers on the network, but not the bad one
0
 
giltjrCommented:
By chance you are not using LAA's (Locally Administered Addresses)?  That is, are you assigning MAC addresses or are you using the default mac address.  Its been years since I have used LAA's, so I am not sure if they show on the "ipconfig /all" command or if only the burned in address shows.

What happens if you power down both of the working computers, then reboot the one that is having problems?
0
 
ccuretonAuthor Commented:
Using the default MAC addresses.

I'll power down and check what happens.
0
 
ccuretonAuthor Commented:
No noticeable difference when non-working computer is booted by itself.
0
 
DireOrbAntCommented:
Your second post says 162.168.1.1, I assume 162 is a typo and should be 192 right?
If it's not a typo, it explains your issues, if it is...

Set the TCP/IP settings static to:
IP: 192.168.1.150
Mask: 255.255.255.0
Gateway: 192.168.1.1

Then ping 192.168.1.100 (assuming the box is back up)
And then ping 192.168.1.1

By any chance, go to Services and check that DHCP client is running.
0
 
ccuretonAuthor Commented:
yes, a typo

how do I check to dee that DHCP client is running?
0
 
ccuretonAuthor Commented:
when set to static I can ping gateway and other computer on network. I can also access files on the network, but I can not connect to internet.

I had IE automatically detect LAN settings.
0
 
ccuretonAuthor Commented:
I can also ping 64.233.187.99 but not www.google.com
0
 
ccuretonAuthor Commented:
when I double click on the network connections icon in the system tray the graphic that comes up in the box shows a small closed lock on the corner
0
 
DireOrbAntCommented:
right-click MyComputer, choose Manage, open up Services and Applications, then Services.
Then look for DHCP Client. Double-click it, then make sure it says Startup type: Automatic and Service Status: Started
0
 
ccuretonAuthor Commented:
DCHP client... started and automatic... yes
0
 
DireOrbAntCommented:
Well as a workaround, set this box to a static IP outside of your DHCP range, so 192.168.1.151
Then grab the DNS from a working machine (ipconfig /all) and put them on that one as static ones.
0
 
DireOrbAntCommented:
What router brand/model do you use?
What OS are the client machines?
0
 
ccuretonAuthor Commented:
grab the DNS... does that mean input the dns servers in the tcp/ip config screen

if so I've done that
0
 
DireOrbAntCommented:
Yes, input the DNS servers you see on a valid box into the TCP/IP settings on the non working box, making sure you double-check the IPs.
Since your DHCP is not picking up an IP, I doubt this would help but go back to services and check that the DNS Client service is also running.

So with those DNS entered, still no ping on google.com?
In a DOS prompt run:
nslookup google.com

What do you get?
0
 
ccuretonAuthor Commented:
UnKnown can't find google.com: No response from server.
0
 
ccuretonAuthor Commented:
I've been at this 15 hrs today... I must stop for the night... I hope you'll be back tomorrow
0
 
ccuretonAuthor Commented:
Please see

http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21913622.html

Much work worthy of points has been done, but this problem continues and is becoming urgent.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.