Solved

IE Disable Close

Posted on 2006-07-09
12
1,154 Views
Last Modified: 2013-12-28
Here is the situation.  I have written a science display program using Flash (thanks for the help EE).  I have it installed on an old 98 machine running IE6 and it runs fine.  I have it running in full screen mode with the menu bar on autohide.

The biggest problem is that kids are smart and many like to break things.  Therefore when someone else wants to run the game (called "Mr Science Guy") it may have been shut down by the previous mischievous user.  I want to disable the toolbar completely in IE6.  If that can't be done, I want to hide all of the buttons (Back, prev, etc) and disable the Exit button so that the only way to exit the program is ALT-F4.  Since there is no accessible keyboard (the only input for the user is through a rollerball mouse) there is no need to worry about keyboard shortcuts or anything else keyboard related.

The computer is set up in a cabinet so access to the puter itself is not an issue.  It is an old computer running Win98 and IE6.  The Flash program is compiled in version 6 mode.  Is there a way to handle this using Flash?
0
Comment
Question by:slink9
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
12 Comments
 
LVL 23

Expert Comment

by:Erik Bjers
ID: 17070384
You need to set the page up to start as a pop-up window, this will hide all tool bars and menus.  I don't know how to do this, but I'm sure you can find the answer on EE.

eb
0
 
LVL 29

Accepted Solution

by:
blue_zee earned 500 total points
ID: 17070872
Take a look a this:

How to Use Kiosk Mode in Microsoft Internet Explorer
http://support.microsoft.com/?kbid=154780

And this link includes a few extra tips on the last paragraph that may also be useful for you:

http://www.g4tv.com/techtvvault/features/34389/Windows_Tip_Kiosk_Mode_for_IE.html?detectflash=false&

Hope these help.

Zee
0
 
LVL 23

Author Comment

by:slink9
ID: 17072264
I have tried kiosk mode but it still has the sizing and close buttons.  It seems like there should be a small VB6 or C program that I should be able to run to disable these buttons.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 23

Expert Comment

by:Erik Bjers
ID: 17072324
run it as an unclosable popup
0
 
LVL 29

Expert Comment

by:blue_zee
ID: 17072364

Kiosk mode doesn't show any buttons on my machine.

Are you sure you tested it correctly?

Zee
0
 
LVL 23

Author Comment

by:slink9
ID: 17072388
I ran it with "IEXPLORE" -k and it came up with a black box in the right corner with the minimize, maximize, and close buttons.  I thought kiosk mode would be without them also.
0
 
LVL 23

Author Comment

by:slink9
ID: 17072394
I just cranked it up and can test any changes right away.  I would like to deliver this machine today, but want to have it right before doing so.
0
 
LVL 29

Expert Comment

by:blue_zee
ID: 17072424

The command is incorrect.

Try Start > Run and type:

iexplore -k path

Instead of "path", either test with your homepage, ex: www.msn.com, do NOT use quotes, and press Enter.

Or the path to your flash program, ex: c:\flash\whateverisnameis.

Curious on the result.

Zee
0
 
LVL 23

Author Comment

by:slink9
ID: 17072447
I was winging the command line before.  That is exactly what I have put in.

"C:\program files\internet explorer\IEXPLORE.EXE" -k c:\sciguy\sample.html

This is the exact command line that I have.  It comes up with a black box in the upper right corner with all three control buttons and a "windows" activity indicator.
0
 
LVL 23

Author Comment

by:slink9
ID: 17072471
By the way, IE version is 6.0.2800.1106 with SP1 applied.
0
 
LVL 23

Author Comment

by:slink9
ID: 17072487
I believe I just found it.  If you do kiosk mode with full screen enabled (F11) it shows that box.  I accidentally left regular mode enabled and I didn't get a box after starting IE.  Playing with it now ...
0
 
LVL 29

Expert Comment

by:blue_zee
ID: 17072521

That is good and I wasn't aware of that "glitch"!

Hope it works as you want/need.

Zee
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question