[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Share Windows system folders on LAN

Posted on 2006-07-09
12
Medium Priority
?
1,957 Views
Last Modified: 2010-05-18
I'm running XP on most of my PC's and Win 2K and 98 on a few others. I connect to our LAN on an ON/Off basis. (not always connected to switch)
On previous installations of XP on my main PC i have been able to access folders such as C:\Program Files\ and C:\Windows\ on other PC on the LAN using Explorer. I did not have to specify Program Files as a share at the time either.
I don't want to drag a shortcut of this to Shared Folders and i don't want to use Remote Desktop to access it.

Thanks for help in advance
0
Comment
Question by:Ryan_R
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
  • +1
12 Comments
 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17069872
you can still access those folders

this is one way to access
\\computername\c$

this will allow to access the C root folder,
however it will ask you for admin password.
once you get the folder view, you can access the windows and program files folder too

regards
naren
0
 
LVL 8

Expert Comment

by:thur6165
ID: 17070460
Did you try to map the drive in My computer.  right click on my computer and select map drive.  the location would be as advised above \\comutername\c$.  click the hyperlink that says "differnet username" and put in the password.  Is this a domain or workgroup?  if domain you will need to put the domain name before the username follower by a backslash like this:  domain\username.  If workgroup that account you use will need to be created on the remote system and be in the admin group.  The remote drive will then show up as if it were a local drive in my computer.
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17070792
ok. this is a workgroup. I would expect that you can't map to a drive unless you could connect to the share in the first place.
therefore if   '\\laptop\c$\program files'   works then you would get the points anyway. I'll test it later and get back to you.
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17070899
\\computername\c$\Program Files

works
0
 
LVL 10

Accepted Solution

by:
bbrunning earned 225 total points
ID: 17071163
Actually  r_naren22atyahoo "\\computername\c$\Program Files" will not work.

Using \\computername\c$\whatever requests use of the guest account which most systems will block it and since he said remote desktop he's talking about 2k or xp.

You have to use \\computername\c$ then let windows request the username/password combo and enter it.

Other than that you can use \\computername and go to the shared folders without a pass depending on the OS and permissions. Either you have to map the drive or create a shortcut. Depends completely on the OS and the Share permissions.
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17077549
you're right, bbrunning. I did get the guest account, and no matter how many different passwords i tried (after resetting the Guest account password on my PC and laptop, could not connect. After that the guest login came up just to visit \\laptop

Both OSs are XP Pro SP2 with Windows Firewall disabled. Using Zone Alarm 6 Pro as my firewall.

Using the map drive function didn't work at the time of me trying it, however playing around with a few settings in the right order seems to have solved my problem for me.

For those wanting to know how to do it, i'll type my actions below:
-----
Firstly, goto Control Panel, Folder Options, View Settings
The bottom option needs to be de-selected ("Using simple file sharing (recommended)")
Right/click the program files folder and click properties. Goto security tab and ensure that the "Everyone" user group has full control priveleges.
On the sharing tab, share the folder as Program Files, and ensure that "Everyone" has Full Control privleges.
    ( Whilst using the sharing folder function sort of goes against my original question, i think there is no way
     around it.)

Restart the PC's if you can't immediately access the shared folder.
-----

I think the emphisis of this was on the first step, as without this the Sharing tab on the Program Files will have the sharing options disabled as it is a system folder.

I've only done this with one PC between crossover cable. Will try it with another one running Win 200 Pro before i close this Question.

So now that there are still 75 points up for grabs, i thought i might ask your opinion about this:

------------------------------------------------------------------------
------------------------------------------------------------------------
------------------------------------------------------------------------

A few months ago, I connected to mainly 2 other PC's one at a time using a crossover cable. On all of the PCs i manually set IP addresses to 169.254.105.xx and had no problems connecting to other PCs on an on/off basis (not permanently connected). Recently, i purchased an 8 port switch to share our broadband access (also as an on/off basis) so i decided to change all of the network settings to Auto-get IP address. This has ultimately resulted in IP addresses changing to something like 192.168.0.xxx

There are a few PCs that are connecting to this switch on an on/off basis. They are:
Port 1:           Broadband Modem (always connected)
Port 2:           \\Home  (always connected)
Port 3:           \\Toshiba  (dad's laptop), off/on basis
Port 4:           \\Ryan  (my desktop, off/on basis between this network (switch) and crossover cable to brother's PC)
Port 5:           \\Laptop (mine, off on basis between the switch and my desktop and another LAN at school)
Port 6:           \\Todd  (brother's desktop, off/on basis between switch and my PC)
Port 7 & 8 not used

Problem is we only have one 25 metre cable to reach from the switch to where my PC, Laptop, and Todd's PC usually reside. This means that i can't have these 3 PC's connected to switch at the same time so thast they all get relevant IP addresses which the switch can then remember.
Every time i change which network i'm connected to my IP address changes to a new one an I have limited connectivity when connected to \\Todd but can still connect, and the opposite when connecting to my laptop (100mbps, but no access)

What can i do to fix up this network?
0
 
LVL 10

Expert Comment

by:bbrunning
ID: 17078026
Ryan, you did exactly what I was talking about in my post.

>>Other than that you can use \\computername and go to the shared folders without a pass depending on the OS and permissions."Either you have to map the drive or create a shortcut. Depends completely on the OS and the Share permissions."<<

Close this question and repost the new question with the correct title.
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17078666
you can be assured of getting points here. but your comment was very general and only after i started mucking around with other settings did i find the solution to the problem.
assuming i did nothing alse besides what you said i would not be able to share the program files folder to begin with. That's why i outlined step by step what i did to fix it.

>>Depends completely on the OS and the Share permissions.<< doesn't really answer the question the same as >>Firstly, blah blah blah<<

i am not asking a second question in this post rather i am seeking the opinion of you guys on my current network setup.

Ryan
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17078677
just to clear up any OS confusions, \\Ryan, \\Todd, \\Home, and \\Toshiba all run XP Pro SP2.
\\Laptop runs Win2k (no SP's installed)
other PC runs Win98se/Win2k but is pretty much never connected to any network
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17126345
bbruning - so close to the 10000 point mark
just got there myself
hope this answer got you over the line
0
 
LVL 10

Expert Comment

by:bbrunning
ID: 17126940
Almost....9950, thanks!
0
 
LVL 15

Author Comment

by:Ryan_R
ID: 17127658
if i checked your stats before accepting you answer i wouldve givn an A
next time
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question