Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 552
  • Last Modified:

Problem with registry path when creating custom .adm file

I am attempting to create a custom .adm file to control the folder used by the My Pictures Slideshow screensaver. My understanding is that it need to change the registry entry that gives the path to the folder. I have used Regshot to find out exactly which key gewts changed when I change the path from the default (HKEY_USERS\S-1-5-21-128323046-1898321161-1566985067-3370\Control Panel\Screen Saver.Slideshow\ImageDirectory: "C:\Documents and Settings\TestUser\Desktop" in my case) This key is only created if the path is changed from the default (C:\Documents and Settings\TestUser\My Documents\My Pictures).

The .adm file I have created is:-


CLASS USER

CATEGORY !!ControlPanel
        CATEGORY !!Display

            POLICY !!MyPicsSet
                  KEYNAME "Control Panel\Screen Saver.Slideshow"
                  PART "Path to folder used by screensaver" COMBOBOX
                  VALUENAME "ImageDirectory"
                        SUGGESTIONS
                        "C:\WINDOWS\Corporate Desktop\Screensaver"
                        END SUGGESTIONS      
                  END PART
            EXPLAIN !!MyPicsSet_Explain
                   END POLICY ;MYPicsSet

        END CATEGORY ;Display
END CATEGORY ;Desktop

[strings]
ControlPanel="Control Panel"
Display="Display"
MyPicsSet="My Pictures Slideshow screensaver"
MyPicsSet_Explain="Custom Policy\n\nDefines the folder location used by the My Pictures Slideshow screensaver.\n\nThe My Pictures Slideshow screensaver cycles through all image files located in the folder specifed."

Now this policy won't display in the GPE. If I change the registry key path to "Software\Policies\Microsoft\Windows\Control Panel\Screen Saver.Slideshow" for example, the policy shows in the GPE and when assigned to a test user, creates the registry key. However as this is the wrong location it has no effect on the screensaver.

The problem, as far as I can see is that the key I need to change is located in HKEY_USERS\S-1-5-21-128323046-1898321161-1566985067-3370\ which I would imagine changes for every user. What do I need to do to get around this?

Tim



0
talltim
Asked:
talltim
  • 2
1 Solution
 
auricoCommented:
There is a setting in GPE that will allow you to set the screen saver, time till the screen saver is activated and password protect the screen saver.  These are all located under  - User Configuration/Administrative Templates/Control Panel/Display

In the code above, you may want to move "END POLICY ;MYPicsSet" over so that when looking at the code (whether it is you or someone else) to troubleshoot easier.

Example:

POLICY !!MyPicsSet
                 KEYNAME "Control Panel\Screen Saver.Slideshow"
               PART "Path to folder used by screensaver" COMBOBOX
               VALUENAME "ImageDirectory"
                    SUGGESTIONS
                    "C:\WINDOWS\Corporate Desktop\Screensaver"
                    END SUGGESTIONS    
               END PART
          EXPLAIN !!MyPicsSet_Explain
END POLICY ;MYPicsSet

In my experience in creating your own .adm files and implimenting them into GPE, that you will need to right click where you want to add the .adm file, such as Administrative Templetes.  Then click on Add/Remove templates.  Once the template has been added, in order to see the setting of the template you need to click on View, then on Filtering.  Then on the Filtering dialog box select "Filter by Requirements information" and deselect "Only show policy settings that can be fully managed".  Then click on the template you created and you will then be able to change the settings.

0
 
talltimAuthor Commented:
Sorry, been a bit snowed under with other work, I will have a look at your filtering suggestion when i get a chance
0
 
talltimAuthor Commented:
The line positioning is acually as you suggest in my ADM, it was a copy/paste error that made it show incorrectly in my post!

I have had a look at what you say about filtering, and yes, when I remove the tick from 'Show only policy settings that can be fully managed' my missing policy appears. It does however have a red mark next to it instead of blue.
Testing the configured policy shows that the correct path for the image folder appears in the screensaver properties. However it is still possible for a user to change this path (although it resets when they log on next time) and other settings within the screensaver. However =I can use the (built in) Hide screensaver tab policy to get round this problem.

For any future referers to this question this Microsoft document http://www.microsoft.com/technet/prodtechnol/windowsserver2003/technologies/management/gp/admtgp.mspx describes the difference between fully managed and 'preference' policies. My browser tell me I had looked at it before but I don't remember it!

I am going to give you the points for this. Thanks :-D
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now