Solved

Application Error

Posted on 2006-07-10
19
210 Views
Last Modified: 2010-04-16
Hi experts ..

I'm using Viusal Studio.Net 2003 ..
when I run my application .. it gives me *Application Error* :

ViewSales.exe - Application Error

     The appliction faild to initialize properly(0xc0000005). Click on OK to terminate the application

It happened everytime I run the program (or any program) ..
another thing when i tried to do :  File>new project>Visual C# project>Asp.net web application .. press ok .. then the VS.NET closed ..

what is going on??
0
Comment
Question by:DrAske
  • 10
  • 9
19 Comments
 
LVL 44

Expert Comment

by:bruintje
ID: 17071563
Hi DrAske,
----------

not sure are you trying to run on a machine that has the .NET 1.1 framework installed or not this is needed for VS2003 apps, .NET2.0 framework is not enough
are you using any db connections on startup that are not available on the machine?

----------
bruintje
0
 
LVL 9

Author Comment

by:DrAske
ID: 17071641
Hi bruintje ..

Yes, I have the .NET 1.1 framework installed on my machine ..

what do you mean by and db connections on startup ???
all what i got is a form with some buttons and labels with no data base connection ..
actually, yesterday i changed my Computer Name .. does that have any relation with the error ??
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17071659
ah now you mention something

have you tried a recompile of the application in the IDE?
0
 
LVL 9

Author Comment

by:DrAske
ID: 17071676
actually .. I got this Error when i try to run the application on the IDE !
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17071750
if you do a rebuild without running are there any error messages in the error list view below the code pane? i mean if it does not run then it will probably not compile [build] without an error or message
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17071755
also check your eventlog for possible clues about the error
0
 
LVL 9

Author Comment

by:DrAske
ID: 17072172
No .. there is no errors when I do a rebuild ..
just happened when i run the application ..
0
 
LVL 9

Author Comment

by:DrAske
ID: 17072181


------ Rebuild All started: Project: ViewSales, Configuration: Debug .NET ------

Preparing resources...
Updating references...
Performing main compilation...

Build complete -- 0 errors, 0 warnings
Building satellite assemblies...



---------------------- Done ----------------------

    Rebuild All: 1 succeeded, 0 failed, 0 skipped

------ Rebuild All started: Project: ViewSales, Configuration: Debug .NET ------

Preparing resources...
Updating references...
Performing main compilation...

Build complete -- 0 errors, 0 warnings
Building satellite assemblies...



---------------------- Done ----------------------

    Rebuild All: 1 succeeded, 0 failed, 0 skipped

0
 
LVL 9

Author Comment

by:DrAske
ID: 17072195
sorry for being late .. I was alittle busy  ..
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 44

Expert Comment

by:bruintje
ID: 17072219
no problem we all are :-)

looks like something in the app.config or some other config file that still points to the old machinename?

to exclude that you could open a new project put a bit of work in it and see if that will run, if it does you can insert all the parts into the new project

i know this is not a solution only a workaround if it works but at least you can look for further clues in config settings
0
 
LVL 9

Author Comment

by:DrAske
ID: 17072278
Nop .. that didn't work :( ..
I opened a new project .. but the same error when i run it ..
I guess It's a permission issue ..?
I didn't know that changing the machinename would be a big trouble :o/ ??
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17072434
are you using asp.net web applications? then i guess its a permissioning problem indeed are you still using the same startup url

have you checked with IIS if all is well there? by now you can exclude the project being the problem

0
 
LVL 9

Author Comment

by:DrAske
ID: 17072536
The problem not happened with specific project (it's a windows application projects) ..
all my previous and new project have the same error ...

I tried to re-install .NET framework 1.1 but I get stuck in a new problem(it gives me) :
--------------------------------------------------------------------------------------------------

The Following Component Failed To Install :
X microsoft.Net framework 1.1

--------------------------------------------------------------------------------------------------
I am an IDIOT ..!!
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17073374
can you rename your machine back to what it used to be?
or if this is XP reload a previous configuration?
0
 
LVL 9

Author Comment

by:DrAske
ID: 17073393
I renamed it .. with no chance ..
it is windows xp .. what do you mean a previous configuration ??
0
 
LVL 44

Accepted Solution

by:
bruintje earned 500 total points
ID: 17073431
i meant system restore
http://www.kellys-korner-xp.com/xp_restore.htm

under the heading > System Restore Usage
it tells how to restore

if that does not work, i would first try an uninstall of the .net framework through the control panel > add/remove programs | reboot and see if you have a chance of reinstalling the framework
0
 
LVL 9

Author Comment

by:DrAske
ID: 17076758
Thanx bruintje ..
I used system restore and re-install it (VS.NET 2003) ..
all my previous projects run as expected ..

Sorry for wasting your time .. actually, you deserve 10000 pts ;o)

regards, ahmad;
0
 
LVL 44

Expert Comment

by:bruintje
ID: 17076938
thank you very much, but i'm glad you got it all working again which is more important i can imagine myself loosing a day on such problems all the time :-)
0
 
LVL 9

Author Comment

by:DrAske
ID: 17077052
yeah :o( .. Actually, I'm teaching mySelf programming with ADO.NET.. I am using (Microsoft ADO.NET professional project ) .. I decided to end studing this book by the end of this week but this problem was unexpected :o/ ..
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article series is supposed to shed some light on the use of IDisposable and objects that inherit from it. In essence, a more apt title for this article would be: using (IDisposable) {}. I’m just not sure how many people would ge…
Calculating holidays and working days is a function that is often needed yet it is not one found within the Framework. This article presents one approach to building a working-day calculator for use in .NET.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now