Opatch returns with error code 255

Greetings,
 Here's my scenario,
 I've had to install Oracle 9.2.0.1 on a new box, which went very well. I then upgraded to 9.2.0.6 that went very well. Now I'm trying to install patch 14 and I keep getting an error stating that Opatch does not "see" java 1.4.x. I have even loaded JAVA 1.5.007. I can't overcome this 255 error. I checked the version  java -version and it shows 1.4.x but when I run the opatch lsinventory I get the 255 error. I'm running Oracle 9I on a w2k3 platform.

I am not a DBA but a Sys Admin who has to tackle this in absence of a DBA...so be gentle.
Thanks,
fswalef
fswalefAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sathyagiriCommented:
On your environment variable see if the path for java version 1.4 comes before anyother java installations
0
actonwangCommented:
run the following:

C:\>set oracle_home=<your oracle home>

C:\>  ...\opatch\opatch lsinventory


you should sth like:
Path to Java = "<path to java>"

check to verify if it points to right java path.
0
fswalefAuthor Commented:
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Administrator
LOGONSERVER=\\XXXXXXXXXX(changed to maintain security)
NUMBER_OF_PROCESSORS=4
OMPATH=C:\Program Files\Dell\OpenManage\oma\bin;C:\Program Files\Dell\OpenManage\LU\bin;C:\Program Files\Dell\OpenManage\oldiags\bin
ORACLE_HOME=g:\oracle\ora9i
OS=Windows_NT
Path=G:\oracle\ora9i\jre\1.4.2\bin\client;G:\oracle\ora9i\jre\1.4.2\bin;C:\Perl\bin\;G:\oracle\ora9i\bin;G:\oracle\ora9i\Opatch;G:\oracle\ora9i\perl\5.8.3\bin\MSWin32-x86-multi-thread;C:\Program Files\Windows Resource Kits\Tools\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Dell\OpenManage\Array Manager;C:\Program Files\Dell\OpenManage\oma\bin;C:\Program Files\Dell\OpenManage\LU\bin;C:\Program Files\Dell\OpenManage\oldiags\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PERL5LIB=c:\perl\lib
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 5, GenuineIntel
PROCESSOR_LEVEL=15
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

sathyagiriCommented:
Can you post the exact error message you got?
0
actonwangCommented:
did you run as I posted?
0
sathyagiriCommented:
Also are you installing it under a userid assigned to ORACLE user group or using a ADMIN account?
0
fswalefAuthor Commented:
Yes        to  post " Path to Java = "<path to java>" from Actonwang
 For sathyagiri useing ADMIN account and here's what I get:

C:\Documents and Settings\Administrator>opatch -lsinventory

Please make sure you are running OPatch with JRE version 1.4 or later.

OPatch failed with error code = 255


***************************************************************************************
Then I tried this;

C:\Documents and Settings\Administrator>opatch

Please make sure you are running OPatch with JRE version 1.4 or later.

OPatch failed with error code = 255

I also checnked to ensure that the Environment table is set correctly. This just doen't make sense.
I do have an additional question that may share some light on this situation.
Does Oracle 9I need the latest version of Opatch  to install patch 14 since I running version 9.2.0.6? The reason I ask is because on my operational server I've noticed that we're running Version 1.0.0.0.55.
0
actonwangCommented:
look at your JAVA_HOME environment variable.
0
sathyagiriCommented:
Here's something that says

OPatch for 10.2 is only compatible with 10.2 and nothing earlier

I would suggesto try and use the OPATCH version that came with your 9i db instead of the current version.
0
sathyagiriCommented:
And for 9i I guess the compatible version is 1.0.0.0.50
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fswalefAuthor Commented:
Allow me to thank you sathyagiri for your efforts. I did in fact reload opatch 1.0.0.0.55 back on and I am now able to continue on with my patch update. It is now my quest to find out what jolt of electrons, or what subliminal message I received that me think that patch 14 required 10.2.0.x to utilized before performing the patch upgrade.
Thanks again for the quick assist.
What a treasure it is have a service such as Experts-Exchange and the combined talents of all the members experts and newbees that make this forum work. My thanks also to actonwang for the assisted input.
Once again Thanks to all. This thread can be allotted to the throes of the archive.
0
actonwangCommented:
no problem. glad to see it has been sorted out.
0
sathyagiriCommented:
You are welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.