Solved

unable to connect to virtual machine through ftp /telnet

Posted on 2006-07-10
33
4,904 Views
Last Modified: 2013-12-21
hi
I have RHEL 4 installed on VMWare 5.5. where host is windpws XP.
I wish to connect to Linux Virtual machine using ftp and move some files from windows host to linux guest.
the ip of my machine is 192.168.203.11 (lets say)
so whenever at cmd in windows i issue

ftp 192.168.203.11 it says:
unknown error: cannot connect...

i have  installed ftp package on linux (for sure)
but if some other settings are required to be done after that ,,i have not done those. So kindly tell what are the required settings...
Also i have configured VMWAre NAT settings and mentioned three ports there...
i.e. 21 (ftp) 22 telnet and 23
n i m not able to connect to the Virtual machine either thru telnet or ftp
..

0
Comment
Question by:aman_greval
  • 17
  • 16
33 Comments
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Have you let down your RHEL 4 firewall for ftp?  Try disabling it first and ftp.. if it works, then open up the ftp port in the firewall..

# service iptables stop

then try ftping from Windows...
0
 

Author Comment

by:aman_greval
Comment Utility
no i have not enabled firewall..
i selected no firewall during installation
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Have you start up the ftp service then?  Can you ftp from the RHEL to connect to itself?  From your RHEL do:

$ ftp localhost

0
 

Author Comment

by:aman_greval
Comment Utility
it says
connection refused
 :(
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Go to /etc/xinetd.d/ and find something with ftp (depending on what you installed).  edit the file and change the line disabled=yes to no then restart you xinetd by:

# service xinetd restart

Then try to ftp from RHEL again.

0
 

Author Comment

by:aman_greval
Comment Utility
i can c gssftp and tftp inside the /etc/xinetd.d directory.. which file shd i edit
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
that's the file.. gssftp... look for the line disabled = yes and change yes to no.  Then restart your xinetd as about mentioned
0
 

Author Comment

by:aman_greval
Comment Utility
also just before reading ur reply i read this command in a pdf n executed

#kill -HUP 'cat /var/run/inetd.pid'
#ftp localhost... Acc to pdf it shd say connected now but for me it still says
connection Refused

pls also tell how to restart the same process
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
RHEL 4 doesn't use inetd, it uses xinetd.  Also you command:
# kill -HUP 'cat /var/run/inetd.pid'
is wrong it should be ` instead of '.

So what you did has no effect on the system.  Restart you xinetd service using:

# service xinetd restart
0
 

Author Comment

by:aman_greval
Comment Utility
ok i did and  made changes in gss too..
now
#ftp says
Connected to system
Ftp server ready
using suthentication type GSSAPI
GSSAPI accepted a uthenticaiton type:
Error major:Miscellaneous failure
Error minor: no credentials cache found
GSSAPI error: intialising context authentication failed
KERberos V4 failed
you have no tickets cached
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
What does your gssftp say.  Can you cut and paste it here?
0
 

Author Comment

by:aman_greval
Comment Utility
i cant copy & paste  as it is on vmware but i will type it

service ftp
{
flags=REUSE
socket_type=stream
wait=no
user=root
server=/usr/kerberos/sbin/ftpd
server_Args= -l -a
logon_failure += USERID
disable=no
}
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
The server_Args says that it needs strong authentication.  change the line

server_Args= -l -a

to

server_Args= -l

Then restart your xinetd again using "service xinetd restart" then you should be able to ftp from local
0
 

Author Comment

by:aman_greval
Comment Utility
I did that...
Same error again..
Connected to system
Ftp server ready
using suthentication type GSSAPI
GSSAPI accepted a uthenticaiton type:
Error major:Miscellaneous failure
Error minor: no credentials cache found
GSSAPI error: intialising context authentication failed
KERberos V4 failed
you have no tickets cached.....
Then it prompts for name
Name(localhost:root):   oracle   I have user oracle as a member of dba group
Prompts for password:    I entered that...
then i goes to halt...and cursor blinks but shows nothing


0
 

Author Comment

by:aman_greval
Comment Utility
wait slyong....
just now it said.. user oracle logged in
remote system type is unixusing binary mode to transfer the files...
ftp>

that means i m connected...

:) congrats to u too

now i wish to transfer files from windows to linux on vmware using ftp..
i tried to connect to ftp on windows saying

c:\ >ftp 192.168.203.11
it says ftp connect unknown error number.
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Could you wait while the cursor blinking.  The ftp server will either close the connection or show you something.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 24

Expert Comment

by:slyong
Comment Utility
you have windows firewall up?
0
 

Author Comment

by:aman_greval
Comment Utility
no i guess..
could u pls tell how to confirm.

Also,
On linux it seems i m able to conenct to oracle user but after getting a long error list...
any workarounds...
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
hi aman_greval,

To check windows firewall if it is on, go to Control Panel -> Security Center.  Also I am not sure if you install any other firewall like ZoneAlarm, Internet Secure, etc.  It is pretty hard to track it down.

The error message is just saying that you are not using Kerberos credentials, it is not really a problem.

You may want to try using ssh/sftp instead of ftp.  Go to http://www.ssh.com/support/downloads/secureshellwks/non-commercial.html to download a ssh client for Windows, install it, then use "Quick Connect" login as oracle and give the password.. Then click on the "Windows" menu item and select "New File Transfer".  That is more secure then ftp and simpler.
0
 

Author Comment

by:aman_greval
Comment Utility
i downloaded this n installed this but m not able to find quick connect option..i chkd ssh2_admin but m unable to connect.
 
I wish to install 10g Applciaiton server on linux. the software files are in windows d:(4 .cpio files wotrth 2GB)  i wish to transfer these files to linux. Thats y i m looking for FTP which is not working. Pls tell me any means to transfer these files to linux so that i can install the software there.
FTP was working perfectly when i had vmware version 4.5. i uninstalled that and installed 5.5.1 on it.
I am working on a DELL laptop with 2GB RAM and windows xp OS. installed vmware 5.5.1 on it and RHEL ver 4.0.
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Did you download this: http://ftp.ssh.com/pub/ssh/SSHSecureShellClient-3.2.9.exe

There is a "Quick Connect" or you can use the Menu item "File --> Quick Connect"
0
 

Author Comment

by:aman_greval
Comment Utility
i m trying ip 192.168.203.11
it says unable to connect.
The host may be down or
this may be due to wrong network configuration
sometimes this can happen due to misconfigured firewalls...


RHEL on linux is up n running on vmware...also thru vmware i m able to connect to 192.168.203.11 as well as localhost
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Can you ping 192.168.203.11??
0
 

Author Comment

by:aman_greval
Comment Utility
no request time out.destination host unreachable
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Hi Aman,

You have all the setup done properly.  You have to check your vmware installation to see what kind of network that you setup and make sure that your windows is not running firewall.  My advise is that if you are not familiar with those options, you are better off burning the files into a DVD to transfer them.  The network between your XP and Linux doesn't seem to be working.
0
 

Author Comment

by:aman_greval
Comment Utility
thanks sylong...
but any other workaround you can suggest
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
I am really not familiar with VMWare, someone might be able to help you out by telling you how to setup VMWare.  Or you can read the documentation here http://www.vmware.com/support/ws55/doc/ws_net.html.  You have to at least get the XP to be able to ping the Linux machine on VMWare.
0
 

Author Comment

by:aman_greval
Comment Utility
ok thanks slyong...
You have been of great help...

0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Sorry couldn't help you further.. hope you can get it up and running
0
 

Author Comment

by:aman_greval
Comment Utility
well i have raised i query on the same to networking experts.. hope to get some resolution there...
u want me to accept the answer and close this?
or
after the host starts pinging VM, i can come baq to u n ask for what next?   :-)
0
 
LVL 24

Accepted Solution

by:
slyong earned 500 total points
Comment Utility
Is ok if you would like it open.  You can always come back to if you have any further queries.
0
 

Author Comment

by:aman_greval
Comment Utility
hi alyong
i m able to ping through ftp now
problem was with the virtual network settings of vmware
the network shd be bridged instead of NAT
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
hi aman,

good to hear that.. so could you ftp or ssh now?
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
NTP Server in VMware 5 115
How to change synology RAID settings 4 47
Oracle Finace 3 43
SBS Disaster recovery 6 27
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Create your own, high-performance VM backup appliance by installing NAKIVO Backup & Replication directly onto a Synology NAS!
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now