Solved

SBS 2003 Exchange - ISP's SMTP server won't authenticate exchange server

Posted on 2006-07-10
10
227 Views
Last Modified: 2010-03-06
Our exhange server cannot connect to our ISP's SMTP server.

I enter the smarthost address - go to advanced - outbound security and enter the username and password.

I have tested with outlook and it connects and sends ok but not with the exchange virtual server.

I prefer connecting directly with DNS but quite a few of our contacts companies refuse the connection with the error:
'Mail rejected because your IP is in DUL' which I understand to be a blacklisted problem.
0
Comment
Question by:zoladog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
10 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17073464
When you tested with Outlook - did you put the authentication details in the box "this server requires authentication", or did you just enable the option without entering any credential information?

Some ISPs will not allow you to send email without trying to receive first - ie make you do a POP3 check.

Simon.
0
 

Author Comment

by:zoladog
ID: 17073532
Yes I did enter the  authentication details in outlook and I had a different pop server to confirm that a pop3 check wasn't required.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17073675
Have you asked the ISP if there is an issue?
ISPs can be very picky - the latest I have heard is only allowing email from one address to be sent via an authenticated session.

So if you authenticate as pete then only email from pete@ would be allowed through.
Emails from bob@ would be refused.

Simon.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:zoladog
ID: 17073728
thanks for your respomse Simon, but this isn't the issue, as when i test from outlook i've tried with different 'from' addresses. I've spoken to the ISP who suggested I ring MS!

I think it may be a smarthost issue as I have now tried with another smarthost from another ISP I use who have added my ip and don't require username/password authentication and that won't connect either. Users get NDR saying Relaying denied??
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17073889
The standard ISP cop out - find someone else to blame. I wonder if the ISPs support team are briefed to do everything they can to find someone else to pass the problem to.

You mentioned that you are doing this because of issues with being on DUL.
Does that mean that some email goes out? If you change the SMTP connector to use DNS, some messages go out?

The "Cannot Relay" message is fairly standard message. It can have any number of reasons - mainly caused by the server generating the message not accepting the message. The key is finding which server is generating the message.

If you get cannot relay messages when you are sending all email via DNS, then the problem is likely to be outside of the Exchange server.

Simon.
0
 

Author Comment

by:zoladog
ID: 17074118
When set to send via DNS 90% of e-mails go, I believe some of our clients (big corporates) won't allow direct mail delivery - we are in the UK and the troublesome addresses all seem to be in other countries. This is why I'm trying to send via smarthost but it appears that our server doesn't want to, i've spent around 8hours now trying different settings and looking for possible answers on the web.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17074490
If you are on the DUL list, then you will need to use a smart host.
Lets break one of the rules by setting things up by hand in SBS.

While you are testing, change the configuration of the SMTP Connector. On the address space tab, remove the * and put in one of the domains that you are having problems with. Add other domains as required. That will allow the bulk of the email to go through correctly.

I presume that you are entering the security information on the SMTP Connector, and not on the SMTP virtual server?
What do you have between the internet and the server? A firewall of some kind?

Simon.

0
 

Author Comment

by:zoladog
ID: 17080907
Found the answer, my fixed IP from my ISP had changed without them telling me or noticing when I rang!!

Was strange because it allowed me through sometimes and other time not!

thanks for your suggestions
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
ID: 17317463
PAQ / Refund
ee ai construct, community support moderator
0

Featured Post

Enroll in June's Course of the Month

June's Course of the Month is now available! Every 10 seconds, a consumer gets hit with ransomware. Refresh your knowledge of ransomware best practices by enrolling in this month's complimentary course for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question