[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 365
  • Last Modified:

Exchange 2003 NDR When Sending Through Smart Host

I have an Exchange 2003 server that is configured to send all SMTP mail through DNS2GO's smart host.  The problem I'm having is that no mail is being delivered outside of my local network.  I am using port 366 as my ISP (read bastards) are blocking port 25 outbound traffic.  I can see the messages in the que, but they never leave the Exchange box.  I am able to telnet to DNS2GO smart host from the server in question so I don't think it's a connectivity problem.  I don't know if it matters but I have 2 seperate mail domains configured on this Exchange box.  I hope someone here can help me figure this out!
0
codestar33
Asked:
codestar33
  • 14
  • 12
1 Solution
 
SembeeCommented:
Which method are you using for the port direction?

Firewall?
Change to the SMTP Virtual Server?
Something else?

Have you configured an SMTP Connector to send email out via that smart host?
Has it been configured with authentication information?

Simon.
0
 
codestar33Author Commented:
I changed the SMTP Virtual Server port to 366.

Yes, I configured the SMTP connector to us the smart host and have the correct authentication information entered.

Would it help if I were to provide some screenshots?
0
 
SembeeCommented:
Can you telnet to port 366 on the address you have been given to use for the smart host?

Simon.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
codestar33Author Commented:
Yes, that works fine.
0
 
SembeeCommented:
If you click on one of the messages in the queue, it should give you a reason for the failure. What does that say?

Simon.
0
 
codestar33Author Commented:
Well, I don't see any reason for the item in the que.  But I just sent a test message and when I get the NDR Email I will post the results here.
0
 
codestar33Author Commented:
This is what the NDR email says:

Your message did not reach some or all of the intended recipients.

      Subject:      test
      Sent:      7/10/2006 5:47 PM

The following recipient(s) could not be reached:

      john.doe@Ichangedtherealdomain.com on 7/10/2006 9:35 PM
            This message was rejected due to the current administrative policy by the destination server.  Please retry at a later time.  If that fails, contact your system administrator.
            <agile-solutions.com #4.3.2>
0
 
SembeeCommented:
The remote server has rejected your message.
As you are using a solution you have paid for, you need to ask them why they have rejected your message.

Another thing you might want to try is to do a telnet test to their server and see where it fails.
http://www.amset.info/exchange/telnet-test.asp

Simon.
0
 
codestar33Author Commented:
OK, I am able to telnet to mail.dns2go.com from my exchange server without any problems.  And dns2go claims that they don't know why I would be getting "rejected".  Is there any way to be sure what is happening with these messages other than waiting for the NDR message to be sent?
0
 
SembeeCommented:
Does the full telnet test go through and the message delivered?
That would give you an idea if things are working correctly.

Simon.
0
 
codestar33Author Commented:
I followed the instructions you provided above (http://www.amset.info/exchange/telnet-test.asp) from my exchange box and that appears to work just fine.
0
 
SembeeCommented:
Were you asked to authenticate when you sent the message via telnet?

Simon.
0
 
codestar33Author Commented:
No actually it didn't which was suprising to me.
0
 
SembeeCommented:
And the message was sent through correctly? It was received at the other end?

I haven't used that service before, did they ask for an IP address that the messages are coming from?

Simon.
0
 
codestar33Author Commented:
well actually, I haven't received the message yet... I thought there just might be a little lag but I think 4 hours should be enough time...  I'll let you know if it ever shows up.

BTW, I really appreciate your time and patients!

Regarding the IP, I actually have a username/password that I am supposed to use when connecting to the SMTP Smart Host.  So I'm not really sure why I wouldn't have been prompted when connecting via telnet.
0
 
SembeeCommented:
The server you are sending through may be configured to accept all email on anonymous sessions, then silently drop it. Four hours is certainly long enough to know that it hasn't been delivered - although check your spam filter as very often a telnet test message will be seen as spam.

Does your ISP not have a smart host that you can use to send email out? They will not advertise it as a smart host, it will be the outbound server for use in Outlook Express. You could have two SMTP virtual servers, the default one on port 25 with an SMTP Connector to send to the ISPs server and then an additional one on the alternative port to receive email on.

Simon.
0
 
codestar33Author Commented:
My ISP has blocked all outbound SMTP traffic except to registered users connecting to their server.  I cannot send messages through it as user1@mysepeatedomain.com only as myseraccount@myispdomain.com.

I did verify last night that the SmartHost is working... I have a webserver running on the same box, so I wrote a little test app that sends smtp mail through the smart host just like I have configured in Exchange.  That worked pefectly, and I did actually receive the messages.
0
 
SembeeCommented:
Let me guess... the ISP also has a very expensive business service where you can run servers. That is the usual game - make people jump through hoops to provide business for their more expensive service.

When you setup the test application, was that authenticating as well?
Is there anything between the Exchange server and the internet that could be interfering - firewall for example?

Have you tried setting the SMTP Connector to send helo instead of EHLO?

Simon.
0
 
codestar33Author Commented:
Yes, the typical "improved service and reliability" line on the ISP service...

In my test application, I used the same authentication/server name/port info that I'm using on the exchange server.  And the applkication executed on the very same exchange server so I don't think it is a rounter/firewall issue.

I will try the HELO setting and will let you know how that goes....
0
 
codestar33Author Commented:
OK, I changed the setting to use HELO instead of EHLO and now I just see the message sitting in the que with a couple of retry attempts.
0
 
SembeeCommented:
That probably means the smart host doesn't support helo, which is odd. Helo is the older version of SMTP, and most servers are backwards compatible.

I went looking on the dns2go web site to see if there were any pointers. I am currently on the end of an 8mb internet link and it was dreadfully slow.

Does your ISP just block port 25, or does it redirect it to its own servers then reject the message? I am just wondering if you haven't setup the virtual server correctly.

Otherwise running out of options, I haven't used the dns2go service before - I used to point my clients to dyndns.org instead.

Simon.
0
 
codestar33Author Commented:
My ISP only blocks port 25... they don't redirect.  I know this because when I performed the telnet test the server notified itself as a DNS2GO stmp host.  If I were to provide screencaps of my Default SMTP Virtual Server config and Internet Mail SMTP Connector config?  If so, let me know where to send them.  Also, I don't know if you noticed above that I have 2 mail storage groups (2 seperate mail domains).  Do you think this could be part of the problem?
0
 
SembeeCommented:
The two storage groups will not be a problem. Email is managed on a routing group or an org wide basis. It doesn't care about the source of the message internally.

Have you seen my instructions for setting up an SMTP Connector?

http://www.amset.info/exchange/smtp-connector.asp

Simon.
0
 
codestar33Author Commented:
Do you think that I can delete my existing Default SMTP Virtual Server and my Internet Mail SMTP Connector and follow your instructions to recreate without causing further problems?  The existing ones were created when I originally ran the "exchange setup wizard".
0
 
SembeeCommented:
I wouldn't touch the default SMTP virtual server.
The SMTP Connectors can be removed quite easily.
Another thing you could try is setting everything back on the default SMTP Connector, then create a new SMTP virtual server, with the alternative port.
Create the SMTP Connector and set it to use the new SMTP virtual server as a the bridgehead.

Simon.
0
 
codestar33Author Commented:
OK, I'm not sure what it was all originally set to as it's been a long time since I started trying to get this to work and I didn't take notes of what changes I've made (shame on me).  But I will try and see what I can do with creating a new smtp virtual server.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 14
  • 12
Tackle projects and never again get stuck behind a technical roadblock.
Join Now