Keyboard (NUM LOCKS) very frustrating ... (is it the PC, the keyboard, the OS, or a combination of all) ...

Ok:

So, I've tried to find an answer/solution to this in the past, but I had no luck.

I have a Mandrake 2006 system (and this same concern happend to me with all my RH distro roll-outs as well).

When I turn on the PC, and it completes POST, the numlock KEY NEVER comes on (I set this in the PC BIOS) ... I know for certain that NUM LOCKS to the BIOS is OFF.

Now, when I start the Mandrake OS, the NUM LOCK is still OFF UNTIL the 'start' of the INIT process (I see it turn ON).  

After I turn it off (so I can log into the system as the ROOT user) ... I then see it TURN back ON again (on its own) after I have finished the root user authenication process (so I think the num locks is being invoked again during the script for the login to the root user).

So, how can I do this:

#1:  Turn off the NUM lock during the INIT process
#2:  TAKE out the NUM lock statements from the root user scripts

Any other tips suggestions would be greatly apprecaited!
LVL 1
pugdog_fanAsked:
Who is Participating?
 
slyongConnect With a Mentor Commented:
Look into /etc/profile.d/numlock.sh and /etc/rc.d/init.d/numlock and find setleds as ravenpl described. -num to set the numlock off +num is to get the numlock on.
0
 
ravenplCommented:
there is a command which sets it on/off
setleds -num
OR
echo "Activating Numlock ..."
for i in 1 2 3 4 5 6; do
/usr/bin/setleds +num < /dev/tty${i} > /dev/null
done

However I'm not familiar with mandriva init scripts, so I will not help here...
However I heard there is a 'numlock' service - try turning it off.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.