Mail Not Being Forwarded

I am using Solaris, I'm sorry but I'm not sure of the version.  If knowing this is fundamental to providing a soloution, can somebody please tell me how I can find out?

I have formerly used something called Exceed when creating new users.  After creating a new user I used to manually create a .forward in the new user's home directory.  This allowed their mail to be re-directed to an Exchange email account.

However, I have recently started using a script to create new users.  To do this, I create the .forward file in /usr/local/src/skel and then use the useradd command with the -k parameter set to /usr/local/src/skel.  All of this takes place within the script.  This does copy the .forward to the new user's home directory with the correct email address within it but whenever a mail is sent to the user, it is not being forwarded on.  Rather, the mail just sits in the /var/mail directory.

What do I need to do to enable the mail to be forwarded onto the email address in the user's .forward?

 
delphilogAsked:
Who is Participating?
 
PsiCopConnect With a Mentor Commented:
More to the point, insure that the user's home directory and .forward file are not world- or group-writable. Sendmail will refuse to use the .forward file if the file, or the directory where it is located, is not safe for it.

Also, keep in mind that the .forward file is only referenced by the local Mail Delivery Agent (probably mail.local), not by the sendmail daemon itself. Be sure that the daemon is recognizing the address as one that should be delivered locally.
0
 
TintinConnect With a Mentor Commented:
Does the .forward file have permissions on 644?
0
All Courses

From novice to tech pro — start learning today.