About RealVNC

I use the realvnc free editions 4.12 in two machine once is runng VNC server other running VNC viewer!

the quesion is the VNC server PC is behind a router and VNC viewer PC is behind a swtich! and I did a port forwarding in VNC server.

But when I type the eg:202.168.134.254:5850 in the VNC viewer, it diaply a message read:Connection reset by peer (10054) Do you wish to reconnect to 202.168.134:5850?

I try to use Windows Remote Desktop Connection with no issue..

anyone know the answer!

urgent!
domdigAsked:
Who is Participating?
 
r_naren22atyahooCommented:
>>>I found a funny things when I don't put the port # I can got log on to the remote PC, but only for the first user, which I have 2 user in that computer

then the server is running on the same port 5900

for windows free vnc server edition, you can only use single login at time.

regardss
naren
0
 
prasanna_lakkundiCommented:
I think the port which you are using to connect is not correct, The port used for VNC is 5900 not 5850. You have to open the port no. 5900 in order to connect through VNC.

Also go through the URL for more details.

http://www.iss.net/security_center/advice/Exploits/Ports/

0
 
r_naren22atyahooCommented:
VNC server port is 5900
not the 5850
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
r_naren22atyahooCommented:
thats quick
0
 
domdigAuthor Commented:
but I change the port in VNC server to 5850, and forward the port to 5850 through router already!
still can't use 5850?
0
 
r_naren22atyahooCommented:
go to VNC server
Properties
authentication
untick
"prompt local user to accept connections"

regards
naren
0
 
r_naren22atyahooCommented:
in VNC viewer
Go to Options->Inputs in the viewer and select "Rate-Limit mouse move events".
http://www.experts-exchange.com/Networking/Q_21863921.html
0
 
domdigAuthor Commented:
thanks r_naren22atyahoo ,

but I try that still have the error message!
0
 
domdigAuthor Commented:
I found a funny things when I don't put the port # I can got log on to the remote PC, but only for the first user, which I have 2 user in that computer
0
 
jcdesign4uCommented:
domdig --> What do you mean with "put the port #" ?
0
 
domdigAuthor Commented:
sorry ! it mean I jst enter 202.168.134.254 without : 5850
0
 
masheenCommented:
I would first try and test with a workstation (if possible) inside the router to see if your problem is on the router or the server. If you can connect internally then port forwarding is not working correctly.
0
 
dognamedmosesCommented:
restart the computer with the VNC server.
0
 
montasirmaCommented:
Please take care that you need to forward both the ports 5800 and 5900 on the router not only 5800. And since you changed the default port from 5800 to 5850 then you should forward the ports 5850 and 5900.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.