Solved

Missing Rules tab on server

Posted on 2006-07-11
8
1,472 Views
Last Modified: 2013-12-18
The Rules tab on our main Domino server is not showing up anymore (Domino 6.5.4 on Windows 2000 server). If I look under Server - Configurations - Router/SMTP - Restrictions & Controls on our other servers like SameTime or Quickplace, it's visable, but on the main server that tab just doens't appear anymore.  If I open the names.nsf file in the Designer I can see the Rules page and the actual rules themselves, so I know it's still there. The rules are also still working.  Any ideas how to get it back so I can make some changes??

cheers
Andrew
0
Comment
Question by:manta357
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 17084139
I would try to create a new replica locally, and then down the Domino server, rename the old names.ns to names.old, and replace it wit the fresh replica.


I hope this helps !
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 17085482
There is no tab Rules? It could be that you upgraded from an older version of Domino. Open the design of names.nsf and remove (or rename) the subform $RouterSMTPSettings. Then refresh the design of the database. If all's well then a new $RouterSMTPSettingssubform should be added.

There might also be some hide-when setting on the Rules tab. I'm trying to find it. Please check the above first.
0
 

Author Comment

by:manta357
ID: 17087150
It is an upgrade but we started with version 6.0 just over 3 years ago. It's been incrimental upgrades since.
Tried a new replica and it was the exactly the same. Could see the rules in Designer but no joy in the Administrator.
Renamed the subform and did a design refresh. Exactly the same results.
It indicates the master template is StdR4PublicAddressBook, template version 6.5.1 - 12/16/2003.
Odd... very odd.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 17088613
I can't find out how they did it with, hiding that tab. All I can find is that the Rules are hidden from a browser, and when ActForm="MessagingSettings". When you edit the document, do you indeed see Messaging Setting in the header of the form?
0
 

Author Comment

by:manta357
ID: 17090615
The form title is Configurations for Bairdhq/Baird
this image show's what I'm getting  zurg.baird.com/~awl/noRules.gif
I have just tried turning off the Hide Formula: ActForm="MessagingSettings" on the $RouterSMTPSettings subform. It seems to work on an local replica. I can edit the rules, add, delete. I'll give that a try on the server tonight when I can take it offline.
0
 
LVL 46

Accepted Solution

by:
Sjef Bosman earned 125 total points
ID: 17090847
Did you try to Fixup and/or Compact the database? And the a Refresh (or even Replace) Design?? If this is a fault in the design of the database, it might be repaired that way. Odd indeed.

With the Document Properties (Alt-Enter), see if there's a field ActForm in that document. You could try to remove it with a small agent.
1
 

Author Comment

by:manta357
ID: 17092718
the field ActForm is there filled with "MessageSettings"
Googled ActForm and came up with this tech note from IBM:
http://www-1.ibm.com/support/docview.wss?fdoc=wplcdomi&rs=463&uid=swg21214711

Problem
When using the Domino Administrator client, the Rules tab does not display when you select Messaging Settings on the Configuration tab. This issue occurs after you upgrade the design of the Domino Directory to the 6.5.4 or 7.0 pubnames.ntf. You may also notice that after a Configuration document is edited from the Domino Administrator client, the Rules tab no longer appears when the document is viewed from the Notes client.
------

one of the listed solutions is, as you suggested, to create an agent and delete the ActForm field.

thanks for the help, I appreacite your ideas that helped to track this down
Andrew
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 17094924
We cracked it! A pity it's been cracked before... ;)
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is an old article, please see an updated version of this article, located here: http://www.experts-exchange.com/articles/23619/Notes-8-5x-Windows-7-Notes-info-and-tips.html
Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question