Solved

CRViewer.DLL causes IE 6 to crash

Posted on 2006-07-11
9
1,762 Views
Last Modified: 2009-01-15
I have am developing an intranet application serving up Crystal Reports using the CRViewer.dll ActiveX Control (which was working fine up until a few weeks ago).  I, quite honestly, am not sure what has changed on my pc other than the MS ActiveX compliance updates.  

Anyway!  I now try to view my reports and each time the viewer is instantiated, I receive a Microsoft IE error:

=====================================================
Internet Explorer has encountered a problem with an add-on and needs to close.

The following add-on was running when this problem occurred:

CRViewer.dll
=====================================================


I can upload the scripts & reports to my clients computer and the viewer works perfectly and I can see that all is fine with my report structure, queries, etc.  But am getting very annoyed that I cannot test the results of the reports locally...  Has anybody had such a problem??  

Any help would be GREATLY appreciated!!!

Thanks in advance.
0
Comment
Question by:tctekkie
  • 4
  • 4
9 Comments
 
LVL 42

Expert Comment

by:frodoman
ID: 17090145
Have you tried removing the viewer and letting it reinstall?  IE plugins do sometimes get corrupted and that's generally the only way to correct them.
0
 
LVL 4

Author Comment

by:tctekkie
ID: 17090352
Yes.  I've tried removing it and letting it reinstall.  The DLL isn't corrupt as I can move it to another XP Pro machine and it works perfectly.  Am stumped by this one...

0
 
LVL 42

Expert Comment

by:frodoman
ID: 17093310
Odd - it sounds almost like it's an IE problem more than a Crystal problem - I assume both XP Pro machines are at SP2?  Is there anything different about the configuration that could be the source of the problem?  
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 4

Author Comment

by:tctekkie
ID: 17093389
Hi thanks for your response.

I wasn't sure if it was IE or CR so I posted here hoping that perhaps somebody could point me to some sort of config file that may have changed.

Both XP Machines are @ SP2 and are configured almost identical!  

That's why I'm baffled by this.  

I will put a Support Ticket into Business Objects to see if they can come up with some solution.

I've downloaded all of their hotfixes, etc. but with no luck.

Thanks... :)
0
 
LVL 42

Accepted Solution

by:
frodoman earned 500 total points
ID: 17093568
The only other thing that I can think of at the moment would be to check the Event Logs and see if there is anything in there that might give a better clue of the root cause.  I'll also make a separate post and see if I can get some of the other experts to take a look at this thread.

frodoman
0
 
LVL 4

Author Comment

by:tctekkie
ID: 17093599
I will do that Frodo.  Thanks for all of your help!

0
 
LVL 4

Author Comment

by:tctekkie
ID: 17429385
Sorry about not responding sooner but have been out of commission for awhile!  Regardless, this now works!  Thanks for your help frodo.
0
 
LVL 42

Expert Comment

by:frodoman
ID: 17430714
Glad you've got it working.

Cheers
0
 

Expert Comment

by:Bagur
ID: 23386897
Hi tctekkie,

Can you please tell me how you resolved this issue? We are having the same issue on our side and any input is greatly appreciated.

Thanks,
Bagur
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question