Connecting to Notes/Domino Mail


I'm in the process of moving to my own Domino Server from hosted Domino solutions. Over the weekend I set up the Server and created a mailbox (Registered a user) to use Lotus Notes Mail. The server seems to be working fine and I sent an email to the mailbox I created from my gmail account and it seemed to work as I didn't get a Delivery Faliure Notification.
Now I need to set up my Notes Client to connect to this domino server and send and receive from that mailbox. How do I go about doing that? I've only used pop mail with notes client before so this is kind of new.

Thanks in advance:)

Who is Participating?
Sjef BosmanGroupware ConsultantCommented:
Assuming you have the permission to do that, you can just open your mail database on the server. You need the server's FQHN or IP-address, then type Ctrl-O, fill in the server's address and type Enter. If everything is okay and they gave you permission to open the server, you're in. Go to the mail subdirectory and search your mail database. Double-click it to open it.

Now to make it really your mail database, you have to set it as such in your current Location document. Just set the mail server and the relative address of the mail database.

If you already have a notes client installed, then you have two choices:  the way that sjef suggests, which is to drop your mail file onto your client and then create a location document.

First:  I would backup  your pop email stuff, just in case.. pernames.nsf, pop mail database, desktop and bookmarks, etc.

OR: just simply run the notes client reconfiguration wizard.. open Notes, select File>>Preferences>>Client REconfiguration wizard and follow the directions.  

OR: If you need to run the entire set-up utility, then open the Notes.ini file and delete rows 5 through the end of the file.  Save that, and reopen notes.  The setup program will start.

What's the difference?  Well, when you do a complete install, then all the local databases, log, address book, etc., are created for you and you have the correct permissions for them.  When you drop the icon and id onto an installed client, it assumes that the current installation is not only correct, but that you know how to troubleshoot and correct all the little problems, values, that need to be in place for the client to run correctly.

You can use the reconfiguration to change servers, to add pop accounts, etc.  So, you can have both your regular and pop accounts running in your Notes Client.  (I do!).  I just create a different location for each (as sjef suggests)

sjef - note the ease of the wrist as I, very nicely, and with charm, refer to your comments, and add new comments to the question. ;)
Kuljeet912Author Commented:
Hello guys,
Why did I  have a strong feeling that you two will be the ones responding? haha...

Anyway back to business... Well I had already done the first part of what Sjef suggested. I opened the database and I'm receiving mails from outside. But I can't send mails.
I went ahead and edited the location. I selected Send Outgoing Mail through Domino Server.
And aparently it's not working. The server seems to be working properly and I had done the SMTP config as the Help Docs suggested.

Obviously there are a lot of settings and stuff that could have went wrong... but any ideas?
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Where is it stopping?  Is it going from your client to the server but stops at the server, if so, what is the server error message?
Is it not leaving the client?

Do you have SMTP enabled on the server?
Have you configured a foreign SMTP domain so Notes knows where to send SMTP mail?

Does your Notes server have a direct connection to the internet, or did your ISP tell you to relay to their server.. i.e.
Kuljeet912Author Commented:

The mail is stopping at the server.

The error I get:

Router: No messages transferred to AMERITECH.NET <host a itmx4.prodigy.NET> via SMTP: The server is not responding. The server may be down or you may be experiencing network problems. Contatact your sys admin....

Router: Failed to connect to SMTP host AMERITECH.NET because The server is not responding. The server may be down or you may be experiencing network problems. Contact your system admin.....

I'm guessing it's because I didn't set up a foreign domain. I have a global domain setup.  I'm a little confused there.

The server has a direct connection to the internet.
Sjef BosmanGroupware ConsultantCommented:
So there is some progress. Brilliant!

In the Location document, did you also specify the server and the mail database?
- Under Server
    Home/mail server
- Under Mail
    Mail file location = On server
    Mail file = mail\yourname.nsf
    Domino mail domain = ...

Marilyn - so noted ;)
Are you:  or is this your ISP?

If the server has a direct connection to the internet, then you have to set up a foreign smtp domain and a smtp connection document to tell the server how to route smtp mail.

So the server is accepting mail on port 25, but it doesn't know how to send it out.  That requires the two documents:  the foreign smtp domain, and the connection document that tells notes how to route smtp mail.

Do you have those two documents set up on the server?  Also, you will need to add a configuration document on the server that will fine tune your smtp mail and lock out relays, etc.    You should find this under:  names.nsf>>servers>> configurations
Sjef BosmanGroupware ConsultantCommented:
Is the error resulting from the communication between your Notes and the Domino server, or between the Domino server and the ISP??

I assume you use Notes RPC (port 1352) for your mail from Notes to server...
Kuljeet912Author Commented:
Marilyn, is the domain of the email address I'm trying to send the mail to.

I get the same error when i try sending the mail to my hotmail account. The only difference in that error is gets replaced by

I did set up a Foreign SMTP domain last night and a SMTP connection. I'm still getting the error. Perhaps I configured it wrong.

The errors I reported earlier, I saw them at the "console" of the Domino Server. It's running on a Windows 2003 Server and I started Domino Server as an Application so that the command prompt type console comes up. Whenever I click send on my notes client on my laptop and then I look at the server and 2 seconds later It gives me that error. It repeats it (seems like it's trying to send) so that means from Notes my mail is going to the server but it's stopping there?
What do you mean by "between Domino Server and ISP?" because the server is located at data center I'm using Remote desktop to control it. Which means it's connected to the Internet fine.

I'll look at your guys' suggestions from today in detail when I get home and see what I can do:).
Untill then.... Chow.
Sjef BosmanGroupware ConsultantCommented:
> that means from Notes my mail is going to the server

AFAIK, the SMTP domain and connection are not really required if your system has the correct name and the DNS works correctly, but they won't do any harm.

Form your Remote desktop, can you get a Command prompt, and then

Do you get a proper answer to that?
Good suggestion.. think it doesn't have  the open port to the internet.. So, while you may be able to open a web page (port 80) on the server, the outgoing port as sjef suggests may not be open.
Kuljeet912Author Commented:

I did a nslookup from the server's command promp and this is what I got:

c:\> nslookup

DNS request timed out.
       timeout was 2 seconds.
Non-authoritative answer:
Did you also go to and check not only your records but you can see if your mail server is configured correctly, and if you can send a test email from there.

Also, try this configuration utility:,ping

So, when you open on your server, are the two emails you sent still in the mail box?

Can you open your  server document to the PORTS>>Internet Ports>>Mail tab, and check to see if the OUTBOUND SMTP port is configured and enabled, then make sure whatever port is there is open and available on the SERVER side.?

Kuljeet912Author Commented:

I finally figured this out... I had everything set up right the only problem was that data center needed me to send the mail to a relay host. The person I talked to earlier said I didn't need to but aparently I do. Well I set that up and now it's working. Unfortunately I can't say It's working flawlessly:(.

I received the emails at my external email accounts and the "Sender's field" looks something like this:


anyway to fix that? Make it appear just FirstName Lastame?

Thank you guys.

Oh Marily, I should've listened to you earlier:). I know you mentioned the relay host issue at an earlier point. Kudos to you.
Sjef BosmanGroupware ConsultantCommented:
Tha can be configured:
- in the Global Domain document for your server, under Conversions
- explicitly, in your location document
Kuljeet912Author Commented:

I did that. Now my E-mail address shows up in the "Sender's Field". (  I was hoping it shows up as MyFirstName LastName.
Sjef BosmanGroupware ConsultantCommented:
Thanks, but is the problem solved now?

A few lines from the Configuration document:

Internet address lookup:    Disabled
   If disabled or no match, convert as follows:
Local part formed from:    Common name
Domino domain(s) included:    None
Domino domain(s) position:    Left of '@'
Domino domain separator:    . - period
Address example:    "Jane M. Doe" <>

The Internet address in your Location document overrules everything, so you need to leave it empty for the Configuration document to do the work.
Kuljeet912Author Commented:
I have the same settings showed above but in the Address example field it shows I don't understand why. I've tried changing everything.

And my location document has the internet address field is empty.
when you changed the configuration, did you bump the server?
Kuljeet912Author Commented:
Yes, I restarted the whole server.:)
Sjef BosmanGroupware ConsultantCommented:
The last line of the Conversions-tab:
    Address format:     Name and Address
The Router uses the address conversion settings in the Global domain document for outbound mail only in cases where the sender does not have an Internet address defined in the Location and Person documents, or address lookup to the Domino Directory either fails or is disabled.

so, in your configuration document:
 1.      Make sure you already have a Configuration Settings document for the server(s) to be configured.
  2.      From the Domino Administrator, click the Configuration tab and expand the Messaging section.
  3.      Click Configurations.
  4.      Select the Configuration Settings document for the mail server or servers you want to administer, and click Edit Configuration.
  5.      Click the MIME - Conversion Options - Outbound tab.
  6.      Complete the following and click Save & Close:

If you set the:
"Lookup Internet address for all Notes addresses when Internet address is not defined in document"  to ENABLED, then DOMINO is going to look in the PERSON document in the NAB under Internet Address for the internet address.  If one is not there, then it will use the values in the GLOBAL DOMAIN DOCUMENT, if there is no global document, no internet address in the user's location document, then it will build the address based on the shortname + ""

When sending mail Notes looks for the internet name in this order:
Location Document
Person Document
Global Domain Document

In that order, each will override the other.  For example:

If I have in my location document, in my Person Document, and the Global Document set to use:

With lookup enabled on the configuration document, if I send an email it will use:

If I delete the location internet address, then it will use:
If I delete the internet address in the persondoc, then it will use:

Make sense?

Kuljeet912Author Commented:
Thank you mate... I got it...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.