Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 956
  • Last Modified:

Terminal Server running Windows Server 2003 requires an ipconfig /flushdns about once a week.

I am running a Terminal Server with Microsoft Windows Server 2003.  It is in great condition except that about one time a week the server requires us to flush the DNS (or reboot).  We have anotherTerminal Server (TServ2) that does not have this problem and we have narrowed the problem to one server talled TServ1.

What happens is that TServ1 will maintain an internet connection, however about one time a week, its DNS will get jammed, and need to be flushed by going to the command prompt and typing ipconfig /flushdns .  When the DNS is jammed it cannot connect to our Exchange server, and sometimes other servers as well.  TServ1 has two network cards.

Thanks!
0
freddy9000
Asked:
freddy9000
1 Solution
 
oBdACommented:
You probably have an external DNS server specified in the TCP/IP properties of this server. Use only your internal DNS server, and configure forwarders on this one for external name resolution.
0
 
NJComputerNetworksCommented:
make sure DNS is setup similar to this (same type of suggestion already made by obda)

Server DC 1
NAme:  ServerDC1
IP:  10.10.10.5
subnet: 255.255.255.0
Gateway: 10.10.10.1
DNS1:  10.10.10.5 or 127.0.0.1  <--- must point to itself and not to ISP DNS server
DNS 2: Some other internal DNS server in the internal domain ....recommended also to be in the same site if possible

Client IP settings
Name:  Clientworkstation1
IP:  10.10.10.25
subnet: 255.255.255.0
Gateway:  10.10.10.1
DNS1:  10.10.10.5  <--- do not point to ISP ,...must point to local DNS server of the windows domain
DNS2:  some other internal Windows 2003 DNS server....but not to domain.


Why does the TSserver1 have two network cards?  do you have two networks conencted here...or do you have nic teaming enabled?
0
 
bilbusCommented:
sounds like your dns settings on the TS may be registering connection.

When it locks up, ping the TS1 address, i bet you it has changed from the one you set.

Lan card, TCPIP, advanced, DNS, uncheck register this connection.

Do it for both lan cards.

Make a entry in dns for the name of TS1. I bet that will fix it
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now