Can not access published application using Citrix ICA Client on Windows 2003 server

Hello

I have tried posting this question under windows 2003 thinking it's a terminal server connection problem but it may very well have to do with Citirix. I am using presentation server 4 on my windows 2003 server and having problem connecting throught citrix ica client.



I have a Windows 2003 server with TSL installed. I am the member of remote desktop user group and in group policy, I have rights to both log in locally and through terminal services.

When I try to log in using citrix ICA client or  remote desktop through my windows xp machine I get two error messages and I can not log in.

"The desktop you are trying to open is currently available only to administrators; contact your administrator to confirm that the correct settings are in place for your client connection."

Followed by:


To log on to this remote computer, you must have Terminal Server User Access Permissions on this computer. By default, members of the Remote Desktop group have these permissions. If you are not a member of the Remote Desktop Users group or another group that has these permissions, or if the Remote Desktop User group does not have these permissions, you must be granted these permissions manually

The user administrator can log in fine but I don't want any user to be the member of administrator group.



I have installed proper license for both TSL and Citrix presentation server.

Also after unchecking the option under RDP-TCP  ( citrix connection configuration ) for "Only Lauch published applications"

 i was able to connect using remote desktop however i still can not access using citrix ICA client and end  up with both error messages.

Below is the link to my question posted under window server section.

Please help!

Thanks
NM



http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21915470.html

nm6436Asked:
Who is Participating?
 
BLipmanConnect With a Mentor Commented:
Oh, you need to set up a new Application Set, not Custom ICA Connection.  Just hit the "Up Folder" button until it greys out and go in the the Application Set Manager.  I misunderstood your question.  
0
 
BLipmanCommented:
Go into the Citrix Connection Configuration program, go into the properties of each listener (RDP and ICA), remove the checkbox that says "Published Applications Only"

Connection Error : The desktop you are trying to open is currently available only to administrators
http://knowledgebase.citrix.com/kb/entry.jspa?externalID=CTX104106
0
 
nm6436Author Commented:
Thanks, I had already done it for RDP but I have also checked the option for ICA now. I am able to connect however, it opens the desktop not the published application.

How can I get it to open the published application?

Thanks
0
 
nm6436Author Commented:
yes it worked. I have always used custom ICA connection so never thought of using New Application Set.

Thank you so much for you help!

NM
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.