[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 517
  • Last Modified:

Remote desktop on a SBS 2003 VPN connection

I using awindows PPTP VPN to access a network running SBS 2003 without ISA installed.  They are using sonicwall.  

My problem there are about 10 clients at this busniness.   I can access all of them by remote desktop but the strange thing is I can only access some of them by NET bios name the others I have to access by IP address.  I don't see any difference in the machines.   What could cause this?

Wes
0
hmcnasty
Asked:
hmcnasty
  • 2
1 Solution
 
Rob WilliamsCommented:
Name resolution over a VPN can be difficult to get working. The fact that you can connect to some but not others is odd, unless the DNS server is not updating records properly. You might want to check your DNS server to see if all computers have a Host (A) record.
It could also be that the workstation from which you are working has cached some of the host records. Running at a command line (case sensitive):
  nbtstat  -c
should list the name cache. See if that corresponds to the computers you can connect to.
Or....run
  ipconfig  /flushdns
  nbtstat  -R
to flush the name cache and DNS as a test. After this if you cannot connect to any by name you will now that the names were cached.

A few other options you may want to look at for name resolution:
1) An option is to use the LMHosts file which creates a table of IP's and computer names. LMHosts is located in the Windows directory under c:\Windows (or WINNT)\System32\Drivers\Etc\LMHosts.sam , instructions are included within the file. Any line starting with # is just a comment and is ignored. Open the file with Notepad and add entries for your computers as below;
192.168.0.101      CompName       #PRE
Hit enter when each line is complete (important), then save the file without a file extension. To be sure there is no extension ,when saving enclose in quotations like "LMHosts". Now when you try to connect to a computer name it should find it as it will search the LMHosts file for the record before connecting.
More details regarding LMHosts file:
http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/windows/2000/server/reskit/en-us/cnet/cnfd_lmh_QXQQ.asp
The drawback of the LMHosts file is you have to maintain a static list of computernames and IP addresses. Also if the remote end uses DHCP assigned IP's it is not a feasible option. Thus in order to be able to use computer names dynamically try to enable with some of the following options:
2) if you have a WINS server add that to the network cards configuration
3) also under the WINS configuration on the network adapter make sure NetBIOS over TCP/IP is selected
4) try adding the remote DNS server to your local DNS servers in your network card's TCP/IP configuration
5) verify your router does not have a "block NetBIOS broadcast" option enabled
6) test if you can connect with the full computer and domain name as  \\ComputerName.domain.local  If so, add the suffix DomainName.local to the DNS configuration of the virtual private adapter/connection [ right click virtual adapter | properties | TCP/IP properties | Advanced | DNS | "Append these DNS suffixes (in order)" | Add ]
0
 
Rob WilliamsCommented:
Thanks hmcnasty,
--Rob
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now