Solved

Arcserve backup failed question

Posted on 2006-07-12
13
3,860 Views
Last Modified: 2008-12-29
I am new to ArcServe (use Veritas mostly) and am a little confused. In one instance my backup job completes with a status of INCOMPLETE (i understand this, it cant get to a few files etc), the next day the backup job finishes with a status of Backup Operation Failed but the job log looks identical to the one that finished INCOMPLETE. Granted the log is big and i did not compare every single line, but both complete the VERIFY operation ok. It is just the status at the end.

I can also restore files from the session that "Failed"

Thanks for any explanations.
0
Comment
Question by:dolphan2013
  • 6
  • 3
  • 2
  • +1
13 Comments
 
LVL 11

Expert Comment

by:Renato Montenegro Rustice
ID: 17089536
Try to compare the very last lines in the job log pane. There you have the totals.

When a job is classified as FAILED, is because something bad happened. Search Activity Log for more information. Look for the errors (red icons). The yellows shows what causes an incomplete job.

Note that you must enable logging on the job to populate Activity Log.
0
 
LVL 22

Accepted Solution

by:
dovidmichel earned 125 total points
ID: 17091183
A typical reason for a Failed status is a missed target. Such as when a workstation was shut down. That type of thing is easy to miss in the log. Easy way to check this is to compare the number of sessions backed up. Also just comparing the # of directories and megabytes backed up will provide a general idea if all the data has been backed up.

Also when backing up a database there are usually several sessions for the one database and it can be easy to miss it when one of those sessions and the rest worked.

You can also try doing a search through the activity log for failed. The file name is either arcserve.log or brightstor.log depending on the version used, and is located in the log subdirectory under the ARCserve home directory.

Updating is also a good idea. If you provide the ARCserve version I'll give you the link to the download page.
0
 
LVL 16

Assisted Solution

by:gurutc
gurutc earned 125 total points
ID: 17092679
Another thing you can do is to run a merge operation on the tape with the failed job.  It update the ArcServe Database with everything that is truly on the tape.  So when you want to restore from the session, ArcServe will only show you what's really there on the tape to restore.  

In my experience ArcServe 'fails' a job if the wind is blowing from the East instead of the West.  Or from bad planetary alignment.  I have had good luck restoring from 'failed' jobs.  But it is better to track things down.  What are you backing up?  Does it include Exchange Server?  That type of data, for instance, is a notorious source of spurious 'failed backup' error messages.

- gurutc
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 17093023
No need to Merge the data on tape that is done automatically at the end of the job, and running a Merge job will just repeat that same operation.

As for wind direction and planetary alignment effecting jobs, I have not notice such behavior. Perhaps that is because my clients have their servers in a server room instead of in the back yard.

Status Failed - indicates the job failed to backup a target
0
 
LVL 16

Expert Comment

by:gurutc
ID: 17093374
True, the backup contents are merged to the database, but unless you run verify, those content records may be inaccurate.  After the fact, a merge will tell you what's truly on the tape and if it is readable.

How did you know where I kept my servers?

- gurutc
0
 
LVL 16

Expert Comment

by:gurutc
ID: 17093390
Also, 'failed' sometimes means the end-of-job merge bombed...  And CA hasn't made detecting this type of failure 'user friendly.'


- gurutc
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:dolphan2013
ID: 17095995
I just tried to "merge" and got this error when it failed:

"Invalid session header signature"

In the log file of the failed bakup operation I notice a couple of things:

There are a lot of these entries trying to backup a volume on a linux box

AE9033 Failed to open file /sys/bus/pci/drivers/e100/new_id

AE9131 File /sys/bus/serio/drivers/atkbd/description is truncated ( 4096 -> 28 ) on the WS

On a windows box i am getting on multiple files:

AW0004 Failed to open file <C:\NTDETECT.COM>. RC=5, Access is denied.  

AW0004 Failed to open file <C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys\c5f877f3a3d13a69fcad919970aaf24a_2d13b326-e94f-4c98-9127-d2799cb999b0>. RC=5, Access is denied.

This is the last 3 entries in the log:


[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Job No....................... 1
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Job ID....................... 17
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Workstation.................. Computer1
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Source....................... TUESDAY, ID 6E9A, Sequence #1
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Session...................... 34
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Target....................... C:\Program Files\CA\BrightStor ARCserve Backup\DATABASE
[07/12/2006-01:13:26 ,0,0,0,0,0,2,0,0,0] Start Time................... 7/12/06  1:13 AM
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Total Directories............ 1
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Total File(s)................ 691
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Total Skip(s)................ 0
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Total Size (Disk)............ 754.76 MB
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Total Size (Media)........... 756.87 MB
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Elapsed Time................. 4m 41s
[07/12/2006-01:18:06 ,0,0,0,0,0,2,0,0,0] Average Throughput........... 161.60 MB/min
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0]


[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Totals For................... Job
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Session(s)............. 28
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Directories............ 73,783
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total File(s)................ 28,764
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Skip(s)................ 0
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Size (Disk)............ 6,453.22 MB
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Size (Media)........... 6,685.00 MB
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Elapsed Time................. 46m 52s
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Average Throughput........... 142.63 MB/min
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0]


[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Totals For................... Job
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Session(s)............. 34
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Directories............ 72,471
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total File(s)................ 28,881
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Skip(s)................ 515
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Size (Disk)............ 6,451.65 MB
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Size (Media)........... 6,673.62 MB
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Elapsed Time................. 53m 30s
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Average Throughput........... 124.74 MB/min
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Total Error(s)/Warning(s).... 94/1,696
[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0]


[07/12/2006-01:18:07 ,0,0,0,0,0,2,0,0,0] Backup Operation Failed.


Thanks
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 17096674
I'm not up on Linux enough to know if it is normal or not to have a problem with files in the drivers directory.

For the Windows systems make sure the backup user is a member of the Backup Operators Group.

So you have 94 errors and 1,696 warnings.

I said it before and I'll say it one more time, updating is a good idea. Lunux Client Agents are listed under the UNIX version page.
0
 
LVL 16

Expert Comment

by:gurutc
ID: 17098070
Hi again,

Are you using the Client Agents on the machines you're backing up?  These agents are especially important for backing up Linux boxes, which I think CA regards as 'servers' in the grand scheme of charging for licensing.  But the real benefit of using Client Agents is that they speed up the backup jobs tremendously.  I've had the use of Client Agents quadruple the performance of my backup jobs in some cases. Also the Open Files Agents are pretty important as well.  Without them, jobs will fail due to missed files one day and work fine the next on any type of machine you are backing up.  You could try excluding the folders that hold the missed files or specifically excluding missed files if they are the same ones over and over.  

About the 'invalid session header signature'  that one is a little more tricky.  This has happened to me most often when the tape drive needs cleaning, the tape media is getting worn out, or when I'm using File System Devices with ArcServe.  What kind of tape drive are you using? Are the tapes nearing their Service Life Limit?  Can you isolate the failures to specific tapes?   What OS is on the Tape Backup Server?  And finally, what version of ArcServe are you using and is it fully patched?  This last issue is very important because OS Security Updates and Patches, particularly Windows ones, periodically play havoc with the low-level interaction between the various ArcServe Service Components and the Protective Secuirity Features of OSes.  I check weekly supportconnect.ca.com for ArcServe patches.

Having to update the ArcServe software often is an indication of two things that support my endorsement of ArcServe:

1. ArcServe accesses file systems and hardware at the lowest level possible to provide the best speed and recoverability.
2. CA is on the ball and keeps a team of engineers working to ensure their product maintains compatibility with the rapid pace of OS updates.

I'm looking forward to any answers you can post to my questions.

- gurutc
0
 
LVL 16

Expert Comment

by:gurutc
ID: 17098087
I forgot to ask, what is the complete error message text for the 'invalid session header signature' message.  Please post the Error Code which is usually a letter followed by a number like 'E3801'.

- gurutc
0
 
LVL 16

Expert Comment

by:gurutc
ID: 17599620
Interested - gurutc
0
 

Author Comment

by:dolphan2013
ID: 17628647
My apologies for the long delay. Both of your answered help me. The resident linux expert helped me figureout that the Linux files that were not backing up were virtual files that the kernal uses. I had to exclude them.

Regards
0

Featured Post

How to Backup Ubuntu to Amazon S3

CloudBerry Backup offers automatic cloud backup and restoration for Linux. It has both GUI and command line interface (CLI) ensuring its flexibility in use. Find out more

Join & Write a Comment

Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now